We help IT Professionals succeed at work.

Unable to Deploy Microsoft CRM 4.0 Email Rules

JoyCara
JoyCara asked
on
Medium Priority
1,271 Views
Last Modified: 2012-05-06
I'm trying to deploy email rules to a new CRM 4.0 org and when I run the deployment wizard keep getting the error "Failed to create a MAPI profile for the user" and the following debug info info:

<ExceptionInfo>Microsoft.Crm.Tools.ExchangeConnectorDeployment.RuleDeploymentException: Failed to create a MAPI profile for the user. ---> System.Runtime.InteropServices.COMException (0x8004010F): Failed to create a MAPI profile for the user. --- End of inner exception stack trace --- at Microsoft.Crm.Tools.ExchangeConnectorDeployment.RuleDeploymentSession.SendCommand(String command, String exchangeServerName, String exchangeStoreDn, String exchangeSystemDn, String exchangeMailboxDn, String crmEmailAddress, Boolean disabledMode, RULE_STATUS& ruleStatus) at Microsoft.Crm.Tools.ExchangeConnectorDeployment.RuleDeploymentSession.DeployRule(DirectoryEntry userDirectoryEntry, String crmEmailAddress, Boolean disabledMode) at Microsoft.Crm.Tools.ExchangeConnectorDeployment.RuleDeploymentRequest.ProcessNext()</ExceptionInfo>

The user logged in running the deployment wizard is a domain admin, has full exchange admin privledges, and is an admin user in CRM.
Comment
Watch Question

Commented:
Where is the Rule Deployment Wizard installed?  What version of Exchange?
Where are you getting this failure? (which screen)

Author

Commented:
Rules deployment wizard is installed on the Exchange server with the email router.  We are running Exchange 2003 Standard that is up to date with SPs and patches.  The error first shows up after I select the users that I want to deploy the rules to.  The wizard finds all the mailboxes fine, and then I select them and if I choose any option in the wizard (add, remove, or verifiy) and click next each user displays the message "Unable to create a MAPI profile for the user"  When the wizard ends it dumps the error message above into an xml file for each user.
Commented:
This was a problem also in CRM 3.0 where the router is creating the mapi temporarily, but the directory doesn't exist that it wants to use.  so:

1.      On the server that is running Microsoft Exchange Server, click Start, click Run, type regedit, and then click OK.
2.    Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Messaging Subsystem
3.    Click ProfileDirectory, and then note the location. By default, this location is the following folder:
C:\Temp\Exmppd
4.    On the File menu, click Exit.
5.    In Windows Explorer, locate the folder that you noted in step 3, and then do one of the following:
"    If the folder exists, verify that the user who is running the Rule Deployment Wizard has Read permissions and Write permissions to the folder.
"    If the folder does not exist, create the folder on the server that is running Microsoft Exchange Server.
6.    If you had to create a folder in step 5, verify that you created the folder in the same location that is indicated in the ProfileDirectory registry entry. To do this, follow these steps:
a.     Click Start, click Run, type regedit, and then click OK.
b.     Locate and then click the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Messaging Subsystem
c.     Click ProfileDirectory, and then view the location that appears. Make sure that this location is the same as the location of the folder that you created in step 5.
d.     On the File menu, click Exit.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Awesome, worked perfectly.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.