We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Screen resolution problems in Ubuntu

Medium Priority
910 Views
Last Modified: 2013-11-15
Background:
I am running Linux Ubuntu and
I changed my screen resolution 1 time from 1280x1024 to 1024x768 to troubleshoot a web page issue.  Anyway, when I went to set it back to 1280x1024, the option was no longer available.  I did this through system - preferences - screen resolution .. When I rebooted the computer, it came up with a display of 800 x 600 and only had resolutions lower than that available to change to.  

Then I decided to activate the nvidia accelerated graphics version 177 .. That worked fine for a couple days at 2180x1024 until I rebooted.  It came up at 1024x768 without the option to change to 1280x1024 ... So I rebooted again and it went to do 320 resolution with only 1 option available and it was lower than 320!! ...

I had to downgrade the driver and upgrade back to 177 to get the screen resolution to 1024x768  ... The 1280x1024 is still not available .. I have 1152 x 864 and 1320x768 but not the one I want 1280x1024

Help??

Thanks!!
Comment
Watch Question

Commented:
In a terminal, type:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo dpkg-reconfigure xserver-xorg

Then restart your X server by hitting CTRL + ALT + BACKSPACE.

Hope this helps.
Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
If you are using Ubuntu 8.10, the correct sintax to reset xorg server to default configuration is:

sudo dpkg-reconfigure -phigh xserver-xorg

Author

Commented:
After completing those steps, I can not choose a resolution above 800x600.  
Freelancer
CERTIFIED EXPERT
Commented:
Now you need to choose the right driver. If you go to System->Administration->Hardware Driver, does the system list some restricted driver to install? Which is your graphical video card?

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Well now I have a serious problem.
I enabled the nvidia x server by running sudo nvidia-xserver and restarted the xserver using ctl alt backspace... Now all I have is a black screen that says "can not display this video mode" ..
Is there a keyboard command I can execute or some kind of safe mode I can boot into?

I have already reboot and I am unable to access the machine through vnc.
Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
sudo dpkg-reconfigure -phigh xserver-xorg
Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
What model of nvidia card do you have?

Author

Commented:
How can I run that command if I can't see the screen?
Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
You asked for a keuboard command... You need to enter into the terminal safe mode at boot.

Author

Commented:
It's an onboard chipset , the motherboard book says nvidia mcp61p/mcp61s  .. that is the closest thing it has to a model.

Author

Commented:
Im a linux newb here ... How do I get to a terminal safe mode at boot?
Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
lspci | grep VGA

should give you the right video card
Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
You should have a "recovery mode" entry in your boot menu

Author

Commented:
Ok, I am back, chose fix xserver from recovery mode.....Thanks

Here is the video card
 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)

I just activated version 177 of the driver again and I will reboot to see what happens.


Author

Commented:
I am back to 1024x768 but still no 1280x1024 option.  This is strange considering 1280x1024 was the default resolution when I installed Ubuntu.  


Fabio MarzoccaFreelancer
CERTIFIED EXPERT

Commented:
Try running:

sudo nvidia-settings

(if you don't have that pakage installed, first : sudo apt-get install nvidia-settings)

Author

Commented:
The nvidia settings show the same resolutions.  Still no 1280x1024  ... Is there a command to manually set the resolutions?
Gns
Commented:
Well then, the "driver" you've chosen simply cannot do what you want, so ... stop using that then:-).

The manual way of configuring things are through editing the xorg.conf file directly, which requires a bit of knowledge (or man-page reading) and text editing skills. On Ubuntu, things like that might be frowned upon:-):-)

I'd suggest you try with another driver first... Like the plain "nv" one. Does that give you what you want?
(It sound like the init scripts go whacky when trying to autodetect things for you...)

Cheers
-- Glenn

Author

Commented:
Thanks Glen ..  What you say makes sense, except for the fact that I was using 1280x1024 with this driver for over a month.  In addition, the default generic Ubuntu driver on a fresh install, defaulted to 1280x1024, and now even that driver does not show that resolution option.  I hate to be difficult, but there is something being overlooked here.
Gns

Commented:
Probably true, that something is getting overlooked:-)

In your xorg.conf, what frequencies do you have for your monitor? Colour depth (bits) used? That, and the amount of video RAM, would put a cap on how large a resolution you can get... Could be something funky with your video bios, of course:-)...

Cheers
-- Glenn

Author

Commented:
Well, I wen to the oldest nvidia driver available, version 96 and everything is working great now.  Thanks !
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.