Unable to add disk in windows cluster 2008 from MSA1500

Posted on 2009-02-17
Last Modified: 2013-11-14
I'm unable to add any cluster disk to a new cluster I'm forming.  Everytime, it ends up with the following error:

Creating the physical disk resource for 'Cluster Disk 1'.
Bringing the resource for 'Cluster Disk 1' online.
Unable to cluster 'Cluster Disk 1'. An error occurred while attempting to bring the resource 'Cluster Disk 1' online. The cluster resource could not be brought online by the resource monitor.

There's currently two servers (both running Windows 2008 Enterprise x64) in that specific cluster and either of them can add drives succesfully.  The drives can be seen normally in the OS before trying to add it as a cluster disk, but afterwards, it's stuck as "Reserved".

These drives are on a MSA1500, and both MSA1000 controllers are running firmware 5.20.

On that same NAS, there's a running cluster composed of two Windows Server 2003 R2 Enterprise x86, which is running fine.
Question by:Télé Québec

    Author Comment

    by:Télé Québec
    This is still an issue .. is my question lacking information or simply not under the correct categories ?
    Anyone else experienced something similar ?
    LVL 55

    Expert Comment

    It's in the right category but I don't think anyone knows the answer. Nothing about the problem on HP's forums where you'd expect to find anyone else with the same error message.

    Author Comment

    by:Télé Québec
    Aye, I'm suspecting a firmware issue, as there's some difference (from the hours googling around) concerning PR (Persistent Reservation).

    Author Comment

    by:Télé Québec
    Still no solution, I guess I'll just revert to 2003 R2 for now since I need the cluster.

    Expert Comment

    As of Windows Server 2008, you cannot use parallel SCSI to connect the storage to the clustered servers.


    LVL 55

    Accepted Solution

    It's not parallel SCSI attached, it's fibre channel.
    There are Windows 2008 clusters using MSA1000/1500 active/active listed on Spock, but no active/passive ones which is what firmware 5.2 provides. See - you have to sign up but that's free.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    The problems with reply email signatures

    Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

    Problem description :  Some external hard disks / USB flash drives do not show actual space as mentioned in the factory settings. This is a common problem when you use an 8 GB USB drive to make it bootable to install a firmware/ driver on a serv…
    Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
    To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
    This tutorial will walk an individual through the process of upgrading their existing Backup Exec 2012 to 2014. Either install the CD\DVD into the drive and let it auto-start, or browse to the drive and double-click the Browser file: Select the ap…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now