We help IT Professionals succeed at work.

Performance and Memory issues on Sql 2000 running Windows 2003 Enterprise R2

Medium Priority
Last Modified: 2012-05-06

We upgraded to new hardware this weekend and a new OS on our Sql server Database system.  We moved from Windows 2000 running Sql Server 2000 databases and moved to WIndows 2003 Enterprise 2003 R2 running Sql Server 2000 and named the machine the same name and same IP address and ported the databases over to the new system.   We believe we could be having memory leaks or issues but not certain.

We are currently running on a IBM 3850 with a DS3300 for storage and our 3850 is configured as follows.

Windows 2003 Server Enterprise R2 at Sp2
Sql server 2000 at SP4
Boot ini switch we have 3GB and PAE enabled.
13.7 GB max memory for sql
16 GB Ram on server
paging = 48GB  
We also are running Trendmicro Officescan version 8 with exclusions.

Does anyone know of anything that we might be missing or have overlooked in this configuration or something else we might check.  

We have about 500 processes at any one time running on the system.

Thanks for your help

Watch Question

Distinguished Expert 2019

You do not need the /3GB switch since you are not using AWE.
Since you do not have Enterprise version of SQL, you can not use AWE.
Check the advanced settings under properties of my computer, performance settings\advanced should be processor and memory priority for application rather than background services.
You can also get the Server Performance adviser and run tests to see where your performance hit is.

How big is your database?
You can use perfmon to look at memory and processor performance to see whether the hit is coming from swapping memory (paging)



I forgot to add that we are using Sql Server 2000 Enterprise edition.

Also the database is about 52 GB in size.

Distinguished Expert 2019

Setup SQL to run with AWE. Note you should first double check that all the updates to your sql 2000 EE are applied including the hotfix dealing with AWE from the links below. Make sure the user used to run sql has lock pages in memory rights.
Remove the /3GB from the boot.ini
Hotfix SQL 2000 SP4 might be outdated:

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.