Troubleshooting external mailflow from Exchange 2003 to Exhcange 2007

Hello Experts,
I have an exchange 2003 box that sends and receives mail from a smarthost (Postini). We recently added a new server with Exchange 2007. I ran the required setup.com /prepareAD and everything installed properly. Last night I moved a mailbox to that server (2007) and when I came in this morning he could send and receive internal mail, could send mail externally but cannot receive mail from outside.
Now the 2003 server is set to be the primary server, and all mail from the 2007 is routed through the 2003 box.

So upon doing some searches I tracked some messages flowing through the 03 box to the 07 box and according to the 03 box is is handing them off, but when I look in the queue the messages are still sitting in there. I don't see any errors, or more to the point I'm not sure what I should be looking for as to why the messages are still sitting in the queue.

So I tried to telnet to the new server from my personal workstation and I get a response from the server, I say helo it says hello back, I enter Mail From: me@domain.com and it returns "530 5.7.1 Client was not authenticated", but when I run it from the server it appears to work ok and the recipient does in fact get the message.
If I try to make the Mail From: my gmail address it returns " 425 4.3.1 Insufficient system resources"

So any help is appreciated.
LVL 1
js479Asked:
Who is Participating?
 
js479Connect With a Mentor Author Commented:
So i found that C drive of the new server only had about 700MB of free space and I think that may have been an issue. I've moved the database and log locations for just about everything to another drive with plenty of space. I'm in the process of moving a mailbox back to my 03 exchange server and then I'll install update rollup 5 to see if that corrects an issue I just started having with my transport service. I was getting a .NET 2.0 error with the edgetransport.exe file and it won't start now. MS has the error listed and claims rollup 5 will fix it.  So that's where I am right now, hopefull y the space issue was the thing preventing communication.
0
 
js479Author Commented:
Couple more bit of information to help someone diagnose the issue here, there is NO smarthost set in the virtual SMTP server, there is one in the SMTP connector.
0
 
MesthaCommented:
Have you made any other changes to the SMTP virtual server to work with Postini?
Authentication settings for example? Or connection restrictions. The SMTP VS on the original server is where the problem is.

-M
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
js479Author Commented:
Other than connection restrictions I don't believe so. I had already added the new exchange ip to the allowed list though. So here are my settings for the SMTP virtual server.
Authentication:
Anonymous access checked
Resolve anonymous email unchecked
Basic authentication checked
requires TLS encryption unchecked
default domain - blank
Integrated windows authentication checked

Connection:
All except the list below, and there are no entries in the box.

Relay Restrictions:
Only the list below, here is where my IP ranges for Postini are listed as well as several computers in the domain including the internal IP of the new exchange server.
0
 
MesthaCommented:
You don't need the Postini servers listed in the relay restrictions. If Postini want you to restrict to their servers only then that would be set on the Connection settings. Although personally I prefer to place the restrictions on the firewall, rather than on the server itself. Avoids these sorts of problems I find.

-M
0
 
js479Author Commented:
The restriction is there because we use postini for outbound filtering as well. So we want all outbound mail to go through postini.

Do the settings of the SMTP VS look right? I'm still tracking down some issues here but so far nothing.
0
 
MesthaCommented:
Even though you use Postini for outbound email, you do not need them listed in the relay settings. You do not need any server listed in the relay settings - just set the Postini server as your smart host in the SMTP connector.

The settings look correct going by what you have posted.

-M
0
 
js479Author Commented:
I'm going to uninstall and reinstall. Thanks for the effort.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.