We help IT Professionals succeed at work.

Out of Office Settings Cannot be Displayed

pzozulka
pzozulka asked
on
Medium Priority
2,393 Views
Last Modified: 2012-05-06
"Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later."

This is an error message received from one of our users. He said he cannot turn off his Out of Office assistant. I then tried access my OOF, and same error message.

Did a brief search, and ran this command in Exchange Power Shell: Test-OutlookWebServices

Results:

Id: 1003
Type: Information
Message: About to test AutoDiscover with the e-mail address MagicianB@Domain.com.

Id: 1007
Type: Information
Message: Testing server martini.bcr.local with the published name https://mail.domain.com/EWS/Exchange.asmx & .

Id: 1019
Type: Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://mail.domain.com/Autodiscover/Autodiscover.xml.

Id: 1013
Type: Error
Message: When contacting https://mail.domain.com/Autodiscover/Autodiscover.xml received the error The remote server returned an error: (401) Unauthorized.

Id: 1006
Type: Error
Message: Failed to contact AutoDiscover
Comment
Watch Question

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
In Exchange Management Shell:
* Remove-AutoDiscoverVirtualDirectory Identity AutoDiscover (default web site)
* New-AutoDiscoverVirtualDirectory
After you run New-AutodiscoverVirtualDirectory, you will notice an error. Simultaneously you will also notice the WWW service crashing. Wait for it to STOP.
Next, STOP the IIS Admin Service, along with HTTP SSL.
Next, try running New-AutoDiscoverVirtualDirectory. <-- It should now successfully create AutoDiscover.
Start the following services: WWW, IIS Admin Service, and HTTP SSL.

Author

Commented:
Thanks for trying, found my own solution below.
Here is what worked for me:

The problem everyone is describing ultimately leads to outlook not knowing how to get to the autodiscover settings of Exchange 2007.
I noticed that our home user's (who is not on our domain) outlook was trying to go to "autodiscover.{domain}.com". This was trying to
resolve to our web server since "*.{domain}.com" is usually setup on DNS servers as a catch-all for websites.

I added an alias in our DNS server "autodiscover.{domain}.com" and pointed it to the EMail server specifically.

I then flushed the user's DNS and tested with a ping to verify it was resolving to the email server first.
Started up outlook and Out Of Office worked perfectly! It did prompt her for her login/password upon first
starting outlook since she is not a domain user, but after supplying the credentials, she was working without a hitch!

The above is much easier than most other steps I've seen in other links and resolves the ultimate issue that outlook is trying to find
"autodiscover.{domain}.com" and can't.

~ Raestlin
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.