"A disk read error occurred, Press Ctrl+Alt+Del to restart" on HP notebook - hd is NOT defective

I have an HP nx6310 notebook that suddenly refuses to boot. After the BIOS self test stuff has passed, it takes about 5 seconds and should then start Windows, but instead it displays the above error message. The harddisk is definitely not the problem, as I could read it fine in another PC and image it. I have then replaced the harddisk and restored the image in the problem-notebook, followed by a checkdisk in a PE environment, all without any errors. PE can also see the contents of the drive without problems. The problem is in all cases the above error message.

As the notebook can technically read the drive, loose cables etc can be excluded - also because there aren't any cables attached to the drive, as it snaps right into a connector on the motherboard.

Setting the BIOS to fail-safe parameters doesn't change anything.

I have searched the knowledgebase here, but all the numerous issues concerning the same error message either did not get resolved or were indeed caused by defective harddisks, loose cables, etc.

Can anybody give me a hint here? Hewlett Packard has so far been of no help.

Thank you and best regards,

Thomas
StaudteAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
StaudteConnect With a Mentor Author Commented:
I have fixed the issue now. After giving up on any "soft" recovery attempts (including removing the cmos battery, which sits below the keyboard), I startet to reformat the drive and reinstall Windows. Worked fine until the first reboot during the installation process, which failed (with native SATA enabled and without). Thus it was clear that it was not a software issue, as I had expected. As a last resort I installed a firmware update and this solved the issue. Even the disk that was originally installed and that suddenly stopped booting worked again immediately.

I am awarding andereporter some points because of his time, patience and good intentions :-) Thank you!
0
 
StaudteAuthor Commented:
Glenn,

thanks for the quick reactions, but I've been to these pages - they are a total of 27 very long pages full of repetitions of

a) questions, repeats of the above
b) answers that do not relate to my case here, because the drive is SATA, has no cables and is definitely NOT defective, and changing the BIOS to failsafe doesn't help either (well, why should it, because it's never been changed from failsafe anyway).

I should, however, add that I have also done the fixmbr and fixboot things, ran full chkdsk against both drives (the original and the newly cloned one) and had no problems whatsoever - with the exception that the system won't boot.
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
andeporterCommented:
The quick fix for you would be to go into the BIOS >> System Configuration >> Device Configurations
From here, change the SATA native mode option to disable. Save changes and exit.

The real "fix" is a bit more complicating/time consuming.

It took me forever to find this fix when I ran into this problem ghosting SATA HDD's for HPs.
0
 
StaudteAuthor Commented:
Hi Andeporter,

sorry, no matter if I set SATA native mode to enabled or disabled, the problem remains the same - same error message. In both modes I can access the drive from a PE environment.

What was your "real fix"?
0
 
andeporterCommented:
I'm trying to remember back when I had this similar problem. The issue was that the HDD (after being ghosted) did not contain the SATA driver needed to make the HDD function properly again (One of HP's little tricks to make admin difficult I suppose)

The one you would need creates a disk to use to get the HDD up and running again. It's located here:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=321957&prodSeriesId=1839143&prodNameId=1839164&swEnvOID=1093&swLang=8&mode=2&taskId=135&swItem=ob-39535-1

Keep me posted....and let me know.
0
 
ridCommented:
Just to make sure I understand you correctly: The HD is behaving flawlessly if connected to another system (OK on all tests and contents readable), but you get the read error at all times when it is in the laptop? Did you try booting the laptop with a bootable CD and then browse the HD? Did it work?

Could be a controller issue in the laptop.

Did the problem occur totally out of the blue? Nothing done (physically) to the unit before the error started to show? (re-seating the HD or optical unit, or adding a new PC-Card or a new mouse or something at all)

Did you try resetting CMOS?
/RID
0
 
StaudteAuthor Commented:
You are pointing me to the F6-driver that is needed so that Windows setup can detect the harddisk to start with. This is not needed here for three reasons:

1. The system worked before. It was just shut down because the batteries ran empty and when connected to a power supply, it didn't come up anymore. So the system was completely installed and all drivers were in place.
2. The system doesn't even get as far as loading any drivers. If the drivers were missing, it would likely bluescreen to a stop 0x7b, but there's simply no trace of Windows starting
3. I just started a Windows setup and it detects the harddisk without the need for an F6 driver. (This is because I have disabled native SATA before. With native SATA enabled I need the driver.)

What is odd though, is that Windows setup didn't find the previous Windows installation - it just found the partition where Windows is installed, so I can't simply do a repair installation. Apparently, there's something wrong with the partition structure, the Windows installation, or something thelike. BTW, the partition is NTFS.

This is pointing more and more into a "software" issue, i.e. somehow the organization of the drive/partition/Windows installation is corrupt.
0
 
andeporterCommented:
I misunderstood the fact that it was intact and working correctly.
So what happens if you drop another hard drive in your laptop...do you get the same error?

You could try hooking up the HDD slave to a desktop PC and running fixboot/fixmbr.
I checkdisk while hooked up as a slave may work too,I have had success at this before.
0
 
StaudteAuthor Commented:
@Rid,

my comment to andeporter overlapped your response somewhat, so I'm might be repeating myself. But just to be clear:

Both HDs (original and clone) are working fine (except they don't boot) in another AND in the problem-notebook (when booted from a PE-Windows boot-CD). Contents are fully readable, chkdisks run without errors. The only that happened between the working and the dead notebook was that the batteries ran empty, the system was shut down for a minute, the power supply connected and the system booted up again. (Well, it didn't boot anymore...)

I wouldn't know how to reset the CMOS on a notebook... loading the failsafe parameters didn't change anything.
0
 
StaudteAuthor Commented:
@andeporter:

Please check my initial post - I have already tried two HDs (the original and a brand new one with the cloned data). I have run chkdsks on both another PC (with the hd attached via USB) AND within the problem-PC - both complete without any errors.
0
 
andeporterConnect With a Mentor Commented:
I'm convinced that if you try using the SATA driver provided by HP it might work. I see your 3 reasons above and I'll rebuttal with:

1. Drivers get corrected, especially w/ power issues being involved.
2. The POST/hardware test is completing successfully or you would most likely get POST error codes.
3.  I'de have to agree here except I have dealt w/ the exact same issue. I've seen it detect an HDD but not know how to use it.

I don't know....just trying to help. Keep us posted.
0
 
StaudteAuthor Commented:
@andeporter

Ok, I'm not refusing to use the F6 driver - but how? This is only requested during installation; I can't simply insert the disk at the current stage. Next problem is - I don't have a disk drive for the notebook. I recall that I had the same problem a while ago (same as you had with HP HDs and F6 drivers) and I solved it by slipstreaming the F6 driver into the XP cd and then running the installation, but this is overkill, as I can simply disable native SATA and live without an F6 driver.

I have little doubt that reinstalling the system would "fix" the problem, but I would like to avoid this, as it would mean to reinstall the full system from scratch. There must be a simple fix here, as the system also didn't need much work to die :-)
0
 
andeporterCommented:
Good point. What a curious problem. So are you leaning towards it being a driver issue or no?
0
 
StaudteAuthor Commented:
No, I think it is NOT a driver issue, nor a hardware fault. I have the feeling that somehow during the last shutdown the system must have corrupted something in the vague direction of harddisk/Windows structure. Just enough so that even the Windows setup will not detect the previous Windows installation (and just show the partition), but not enough to make a chkdsk fail.
0
 
BobRPCCommented:
My SOLUTION
I had the same problem and tried all the same things, even had a clone of the unbootable drive exhibiting the same behavior as the original drive.
One more thing, I could NOT boot from the WinXP pro CD with that harddrive in that condition in that computer, the CD booting would just stop before it ever got to the blue setup screen, so I could not get to the recovery console to run chkdsk /R

what finally worked was:
attach drive to another computer via USB->IDE connector
Using Acronis TI workstation, make a clone image of the drive (always have a backup!)
Using Acronis DiskDirector v10, check disk for errors using the DD chkdsk option, it found errors (other chkdsk routines had not) and it fixed them (it found attribute and index errors...) but this still did not make the drive boot

Then using Acronis DiskDirector (DD) I resized the drive from 250gb to 60gb (arbitrary)
(NOTE: I had tried to resize the drive before running DD's chkdsk but got and error that NTFS something ??? was incorrect, so I ran  DD's chkdsk)
that allowed me to reduce the size of the partition from 250 to 60 and the drive booted without hesitation. then used DD to resize the partiton back to MAX size and all was/is still working.
 
even, replicated the process successfully; Very weird, but it WORKED!

This was on an Inspiron 6000 laptop with 250gb IDE (pata) drive, it had happed to this guy twice before, Dell replaced drive under warranty the first time, he paid to have drive replaced the second time, but NOTHING was ever physically wrong with the drives, seems to be something in the BIOS as relates to hard drive communications fouling things. This laptop had the last BIOS they would ever release for this model and no options to adjust any settings related to fail-safe or IDE parameters, so based on thoughts provoked by the excellent forums out here on the WEB I thought to try what I did and it worked. Hope this helps someone down the line.
0
 
davidwt2Commented:
Hi Bobrpc,
your solution worked for me too.
0
All Courses

From novice to tech pro — start learning today.