Enable Java in my Web Browser

I am using Internet Explorer 7. Java applets say that Java is not enabled in my web browser. Examples of the error is:
"This module requires java to function, but your browser does not support java "

I check in Tools > Internet Options > Advanced, and it seems like Java is enabled. Also, I tried Firefox, and it works fine, so I know that its IE related.

Any ideas?
LVL 8
pzozulkaAsked:
Who is Participating?
 
blahphishConnect With a Mentor Commented:
One easy thing to try is to reset your browser via tools -> internet settings -> advanced tab -> reset. Will put it back to factory defaults.
0
 
pzozulkaAuthor Commented:
I need to actually find the root of this as I suspect this might be a GPO setting blocking JAVA. Reseting the settings fixes it, but it stops working after restarting the computer.
0
 
pzozulkaAuthor Commented:
In Exchange Management Shell:
    * Remove-AutoDiscoverVirtualDirectory Identity AutoDiscover (default web site)
    * New-AutoDiscoverVirtualDirectory
After you run New-AutodiscoverVirtualDirectory, you will notice an error. Simultaneously you will also notice the WWW service crashing. Wait for it to STOP.
Next, STOP the IIS Admin Service, along with HTTP SSL.
Next, try running New-AutoDiscoverVirtualDirectory. <-- It should now successfully create AutoDiscover.
Start the following services: WWW, IIS Admin Service, and HTTP SSL.
0
 
pzozulkaAuthor Commented:
Disregard, wrong post.
0
 
blahphishCommented:
perhaps use gpresult tool to help find the GP responsible for the internet explorer settings? http://www.windowsnetworking.com/articles_tutorials/Resultant-Set-Policy-Queries-GPRESULT.html

Or you could always just dig through the group policies on the Domain Controller manually..
0
All Courses

From novice to tech pro — start learning today.