• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3766
  • Last Modified:

Are there any drivers for Adaptec 2940UW for Vista 64bit

Though the drivers for the Adaptec 2940UW SCSI card are included with Windows XP 64bit, they are not with Vista (at least, not part of the standard install). I have installed Vista x64 Ultimate and the only thing on my computer that does not work is my Adaptec 2940UW SCSI card and my Microtek Scanmaker III SCSI scanner.

Does anyone know where I can find the for Adaptec 2940UW for Vista x64 ?
0
rjjacques
Asked:
rjjacques
1 Solution
 
MidnightOneCommented:
I don't see (on Adaptec's site) any 64-bit drivers for the SCSI card you're trying to use

I did a bit of looking, and found this: http://forums.techarena.in/vista-hardware-devices/697637.htm
In short, it offers two possible work-arounds:
 * Try the embedded 2940-family driver and ignore the warnings
 * Try the Adaptec AIC-7870 PCI SCSI Controller (Emulated).

HTH

0
 
rjjacquesAuthor Commented:
Using the emulated SCSI controller worked.
My scanner is now found, but I am unable to get it to work (there is another thread for this "potentially hopeless" one...
0
 
WhiskyOneCommented:
Hi, found this on googling as I have the 2940 also, will be looking to 64bit it when Windows 7 RTM hits MSDN.
This is the answer to a similar question:-
2904 is a like 2940 without Bios on the board. Both use aic78xx.sys driver

so I suggest you "force" the device manager and select
"Adaptec AHA-2940U/2940UW/2940D PCI SCSI Controller"

you can also try edit WINDOWS\inf\pnpscsi.inf (with notepad.exe, and after
backup original file)

under the line
%PCI\VEN_9004&DEV_8178.DeviceDesc% = aic78xx_Inst, PCI\VEN_9004&DEV_8178
add the two lines :
%PCI\VEN_9004&DEV_5078.DeviceDesc% = aic78xx_Inst, PCI\VEN_9004&DEV_5078
%PCI\VEN_9004&DEV_5075.DeviceDesc% = aic78xx_Inst, PCI\VEN_9004&DEV_5075

and under the line
PCI\VEN_9004&DEV_8178.DeviceDesc = "Adaptec AHA-2940U/2940UW/2940D PCI SCSI
Controller"
add the two lines::
PCI\VEN_9004&DEV_5078.DeviceDesc = "Adaptec AIC-7850 PCI SCSI Controller"
PCI\VEN_9004&DEV_5075.DeviceDesc = "Adaptec AIC-7550 PCI SCSI Controller"
Of course, this is without official support

Reply:-
Thanks for that!

I edited the x64 version of \windows\inf\pnpscsi.inf to copy these lines
from the 32-bit version .inf:
%PCI\VEN_9005&DEV_0011.DeviceDesc% = aic78u2_Inst, PCI\VEN_9005&DEV_0011
PCI\VEN_9005&DEV_0011&SUBSYS_01819005.DeviceDesc = "Adaptec AHA-2930U2 -
Ultra2 SCSI"

I added those after the "_0010" version of each line. Then I used the Add
Hardware Wizard and guided it to the updated pnpscsi.inf file. And it
worked! So far, at least. The volumes on the SCSI drive
show up in My
Computer and Windows Explorer. If further testing reveals a problem, I'll
let you know. As you said, "Of course, this is without official support."

Thanks go to Gilles Vollant for this info info and it was to be uploaded onto planetamd64.com

I must reiterate "Of course, this is without official support"


0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now