We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Microsoft Dynamics CRM - Event ID Error 319

alcoahd
alcoahd asked
on
Medium Priority
924 Views
Last Modified: 2012-05-06
Event Type:      Error
Event Source:      eConnect OutGoing Service 9.0
Event Category:      None
Event ID:      919
Date:            2/12/2009
Time:            11:56:29 AM
User:            N/A
Computer:      SQLSERVER01
Description:
.Net SqlClient Data Provider
Cannot open database requested in login 'TWO'. Login fails.
Login failed for user 'SQLSERVER01\Administrator'.
System.Data.SqlClient.SqlException: Cannot open database requested in login 'TWO'. Login fails.
Login failed for user 'SQLSERVER01\Administrator'.
   at System.Data.SqlClient.ConnectionPool.GetConnection(Boolean& isInTransaction)
   at System.Data.SqlClient.SqlConnectionPoolManager.GetPooledConnection(SqlConnectionString options, Boolean& isInTransaction)
   at System.Data.SqlClient.SqlConnection.Open()
   at ExecuteCompanyRequest.PopulateArrayLists()

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Comment
Watch Question

Commented:
It appears that this is an issue with the econnector to handle integration between Microsoft CRM and Great Plains.  One thing you may want to try is to make sure that the user who is using the eConnect outgoing service and who owns the GP message queue is a Domain Administrator.  These kinds of errors arise frequently when a user has inadequate permissions.

There are some articles about this type of issue available in the Microsoft KB.  However, I am not permitted to share that information publicly.  If you are a Microsoft customer, or you are working with a Microsoft Partner, then you should be able to get access to the Microsoft KB (mbs.microsoft.com/knowledgebase) to search for more information.  

If those don't work, I'm not sure that we can do much else ... but someone else may be able to give you a hand if you can share some more information, such as:
* Is this a new install of CRM?  GP?  Both?
* Which versions?
* How is your infrastructure configured?
* How is BizTalk setup?

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
GP is installed, and the version of eConnect is 9.0 as well as GP 9.0.


I will get more information on the infrastructure and how BizTalk is setup.
Commented:
Test the above recommendation for running appropriate services as Domain Controller to see if that remedies your problem.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.