• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 413
  • Last Modified:

Network adapter issue Windows XP

I am having a problem with a customers computer running Windows XP Home Edition upgraded from SP1 to SP3. The network adapters will not install, after copying files over and appearing to successfully install the adapter an error appears on the final screen of the Add New Hardware Wizard stating "The system could not find the file specified". When attempting to install Simple TCP/IP Services an error appears stating "Could not install simple tcp/ip, file or registry entry missing". It appears to be the same issue as this post http://www.experts-exchange.com/Networking/Protocols/Transport/TCP-IP/Q_23388540.html?sfQueryTermInfo=1+%22tcp+ip%22+network+simpl which was resolved by reinstalling Windows, but I am trying to keep my customer satisfied and they do not want the hassle of having to reinstall anything. The network adapter is an onboard SIS 190, I have also attempted installing a Belkin USB adapter with the same issues. Assistance would be greatly appreciated.
0
shinomen
Asked:
shinomen
1 Solution
 
evan2645Commented:
Hello. It sounds like your TCP/IP stack has somehow gotten defunked! Try to follow this KB by Microsoft, and report back.

http://support.microsoft.com/kb/299357
0
 
shinomenAuthor Commented:
I forgot to mention I had tried that as well as netsh winsock reset and the winsockxpfix. The logfile from netsh int ip reset only states <completed>.
0
 
subliferCommented:
To simplify evan's response, from a command prompt, enter the following to reset the TCP/IP stack although since you found the other question I imagine you've already tried it... :

netsh int ip reset c:\resetlog.txt

Something else that you can try that has worked for me in the past... Go into the device manager, select your network card so its highlighted, press the delete button on your keyboard, agree to its prompt.  Now, do NOT refresh the device list or press the search button, instead reboot the computer, when you log back on it should go through the "Found new hardware" wizard.  If you NIC has an install program, then cancel the wizard and do that, if you instead have the drivers downloaded and in place, direct it to that through the installation wizard.  Once its installed check device manager to make sure there are no visible problems then try the network if you are running DHCP or configure it if you aren't.  If you use DHCP and it didn't start working, try changing the DNS server to a public like 4.2.2.2 and give it another try.

One other thing you can try to do is uninstall SP3 and try installing SP2 afterwards.

Good luck,
sub
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
shinomenAuthor Commented:
Thanks for the continued assistance, but netsh int ip reset c:\resetlog.txt simply showed <completed> in the log file as I mentioned earlier, and the error occurs with every network adapter I have tried to install regardless of driver version. I have never run into this sort of issue before and it is very puzzling. I will go ahead and list everything I have tried thus far.
1. Repair Installation
2. Upgrading from SP1 to SP3 (per forums found via google search)
3. Verifying that the RunOnce key was in the registry (per another google search)
4. SFC
5. Reset winsock and ip interfaces via command line and with Dial-a-fix
6. Reregistered dll files via Dial a fix
7. Ran permissions fix from Microsoft using SubInAcl
8. I have also tried at least 2 known good working drivers for each networking device that I have attempted to install, all fail with "System can not find the file specified" and have Code 31 and a yellow exclamation point in Device Manager after installation.
0
 
subliferCommented:
Well, I guess your customer deleted the wrong files... only thing I can think of that you haven't tried then is uninstall SP3 and install SP2 but chances are, after all you've done, its hosed and nothing but a complete reinstall will fix it.  You can do this without formatting the computer though.  Before you do, move files he wants to keep out of "user" folders and into generic directories on the root.  Then reinstall over the top like a repair install but when it detects the existing Windows and asks if you want to repair it, just continue to install.
0
 
shinomenAuthor Commented:
That is not an acceptable solution, does anyone else have any ideas? Take a look at these entrys found in the setupapi.log file. I also found in the oem33.inf file that SiSGbe2XP.ndi is not the correct file for this network adapter, but it is what the setup log indicates is being installed.

setup-log.txt
0
 
shinomenAuthor Commented:
The oem33 inf file did not post properly so here it is>
oem33.txt
0
 
subliferCommented:
Try downloading a different driver version to install.  You can get the latest from SiS' website here:
http://www.sis.com/download/agreement.php?url=/download/

and can search for older versions elsewhere as it looked like SiS only has the two most recent versions available on their site.

I do see your point in it trying to install the wrong driver but you said you tried other network adapters... it wouldn't make much sense if it was trying to install the wrong ones with each card...

You could also try searching your registry, after uninstalling the network card, for any remaining traces of the NIC by the Class GUID and or by the vendor id.  Delete those references after you backup your registry and reboot and try installing it again.
0
 
shinomenAuthor Commented:
Well I got this one corrected as well, it was done by navigating to HKLM\System\CurrentControlSet\Control\Network and deleting the Config value. After a reboot this allowed the network adapters installed properly and restored all Internet connectivity.
0
 
Statichead2kITCommented:
I'd been working on this off and on for days. I'd uninstalled and reinstalled drivers, deleted registry entries for the card in ENUM, reset stacks, winsockxp fixed.  Deleting the reg value mentioned and then reinstalling the driver from the manufacturer download fixed it immediately. In my case the issue was caused by installing vipre's firewall while trendmicro's firewall was still installed....DERP!!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now