We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

How to activate "Out of Office" through powershell in ex2007

duh123
duh123 asked
on
Medium Priority
6,035 Views
Last Modified: 2012-05-06
Hello

I'm trying to activate Out of Office for a mailbox on exchange 2007 through powershell.
I'm using the EWSOofUtil.dll from http://telnetport25.wordpress.com/2008/03/16/quick-ish-tip-exchange-2007-setting-oof-for-users-via-powershell-2/

And I can't get it working unless I provide the mailbox owners credentials.
But I don't know all passwords of all users.

If i run it as ExOrgAdmin I get an 'unauthorized', and if I run it as ExViewOnlyAdmin I get 'User is not not mailbox owner'

Is there another way to do it?
I dont' want to do it through CDO, although with CDO it works fine.
Please help?

thanks
Heinz


Comment
Watch Question

Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Considering the script is developed by someone, rather than built in, it would probably be best to direct questions at the person who developed it. Your problem is almost certainly connected with permissions, but as there is nothing on the site about what permissions are required, it is almost impossible to answer.

Have you tried use the tool that has been developed by the same author as the post that you have linked to above?

-M
Commented:
Thanks

In the meantime I tried to do it with EWS.
I found a very usefull example at http://blogs.msdn.com/vikas/archive/2007/11/20/howto-ews-disable-out-of-office-oof-message.aspx

When I impersonate as mailbox owner it works perfect. But not with my credentials (I'm exchange org admin) and also not with other admin roles - I get the error "Microsoft.Exchange.Data.Storage.AccessDeniedException: User is not mailbox owner"

I think I need an admin account that has owner-level access to all mailboxes - how to do that ?
I tought this would work if I give an admin full access rights, but still get that error.

Heinz

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.