Remote Desktop Windows 2003 not functioning

I am unable to open a remote desktop connection to a windows 2003 server.  I am trying to connect with an administrator account.  It is the same account I use to log in locally to the server.

On the windows 2003 server, the firewall is disabled (service stopped) and remote desktop is enabled in the Remote tab of the System Properties.  I have also checked to
make sure RDP was on listening on port 3389 by using netstat.

On the server, I can remote connect to another win2003 server.  But if I try to connect to myself, it asks for my credentials and I then I see the color bar on the Remote Desktop Connection window scroll for a second and then stop.   The same thing happens when trying to connect using a XP client.  I have tried using both the server's host name and ip address.

Thanks for your help!
LVL 1
TomProAsked:
Who is Participating?
 
snusgubbenCommented:
Try to roll-back/uninstall the graphic card driver and test RDP towards the 2003 host.

If it work download the latest driver and try RDP again.


SG
0
 
StuFox100Commented:
First check your event logs for errors.
Second what type of graphics card does the server have?
Cheers
Stu
0
 
TomProAuthor Commented:
In the system event viewer log is an entry for each try:

Application popup:  : \SystemRoot\System32\RDPDD.dll failed to load
Event ID: 26

The server is running with a Quadro4 NVS290 256MB 64-bit GDDR2 PCI Express graphics card.

I have already tried reinstalling the latest version of RDP for Win2003 from Microsoft.com
WindowsServer2003-KB925876-v2-x86-ENU.exe
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
StuFox100Commented:
Open regedit and find:
HKLM/System/CurrentControlSet/Control/SessionManager/MemoryManagement
Change the value of "SessionImageSize" - it should be at least 20 (hex) or 32 (dec). You might want to change ths to 40(hex) or 64(dec).
This is a known issue with several drivers that are too big for the registry and this will allow more space for the driver.
Cheers
Stu
0
 
StuFox100Commented:
Forgot...
Or update your graphics driver.
0
 
TomProAuthor Commented:
The nvidia graphics driver had been recently updated.  I rolled back to a previous version known to work fine and now RDP works again!  SInce both you guys equally helped, I'm splitting the points.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.