Cannot access ACT! database

Posted on 2009-02-18
Last Modified: 2012-05-06
Trying to access ACT! Database that is on network, i have a local drive mapped to this network share where i was able to access this yesterday, but now i cannot. No changes have been made to my knowledge.

Here is the error message I get:
The database Data_base_name could not be accessed. In order to access this database, check your network connection and verify that your database server is available. It may be necessary to disable any firewall software on your computer or server.

This is what I have tried:
no firewall running on computer
connection to server is fine
can open act database from server ok.
followed instructions to run act diagnostics and detach database, delete the .pad file, and reattached the database, creating a new .pad file.
verified that database is shared.

System specs:
Act! on server is version: premium 2008 Hotfix 1
server 2003 with latest patches

User systems are windows xp
Act! version

Now the only thing else i saw what that my version of act was different from the servers, and i saw on ACT! support that this could cause an issue. I went and updated my version, but it caused all sorts of problems and now the application will not run.

I am going to uninstall act on my system and reinstall it, then try the update again. I will post the results. But if you can provide any suggestions in the mean time, it would be a great help.

Question by:matrix1324
    LVL 5

    Assisted Solution

    The server is probably set to automatically update Act and your machine to not.  2 different application versions can cause this problem.

    What errors are you getting when loading Act now you've updated the software?
    LVL 30

    Accepted Solution

    First - the versions on both systems MUST be the same

    This error is the most common one for ACT! - it simply means it can't connect to the ACT! server, but usually doesn't have anything to do with the firewall itself.

    Here is a list of the possible causes and fixes:

    Author Comment

    Thank you both for your suggestions!!

    I found out that all user systems were running the same version of ACT! as the server, except for mine. However the problem was not related to this as when i updated to the same version i too was still having the same issue like everyone.

    If anyone else encounters this issue check out the link that GLComputing submitted.

    After looking at that check list of possible reasons for failure, the one that fixed it for me was where for what ever reason the TCP/IP option in SQL Manager was disabled. Once i enabled this option and restarted the SQL ACT! service, everyone was able to connect to the network database.

    On a side note, in my research i found out (which i had a problem with) If your upgrading from 10.0 to 10.0.3 make sure your read the FAQ articles on about .net framework service pack that causes issues. You need to remove this service pack and install if after you install act upgrade. If not you will be able to install act but it will not work, and it will not let you uninstall it. There are steps on the FAQ on on how to fix this if that is what issue you are having. If you having issues getting the update through the ACT! application you can go to and create a user account and then download each upgrade you need separately to install with directions.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Decide what contact details to include in email signatures with these top 10 email signature contact details DOs & DON'Ts.
    In our personal lives, we have well-designed consumer apps to delight us and make even the most complex transactions simple. Many enterprise applications, however, are a bit behind the times. For an enterprise app to be successful in today's tech wo…
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now