• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3345
  • Last Modified:

Cannot access ACT! database

Trying to access ACT! Database that is on network, i have a local drive mapped to this network share where i was able to access this yesterday, but now i cannot. No changes have been made to my knowledge.

Here is the error message I get:
The database Data_base_name could not be accessed. In order to access this database, check your network connection and verify that your database server is available. It may be necessary to disable any firewall software on your computer or server.

This is what I have tried:
no firewall running on computer
connection to server is fine
can open act database from server ok.
followed instructions to run act diagnostics and detach database, delete the .pad file, and reattached the database, creating a new .pad file.
verified that database is shared.

System specs:
Act! on server is version: premium 2008 10.0.3.182 Hotfix 1
server 2003 with latest patches

User systems are windows xp
Act! version 10.0.2.191

Now the only thing else i saw what that my version of act was different from the servers, and i saw on ACT! support that this could cause an issue. I went and updated my version, but it caused all sorts of problems and now the application will not run.

I am going to uninstall act on my system and reinstall it, then try the update again. I will post the results. But if you can provide any suggestions in the mean time, it would be a great help.

Thanks,
0
matrix1324
Asked:
matrix1324
2 Solutions
 
HighlanderXCommented:
The server is probably set to automatically update Act and your machine to not.  2 different application versions can cause this problem.

What errors are you getting when loading Act now you've updated the software?
0
 
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
First - the versions on both systems MUST be the same

This error is the most common one for ACT! - it simply means it can't connect to the ACT! server, but usually doesn't have anything to do with the firewall itself.

Here is a list of the possible causes and fixes: http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=19640
0
 
matrix1324Author Commented:
Thank you both for your suggestions!!

I found out that all user systems were running the same version of ACT! as the server, except for mine. However the problem was not related to this as when i updated to the same version i too was still having the same issue like everyone.

If anyone else encounters this issue check out the link that GLComputing submitted.

After looking at that check list of possible reasons for failure, the one that fixed it for me was where for what ever reason the TCP/IP option in SQL Manager was disabled. Once i enabled this option and restarted the SQL ACT! service, everyone was able to connect to the network database.


On a side note, in my research i found out (which i had a problem with) If your upgrading from 10.0 to 10.0.3 make sure your read the FAQ articles on ACT.com about .net framework service pack that causes issues. You need to remove this service pack and install if after you install act upgrade. If not you will be able to install act but it will not work, and it will not let you uninstall it. There are steps on the FAQ on ACT.com on how to fix this if that is what issue you are having. If you having issues getting the update through the ACT! application you can go to act.com and create a user account and then download each upgrade you need separately to install with directions.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now