?
Solved

ARP is not resolving in  same network with multiple switch(different model)

Posted on 2009-02-18
13
Medium Priority
?
499 Views
Last Modified: 2012-06-21
I have very strange issue, I have multiple switch connected to router, (R1->SW1-sw2->SW3 etc, SW is 3560 and sw is 2950) where the management vlan is 100, and there is a subinterface in router with IP from the management VLAN 100, I can ping from switch to GW, but I cannot ping from switch to switch eventhough they are in the same network, What I noticed that if I reboot the switch connecte to the router then every thing works for some time then it stops, I think the ARP is not resolving properly, any help will be highly appreciated.
0
Comment
Question by:mohaned
  • 5
  • 4
  • 2
11 Comments
 
LVL 3

Assisted Solution

by:thesherminator
thesherminator earned 900 total points
ID: 23671646
Can you paste subif config on the router? have u got proxy-arp disabled. Is the same issue happening on all 3 switches?
0
 

Author Comment

by:mohaned
ID: 23671733
Sorry I don't have access to the router, proxy arp is not disabled and even the local proxy arp is enabled,
what happens is that initially from the router I can access all the switches (I have actually more than 2 switch around 25), but when I log into the first switch connected to the router and try to ping any of the otherswitches say SW5 it doesn't work and , then when I  go back to the router,  I will loose even the connectivity from router to that switch(SW5).
0
 
LVL 3

Expert Comment

by:thesherminator
ID: 23671905
Disable proxy-arp and make sure default-gateway is configured on all switches. This only applies to the management vlan subinterface on the router
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:mohaned
ID: 23672655
Just to update, all the switches can reach any outside network, only problem is connectivity between ip's in the same network, I would like to add more details, this is an VoIP network where the phone's are connected to the switches, Phone's can call any other phone out side his on network  , when they call in the same network it rings and when the attend, some works (bothway Voice)  and for some only one-way audio and for some no audio at all, and this is changing from time to time.
0
 
LVL 3

Expert Comment

by:thesherminator
ID: 23680395
Can you post the "show ip route" from one of the switches
0
 
LVL 57

Expert Comment

by:giltjr
ID: 23680546
Are the connections between the switches setup as trunks?

Are all VLAN's or just some VLANs allowed on the trunks.
0
 

Author Comment

by:mohaned
ID: 23683079

*************This is for switch with IP 192.168.10.19 ****************
SW-Voice1-F9#show ip route
Default gateway is 192.168.10.1

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty
======================================================================
SW-Voice1-F9#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.10.1           30   001d.e620.c380  ARPA   Vlan100
Internet  192.168.10.8          163   001c.b015.bb41  ARPA   Vlan100
Internet  192.168.10.12         204   0021.5645.9441  ARPA   Vlan100
Internet  192.168.10.13         208   001d.e620.c380  ARPA   Vlan100
Internet  192.168.10.19           -   001c.b015.bf41  ARPA   Vlan100
***********************************************************************

Only certain VLANs are allowed over the trunk, vlan100-103 is allowed on all trunks, VLAN1 is  only allowed on some trunks.
Here is the config of one switch
Current configuration : 11741 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SW_Voice1-F2
!
enable secret 5 $1$0B6C$F6liBydrp63A5ANRniNxn.
enable password 7 05590A0E35491C0E16
!
no aaa new-model
clock timezone SD_Zone 3
system mtu routing 1500
ip subnet-zero
!
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-103
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport access vlan 101
 switchport mode access
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
!
interface GigabitEthernet0/2
 switchport access vlan 101
 switchport mode access
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
!
interface GigabitEthernet0/3
 switchport access vlan 101
 switchport mode access
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
!
interface GigabitEthernet0/4
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-103
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 channel-group 1 mode on
!
interface GigabitEthernet0/5
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/6
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/7
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/8
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!        
interface GigabitEthernet0/9
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/10
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/11
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/12
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/13
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/14
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/15
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/16
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/17
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/18
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/19
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/20
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/21
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-103
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet0/22
 switchport access vlan 102
 switchport mode access
 switchport voice vlan 100
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
!
interface GigabitEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-103
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 channel-group 1 mode on
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100-103,111
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 description ****Voice_IP_Phone*****
 ip address 192.168.10.12 255.255.255.0
 ip helper-address 192.168.10.1
!
interface Vlan101
 description ****Voice_Servers*****
 no ip address
 shutdown
!
interface Vlan102
 description ****DATA_Vlan*****
 no ip address
 shutdown
!
ip default-gateway 192.168.10.1
0
 
LVL 3

Accepted Solution

by:
thesherminator earned 900 total points
ID: 23683426
if it is not an arp issue, the only other thing I can think of is a duplicate ip address on the network the same as router ip. Anything on the logs of the switch or router? show log
0
 
LVL 57

Assisted Solution

by:giltjr
giltjr earned 600 total points
ID: 23684178
So if you disconnect R1 and SW1 you can ping to/from any combination of SW1, sw2, and SW3.  However shortly after connecting R1 and SW1 back you loose the ability to ping to/from any of the switches from/to the switches.  But, you can still ping R1 from any of the switches.

The show arp from 192.168.10.19 showed the mac address for 192.168.10.12.  Did it show the correct mac address for 192.168.10.12?

If so, are 192.168.10.12 and 192.168.10.19 directly connected to each other and if so, which port on 192.168.10.12 is it?
0
 

Author Comment

by:mohaned
ID: 23691366
Thank you very much all of your attention to my question.
Finally we are able to spot the issue, there was a loop in the network, so we are in the process of locating the exact location, we have more than 35 switches connected.

Thanks Again
0
 

Author Closing Comment

by:mohaned
ID: 31548305
Thank You very much for your help and support
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSL is a very common protocol used these days when browsing the web.  The purpose is to provide security to communication, but how does it do it?  There are several pieces at work that have to be setup before SSL will even work and it requires both …
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question