• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1084
  • Last Modified:

Outlook/Exchange - Forwarding Email from exchange to external account.

Hi, I'm working on a HelpDesk program called Polar Help Desk for my company to keep track of work orders for our IT dept. That system uses an exchange account to send email notifications of work orders that are entered into the system. I created an exchange account and entered the settings into Polar, and did some tests. I'm able to receive notifications in my exchange account, but if I try to send to an external account I don't get a notification.

I decided to forget it and just make a rule in Outlook 2007, so I started a new rule and told it to forward every message from "is@mycompany.org" to my external accounts. I tried my personal email account through my website, a gmail account, and my mobile phone formatted 10digit#@message.alltel.com. I have no trouble sending to any of these external accounts if I open a new message and simply type in the address. The rule however will not work, and I feel like whatever is causing this is causing the problem with my Polar program as well. I even tried going into Exchange 2003 and creating myself as a contact with those addresses and still I get no forwarded emails.

Thanks so much for any help you can provide!!
0
sjl1986
Asked:
sjl1986
  • 5
  • 4
1 Solution
 
tigermattCommented:

It sounds like automatic forwarding is disabled at the Exchange Organization level. Enable it in ESM > Global Settings > Internet Message Formats > Default > Properties > Advanced > Allow automatic forward, then try again.

-Matt
0
 
sjl1986Author Commented:
Tigermatt. Thank you for the quick reply. The answer you gave worked perfectly for the problem with my Outlook rules. (I'll award points even if you can't figure out my second problem). Outlook now forwards the message to my external addresses. It didn't however fix the problem with the Polar application attempting to send directly to the same address, which surprised me. Is there any other setting you know of in exchange that might prevent an external program from sending emails? I attached an image of the email settings for the Polar program. The pop3 and imap4 settings are blank. We don't use those in our system as of now.
polaremail.JPG
0
 
tigermattCommented:

How do you have the Polar system delivering the mail? Is it trying to send it directly to the external address but through the Exchange Server, or does it deliver to a local mailbox, which then has the forwarding rule set?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sjl1986Author Commented:
Well, I know I don't have it going into a local mailbox and then forwarding, I was just using the Outlook forwarding rule to bypass the built-in Polar option. The Polar system simply asks for the IP address of the exchange server, and the port and the login information for the exchange account I want to send the mail from.

So when I get a message from Polar it comes from the account listed in the Polar email options. Each user set up in Polar has an option for an email address and a check box to enable email notifications. At this point I place my external email address, so nothing is being forwarded. I have tried both with SMTP authentication both enabled and disabled with the same results. It's not a huge deal but if for some reason my Outlook doesn't remain open I'd still like to receive text message notifications of work orders from the Polar system. I notice there are some places in ESM to enable mobile devices and such which I don't know much about but because of the problem with my personal email account I don't feel like that's the solution.  Thanks again!
0
 
sjl1986Author Commented:
http://www.box.net/shared/j0al3af5l9

This is the link for the set of files for the bootable CD based on the earlier link I posted for NightOwl's site.

View the README.txt listed in the zip file I posted and follow the instructions very carefully.
Anybody else who needs a bootable ghost CD/DVD that will read USB and FWR devices feel free to download as well until box.net denies the traffic.

Hope it saves you some trouble!! Enjoy.
0
 
tigermattCommented:

Not too sure about the NightOwl comment. Did you post that to the wrong question?!

As for the Polar system, it sounds to me as though you are attempting to relay from the Polar system, through the Exchange Server directly to an external email address. In the interests of not being an open relay (and subsequently a spammer's dream) Exchange will block this sort of behaviour, which would explain why you can't get the email to send.

What you will need to do is edit the configuration of your SMTP Virtual Server in Exchange System Manager. Somewhere in the Properties there is a 'Relay' button - probably on the 'Access' tab. You'd need to press that, ensure the option 'Only the list below' is enabled and then 'Add' the IP of the Polar server.

Your external email should then hopefully kick into action.

-Matt
0
 
sjl1986Author Commented:
Haha, wrong question, yes!! I was wondering where in the world my post went! I knew I saw it post and then I looked again and it wasn't there. Sorry about that. Well, If you'd like a bootable ghost cd that will detect read USB and FWR devices (minus the ghost.exe) you can get it in the link above!

Thanks for all your help. The second suggestion worked flawlessly. Just in closing thoughts, under the 'Access' tab. there was a place to add the domain as opposed to a single IP address. Would it be safe to add an entire domain if I wanted or would that still allow spammers to get in? Also, I saw an option to "allow all computers who successfully authenticate to relay, regardless of the custom list". Does this mean basically any user logged into the domain would be able to relay? These two options sound pretty synonymous to me.
0
 
tigermattCommented:

I'd just stick to doing it by IP address. It is always best to have control over what can relay through your server, since you only want to open this up when absolutely necessary such as in this case.

You don't want the 'Allow all computers who successfully authenticate...' option enabled. This is simply because in order for Exchange to accept legitimate email from external sources, anonymous authentication has to be enabled. Since having this option enabled would then mean anybody can authenticate and then subsequently relay, you would become an open relay very quickly.

Just a tip, if you want to check you're not an open relay, I'd suggest using http://www.abuse.net/relay.html.

-Matt
0
 
sjl1986Author Commented:
Thanks again Matt! I'll add that site to my favorites. Very good, thanks for everything.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now