[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

How do I enable RDP access via a Static NAT on a Cisco PIX 506E

Posted on 2009-02-18
1
Medium Priority
?
999 Views
Last Modified: 2012-05-06
We currently have a Cisco PIX 506 that has a one to one static NAT via

static (inside,outside) 87.xx.xx.197 DNS-server netmask 255.255.255.255 0 0

We also have the ACL to allow RDP on 3389 via

access-list outside_access_in permit tcp any object-group rdp any object-group rdp

Our problem is this doesn't appear to work? Below is the clean Config, any help appreciated.


show run
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ******** encrypted
passwd ******** encrypted
hostname ourdomain-fw
domain-name ourdomain.london
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.22 ourdomain-exfe
name 192.168.0.25 BBServer
name 193.109.81.33 srp.uk.blackberry.net
name 192.168.0.20 DNS-server
name 62.xx.xx.162 BT-DNS
name 194.xx.xx.38 BT-DNS2
name 194.xx.xx.98 BTDNS-3
name 172.xx.xx.0 Ext-LAN
name 135.xx.xx.192 Mimecast_DC1
name 212.xx.xx.128 Mimecast_DC2
name 213.xx.xx.64 Mimecast_Servers
name 212.xx.xx.144 Mimecast_DC3
name 135.xx.xx.202 test-mime
name 172.xx.xx.0 POffice
name 87.xx.xx.193 ADSLInInterface
name 172.16.4.0 Data_LAN
object-group network Mimecast
  description Mimecast Data Centres
  network-object Mimecast_DC1 255.255.255.240
  network-object Mimecast_DC2 255.255.255.192
  network-object Mimecast_DC3 255.255.255.248
  network-object Mimecast_Servers 255.255.255.192
  network-object test-mime 255.255.255.255
object-group service LDAPS tcp-udp
  description LDAP
  port-object eq 389
object-group service ldap tcp
  port-object eq ldap
object-group service rdp tcp
  description Microsoft Remote Desktop
  port-object range 3389 3389
access-list inside_access_in permit ip any any
access-list inside_access_in remark Allow Internal DNS Server to ISP DNS
access-list inside_access_in remark Allow Internal DNS Server to ISP DNS # 2
access-list inside_access_in permit udp host DNS-server eq domain host BT-DNS2 eq domain
access-list inside_access_in remark Allow Internal DNS Server  to ISP DNS
access-list inside_access_in permit udp host DNS-server eq domain host BTDNS-3 eq domain
access-list inside_access_in remark Allow SMTP traffic from Exchange server
access-list inside_access_in permit tcp host ourdomain-exfe eq smtp any
access-list inside_access_in remark Allow BBServer to srp.eu.blackberry.net
access-list inside_access_in permit tcp host BBServer host srp.uk.blackberry.net eq 3101
access-list inside_access_in remark Allow Web Traffic
access-list inside_access_in permit tcp any eq www any
access-list inside_access_in remark Allow HTTPS Traffic
access-list inside_access_in permit tcp any eq https any
access-list inside_access_in permit icmp any any
access-list inside_access_in permit icmp any any echo
access-list inside_access_in permit icmp any any echo-reply
access-list inside_access_in remark Allow SMTP traffic from Exchange server
access-list inside_access_in remark Allow BBServer to srp.eu.blackberry.net
access-list inside_access_in remark Allow Web Traffic
access-list inside_access_in remark Allow HTTPS Traffic
access-list inside_access_in permit udp host DNS-server eq domain host 217.xx.xx.134
access-list inside_access_in permit tcp any object-group rdp any object-group rdp
access-list inside_outbound_nat0_acl permit ip any 10.0.0.0 255.255.255.128
access-list inside_outbound_nat0_acl permit ip any Ext-LAN 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 POffice 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any Data_LAN 255.255.255.0
access-list outside_access_in permit tcp any eq www any eq www
access-list outside_access_in remark Ldap from Mimecast Servers
access-list outside_access_in remark SMTP from Mimecast Servers
access-list outside_access_in permit icmp any 87.84.225.0 255.255.255.0
access-list outside_access_in permit tcp any host 87.84.225.195 eq https
access-list outside_access_in permit tcp object-group Mimecast host 87.84.225.195 eq smtp
access-list outside_access_in permit tcp any host 87.84.225.195 eq smtp
access-list outside_access_in permit tcp object-group Mimecast host 87.84.225.197 object-group ldap
access-list outside_access_in permit tcp any object-group rdp any object-group rdp
access-list outside_cryptomap_dyn_60 permit ip any 10.0.0.0 255.255.255.128
access-list CompanyVPN_splitTunnelAcl permit ip 192.168.0.0 255.255.255.0 any
access-list outside_cryptomap_20 permit ip any Ext-LAN 255.255.255.0
access-list outside_cryptomap_40 permit ip 192.168.0.0 255.255.255.0 POffice 255.255.255.0
access-list outside_cryptomap_30 permit ip 192.168.0.0 255.255.255.0 Data_LAN 255.255.255.0
access-list inbound permit tcp any host DNS-server eq 3389
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 87.xx.xx.194 255.255.255.240
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNPool1 10.0.0.50-10.0.0.100
pdm location ourdomain-exfe 255.255.255.255 inside
pdm location BBServer 255.255.255.255 inside
pdm location srp.uk.blackberry.net 255.255.255.255 outside
pdm location DNS-server 255.255.255.255 inside
pdm location BT-DNS 255.255.255.255 outside
pdm location BT-DNS2 255.255.255.255 outside
pdm location BTDNS-3 255.255.255.255 outside
pdm location 192.168.0.21 255.255.255.255 inside
pdm location Ext-LAN 255.255.255.0 outside
pdm location 89.xx.xx.106 255.255.255.255 inside
pdm location 217.xx.xx.134 255.255.255.255 outside
pdm location 192.168.0.35 255.255.255.255 inside
pdm location Mimecast_DC1 255.255.255.240 outside
pdm location Mimecast_DC2 255.255.255.192 outside
pdm location Mimecast_DC3 255.255.255.248 outside
pdm location Mimecast_Servers 255.255.255.192 outside
pdm location test-mime 255.255.255.255 outside
pdm location POffice 255.255.255.0 outside
pdm location Data_LAN 255.255.255.0 outside
pdm location 87.xx.xx.197 255.255.255.255 outside
pdm group Mimecast outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 87.xx.xx.197 DNS-server netmask 255.255.255.255 0 0
static (inside,outside) 87.xx.xx.195 ourdomain-exfe netmask 255.255.255.255 0 0
static (inside,outside) 87.xx.xx.196 192.168.0.35 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 ADSLInInterface 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host DNS-server ******** timeout 5
aaa-server RADIUS (inside) host 192.168.0.21 ******** timeout 5
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt radius ignore-secret
auth-prompt prompt Please enter your Windows account details
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 89.xx.xx.106
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 30 ipsec-isakmp
crypto map outside_map 30 match address outside_cryptomap_30
crypto map outside_map 30 set peer 213.xx.xx.26
crypto map outside_map 30 set transform-set ESP-3DES-MD5
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set peer 217.xx.xx.227
crypto map outside_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication RADIUS
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 89.xx.xx.106 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address 217.xx.xx.227 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address 213.xx.xx.26 netmask 255.255.255.255 no-xauth no-config-mode
isakmp keepalive 20
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup CompanyVPN address-pool VPNPool1
vpngroup CompanyVPN dns-server DNS-server
vpngroup CompanyVPN default-domain ourdomain.london
vpngroup CompanyVPN split-tunnel CompanyVPN_splitTunnelAcl
vpngroup CompanyVPN split-dns ourdomain.london
vpngroup CompanyVPN idle-time 1800
vpngroup CompanyVPN password ********
telnet 192.168.0.0 255.255.255.0 inside
telnet 89.xx.xx.106 255.255.255.255 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 5
management-access inside
console timeout 10
dhcpd lease 3600
dhcpd ping_timeout 750
username ouradmin password ******** encrypted privilege 15
terminal width 80
: end

Open in new window

0
Comment
Question by:Wizard_IT
1 Comment
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 23672040
Change the access-list to this:

conf t
no access-list outside_access_in permit tcp any object-group rdp any object-group rdp
access-list outside_access_in permit tcp any any object-group rdp

The source port won't be 3389 (it will be random) which is why this isn't working.
0

Featured Post

Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Powerful tools can do wonders, but only in the right hands.  Nowhere is this more obvious than with the cloud.
As managed cloud service providers, we often get asked to intervene when cloud deployments go awry. Attracted by apparent ease-of-use, flexibility and low computing costs, companies quickly adopt leading public cloud platforms such as Amazon Web Ser…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question