We help IT Professionals succeed at work.

Outlook 2007 auto-complete not working properly

ThinkSmartInc
on
Medium Priority
7,617 Views
Last Modified: 2012-05-06
I have a client that is using Outlook 2007 and the auto-complete feature that fills in the to field in a new email has become sporadic.  It's as if the entire cache got wiped and is being repopulated.  I know that Outlook 2003 uses a .NK2 file which you can backup and reuse as needed, however, Outlook 2007 doesn't appear to work the same way.  Anyone know of a way to backup the auto-complete information and restore it?  At this point the only information I've heard is that a reboot allows you to start repopulating the information again, but it'd be nice to have a way to prevent the loss of this information.
Comment
Watch Question

Commented:
Hi,
Your 2007 .NK2 file is located under %USERPROFILE%\Local Settings\Application Data\Microsoft\Outlook

You should be able to rename that file to *.old and then create a new file called *.N2k

Next, open up outlook and type in an email address manually.  This will recreate the N2k file.  Close outlook and open up the OLD N2k file with notepad and copy in a few addresses from that file and append them to the new .N2k file (be sure to follow the formatting).  Save it and then open up outlook and start to type one of the addresses that you just copied into the new N2k file and it should auto fill.  If this works then copy the rest  of the addresses from the old N2k file to the new and test again.  

HTH

Commented:
Hi,
Just realized that you will not be able to just open up the Nk2 file with notpad and have it make any sense as it is not parseable.

Try this utility after you rename your old .NK2 file to .bak or .old and then open up outlook again.

This will create a new .Nk2 file that you can use with this utility to move the old nicknames to the new .Nk2 file.

http://www.nk2.info/

HTH
CERTIFIED EXPERT
Top Expert 2008

Commented:
Hello ThinkSmartInc,

Adding to what MightySW said, there is a NK2 file for Outlook 2007.  It is located in the directory that MightySW pointed to.  It is a hidden file, so you have to unhide hidden folders and files.  In Windows Vista, open Windows Explorer or any folder. Click the Layout button (to the left of the Views button). Click Folder Options > View tab. Check "Show hidden files and folders".   Click OK

Hope this helps!
war1

Commented:
Roger that.  Sorry, I forgot to mention that tid-bit.

Thanks War

Author

Commented:
There are no NK2 files on the system nor are there any N2K files.  I looked under %USERPROFILE%\Local Settings\Application Data\Microsoft\Outlook and it wasn't there.  I had already set-up the folder options to display hidden files, to not hide extensions, show system files and the contents of system folders.  I did a full search on the entire hard drive for *.nk2 and *.n2k and nothing comes up.  The odd thing is that the system isn't caching all addresses being entered, I was shown an example as end user entered an email address to someone they email all the time how after sending one message that address didn't get added to the auto-complete.  I've done this with Office 2003 on more than one occasion, but I have never seen this file in an Office 2007 installation.  Maybe I'm blind?

Author

Commented:
Addition: in the search options I made the search case insensitive and had it searching in hidden files and folders.

Commented:
Hi,
Sounds like your outlook is set not to create the .NK2 file or suggest names.

go to Tools-->Options-->Email Options-->Advanced Email Options.  Near the bottom you'll find a checkbox to suggest names.  Uncheck it if it is checked, click ok and close outlook, and open outlook, goto same location, check it, close outlook, and reopen, check for .NK2 file.

If it is unchecked already then just check it and close and reopen outlook and check for the file.

Commented:
If that isn't the problem then recreate the outlook profile.

Commented:
I downloaded

http://www.nirsoft.net/utils/nk2view.zip

Ran it then went to file - open, then renamed the Outlook.NK2 file to Outlook_old.NK2.  Closed the program, opened Outlook, select new email, click on 'to' then selected all my contacts.  Saved it as a draft.  Shut Outlook reopen, deleted the draft and auto complete is now working OK.  (touch wood)

Commented:
The Nk2info tool will do the same thing.  We already summarized a rename plan

Author

Commented:
Found the file on a network share that Outlook is using.  They have their systems set so that the profile syncs with the server, but why the file is on the server and not in the local profile is something we are investigating now.  Any ideas?  Obviously the biggest issues are if the sync cache gets corrupted (god forbid) or if they are not attached to the network and the file isn't available locally (as it would appear).

Commented:
Do you have any outlook or office 2007 GPO's affecting the workstations?

Author

Commented:
Here's a screen shot of the GPO affecting the Application Data folder, but the mystery is in Policy Removal Behavior it has "Leave Behind".  I assume that's supposed to mean "Leave a copy of all files on the local system".  What am I missing?  (Also, don't you just love these ever morphing questions?)
GPO.jpg
Commented:
Yes, this is the default setting.  You can change it if you are still using the policy.  If you aren't using roaming profiles anymore or using this policy anymore then you will have to change the registry on the local machines to point to the correct location of the application data folder by changing the registry here:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

Unless your application folders are set back to the local machines then you will not have individual control of your .NK2 files or even your profiles for that matter.

Some of the registry settings may have been switched back, and this was left as a tattooed registry entry.  Again, you can change it above.

You can also create a .reg file with this information (copy and paste the code snippet) for mass distribution.

HTH








Windows Registry Editor Version 5.00
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]
"AppData"="C:\\Documents and Settings\\USERNAME***FILL THIS IN***\Application Data"

Open in new window

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
At this point the client is happy with things as they are.  Points being awarded.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.