We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

EHLO - Command Unrecognzied

jjgriss
jjgriss asked
on
Medium Priority
667 Views
Last Modified: 2012-05-06
I'm having issues with certain domains getting stuck in the queue.  Most are navy.mil, yahoo, and a few others. We are running Exchange 2003 on WIn 2003 Box.
SMTP LOG:
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionCommand SMTPSVC1 EXCH2 - 25 EHLO - mail.help.org 0 0 4 0 2172 SMTP - - - -
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionResponse SMTPSVC1 EXCH2 - 25 - - 500+5.5.1+Command+unrecognized:+"XXXX+mail.help.org" 0 0 52 0 2234 SMTP - - - -
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionCommand SMTPSVC1 EXCH2 - 25 HELO - mail.help.org 0 0 4 0 2234 SMTP - - - -
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionResponse SMTPSVC1 EXCH2 - 25 - - 250+mail5.nrl.navy.mil+Hello+mail.help.org+[66.147.93.41],+pleased+to+meet+you 0 0 78  

Not sure what started this.  Problem came up last Friday and can't think of any changes accept maybe antivirus.  Need help to resolve......DNS seems fine plus not getting any other errors in SMTP log but the EHLO Command unrecognized.  Even the smptdiag test I get server does not support EHLO but connects successfully to mail server.  So not sure what changed or what I need to change on my part to allow mail to flow.  Any help would be appreciated.
Comment
Watch Question

Expert of the Quarter 2009
Expert of the Year 2009

Commented:
What is between the server and the internet?
A firewall of some kind?

-M

Author

Commented:
yes we have a cisco 2128.  I'm thinking it's the antivirus.  I stopped the services on the anti-virus and all mail failed so I have a support call into kaspersky to get it off my server.  I'll wait to hear from them unless you think it could be something else.    
Expert of the Quarter 2009
Expert of the Year 2009
Commented:
I am not familiar with that Cisco model, but some of them have an SMTP Scanning feature, mailguard or something like that. It can cause problems with email delivery and should be turned off.

-M

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
It appears things started working again after a couple days..  Not sure what fixed it ....
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.