?
Solved

EHLO - Command Unrecognzied

Posted on 2009-02-18
4
Medium Priority
?
648 Views
Last Modified: 2012-05-06
I'm having issues with certain domains getting stuck in the queue.  Most are navy.mil, yahoo, and a few others. We are running Exchange 2003 on WIn 2003 Box.
SMTP LOG:
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionCommand SMTPSVC1 EXCH2 - 25 EHLO - mail.help.org 0 0 4 0 2172 SMTP - - - -
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionResponse SMTPSVC1 EXCH2 - 25 - - 500+5.5.1+Command+unrecognized:+"XXXX+mail.help.org" 0 0 52 0 2234 SMTP - - - -
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionCommand SMTPSVC1 EXCH2 - 25 HELO - mail.help.org 0 0 4 0 2234 SMTP - - - -
2009-02-18 17:34:20 132.250.1.14 OutboundConnectionResponse SMTPSVC1 EXCH2 - 25 - - 250+mail5.nrl.navy.mil+Hello+mail.help.org+[66.147.93.41],+pleased+to+meet+you 0 0 78  

Not sure what started this.  Problem came up last Friday and can't think of any changes accept maybe antivirus.  Need help to resolve......DNS seems fine plus not getting any other errors in SMTP log but the EHLO Command unrecognized.  Even the smptdiag test I get server does not support EHLO but connects successfully to mail server.  So not sure what changed or what I need to change on my part to allow mail to flow.  Any help would be appreciated.
0
Comment
Question by:jjgriss
  • 2
  • 2
4 Comments
 
LVL 65

Expert Comment

by:Mestha
ID: 23673675
What is between the server and the internet?
A firewall of some kind?

-M
0
 

Author Comment

by:jjgriss
ID: 23673718
yes we have a cisco 2128.  I'm thinking it's the antivirus.  I stopped the services on the anti-virus and all mail failed so I have a support call into kaspersky to get it off my server.  I'll wait to hear from them unless you think it could be something else.    
0
 
LVL 65

Accepted Solution

by:
Mestha earned 1500 total points
ID: 23675626
I am not familiar with that Cisco model, but some of them have an SMTP Scanning feature, mailguard or something like that. It can cause problems with email delivery and should be turned off.

-M
0
 

Author Comment

by:jjgriss
ID: 23784356
It appears things started working again after a couple days..  Not sure what fixed it ....
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
Exchange administrators are always vigilant about Exchange crashes and disasters that are possible any time. It is quite essential to identify the symptoms of a possible Exchange issue and be prepared with a proper recovery plan. There are multiple…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question