?
Solved

cant send email to webmail servers

Posted on 2009-02-18
33
Medium Priority
?
452 Views
Last Modified: 2012-05-06
Hi
I'm on a domain with multiple sites. The main site hosts a spam email filter for all emails coming in to the domain. Recently there were problems with the spam filter and the admins over there redirected emails so they dont go through the filter. Now ever since they redirected the emails, i havent been able to send from my domain here to any web based email servers like yahoo, hotmail, gmail. I can receive emails from these servers. i can send and receive emails from from a buddy of mine who works at another company, and is not using a hotmail type email account.

the admins at the other campus are saying it has nothing to do with them, even though this problem started when the spam filter problem started. theyre saying outgoing emails from the domain do not hit the filter anyway, so it wouldnt be anything to do with that.

this is the bounce back message im getting when i send an email to a hotmail account.

<my domain exchange server>  #5.5.0 smtp;550 OU-001 Mail rejected by Windows Live Hotmail for policy reasons. Reasons for rejection may be related to content with spam-like characteristics or IP/domain reputation problems. If you are not an email/network admin please contact your E-mail/Internet Service Provider for help. Email/network admins, please visit http://postmaster.live.com for email delivery information and support>

the link they give doesnt help me at all either. has anyone seen this before or have any ideas on what i can check?

im using exchange 03
0
Comment
Question by:Kingsteve
  • 20
  • 10
  • 3
33 Comments
 
LVL 15

Assisted Solution

by:zelron22
zelron22 earned 200 total points
ID: 23673633
Check the PTR record for your domain namespace.  If they are not sending mail out through the same IP, then the PTR record is probably missing.  Most of these providers require a correct PTR record.
0
 

Author Comment

by:Kingsteve
ID: 23673829
so youre saying that since incoming email used to go through the spam filter in site1.domain, and now they redirected it somehow to not be sent through the filter(not sure on the specifics there) the ptr record in their dns(its their dns server that controls internet DNS) is not resolving to my IP here in a reverse dns lookup?

just trying to get my head around what they did over there affecting whats going on here. most of it is new territory for me.
0
 
LVL 17

Assisted Solution

by:Suraj
Suraj earned 1800 total points
ID: 23674717
i guess you are being blacklisted by hotmail .
do this...
1) on the command prompt...
telnet 65.55.37.120 25

-> what banner do you get  ?? is it accepting your connection ?
2) on the command prompt
telnet maila.microsoft.com 25
ehlo

now after ehlo it will give you an ip address (your connecting IP)
tell me what it is...

-X
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 

Author Comment

by:Kingsteve
ID: 23674867
heres the banner for step 1.

220 col0-mc4-f3.Col0.hotmail.com Sending unsolicited commercial or bulk e-mail t
o Microsoft's computer network is prohibited. Other restrictions are found at ht
tp://privacy.msn.com/Anti-spam/. Violations will result in use of equipment loca
ted in California and other states. Wed, 18 Feb 2009 12:56:40 -0800

step 2.

the ip is correct for my domain.
0
 

Author Comment

by:Kingsteve
ID: 23674965
also this isnt only happening with hotmail. its gmail and yahoo as well.
0
 

Author Comment

by:Kingsteve
ID: 23676258
i think im blacklisted by the CBL??? i sent an email to someone, and got a bounceback again. this wasnt to hotmail or anything. the bounce back had a link to cbl.abuseat.org and im listed in there as a bot mail spammer. what do i do??
0
 
LVL 17

Assisted Solution

by:Suraj
Suraj earned 1800 total points
ID: 23677684
Ok cool.... now that we found that you are blacklisted....

go to www.mxtoolbox.com and there you will fiind blacklist tab...
put in the ip you got ..
see which all RBLs have blocked you... just contact them and get your IP whitelisted...

If this webstie doesnt show you are black listed.. just contat those domains and ask if they have blocked your connecting Ip...

-x
0
 
LVL 17

Assisted Solution

by:Suraj
Suraj earned 1800 total points
ID: 23677700
also do telnet to gmail

telnet  209.85.143.27 25
ehlo
mail from: <user@yourdomain.com>
rcpt to:<user2@gmail.com>
data
Test
.
quit


---------check if you get this email on your gmail account
0
 
LVL 15

Expert Comment

by:zelron22
ID: 23678223
Also find out if you're sending out any spam since your mail is no longer going through the spam filter.  If you are, then you'll just be blacklisted again  Some blacklisters make it harder to get off of their list after repeat offenses.
0
 

Author Comment

by:Kingsteve
ID: 23680558
Whats the best way to find that out? I ran malware scans on my exchange server, and symantec scans every other computer on my domain. so far i havent picked anything up.

i'll call the people up today as well. Thanks for your help so far. EE has always been great help.
0
 

Author Comment

by:Kingsteve
ID: 23681139
heres what im finding out on mxtoolbox.

When i look up by my IP, it doesnt come up with anything.
i tried my domain name and it came up with an IP i've never seen. It isnt the IP i get when i nslookup my domain. but then again, its doing an MX lookup, so i dont know.
anyway, when i check the black lists on the IP it comes up with, its all green up until these

BGISOCBL      Listed      TIMEOUT      Return codes were: ERROR, Reponse code=2       0      0
NJABLDYNA      Listed      TIMEOUT             0      0
SNARK      Listed      TIMEOUT      Return codes were: ERROR, Reponse code=2       0      0
TRIUMF      Listed      TIMEOUT      Return codes were: ERROR, Reponse code=2       0      0
WYTNIJ                       TIMEOUT       

these 5 show as yellow.
0
 

Author Comment

by:Kingsteve
ID: 23681638
the telnet test to gmail does work, however the message is sent to the spam folder. there was no delay in receiving the message.
0
 

Author Comment

by:Kingsteve
ID: 23681749
There is now a sixth blacklist name

CSMA      Listed      TIMEOUT      Return codes were: ERROR, Reponse code=2       0      0
0
 
LVL 15

Expert Comment

by:zelron22
ID: 23683066
Can you tell us your external domain name?  
0
 

Author Comment

by:Kingsteve
ID: 23683110
mpl.herzing.edu

i dont know what those time outs are, but after doing another mxtoolbox lookup, the only ones that are actually red in the list are CBL and spamhaus. i called my ISP a few minutes ago and i did not have a ptr record in their DNS. Im going to do some virus scans so i can say i did when pleading my case to the blacklisters.
0
 
LVL 17

Accepted Solution

by:
Suraj earned 1800 total points
ID: 23688741

Hey.. sorry for  the late reply...

So as is suspected you are blacklisted... So we are on the right Path......

Yes you need to have a PTR record.. thats one of the recomendation... But...Blacklisting and PTR are different.. and has no relation between them....

You just need to enable all the spam filterings On the exchange server.. and once you are done with it.. just contact all those RBLS who have black listed you...
Just make it fast.. coz if you get black listed by more RBL... it will take more time for you to get whitelisted....

To enable spam filters just see my comment on the link ...........

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24150223.html?cid=238#a23683274

i am sure Your issue will be fixed...........

-x
0
 

Author Comment

by:Kingsteve
ID: 23691501
k i did most of this.

follow this to enable spam filtering:  [ i willl never recomend 3rd party anti spam.. these are good man]...

1) fist and the formost thing is to enable all the spam filterings on the exchange server :

--> On the properties of Message Delivery under Global Settings in the Recipients Filtering tab checked the 'Filter recipients who are not in the directory'
--> On the Sender Filtering tab checked the 'Filter messages with blank sender'
-->  On the Connection Filtering tab added a rule in the Block List Service Configuration as a display name of Spam Haus, DNS suffix of zen.spamhaus.org and on the return status code clicked on the Match filter rule to any of the filter responses and added the IP address from 127.0.0.2 to 127.0.0.12 with an exception
of 127.0.0.1, 127.0.0.3 and 127.0.0.9
-->  On the IMF tab changed the Gateway Blocking Configuration threshold to 7 and Archive When blocking messages and the Store Junk Email Configuration threshold to 6
-> then go to properties of default smtp virtual server--> general tab-->advance button--> edit--> and check mark all the filters except sender id filtering.................

-> enable tarpeting through the registry path :
-> NOW we wil add a regustry key so that if the spammer is using any kind of script exchange will break it....HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters and added a deword value TarpitTime and gave it a value of 5.

2) now stop the SMTP service. and go to "C:\Program Files\Exchsrvr\Mailroot location and rename Mailroot to MailrootOLD.
3) restart SMTP...... check the mail flow and monitor the queues......


I didnt have this:   On the IMF tab changed the Gateway Blocking Configuration threshold to 7 and Archive When blocking messages and the Store Junk Email Configuration threshold to 6


so far what ive been doing since yesterday is running virus scans on every computer on my domain. the virus definitions were over 2 years old, older than the last admin before me. should i continue to get the virus scans ran before i try to get whitelisted?

anything else i should do?
0
 
LVL 17

Expert Comment

by:Suraj
ID: 23692553
Perfect ! yes continue with the virus scan.. and once you do all the settings...
did u stop the smtp service and rename the queue folder?
if not do that.. this will clear your spam emails...
As these settings are done now.. you will not get any more spams.. Trust me.. ;-)

-x
0
 

Author Comment

by:Kingsteve
ID: 23692729
oops i knew there was something else i couldnt do. i do not have the mailroot folder in the specified location. however, my mail store is on M: instead of C:, so the mailroot folder is on M: instead. I assume it is ok to change that, but i figured id better ask first.
0
 
LVL 17

Expert Comment

by:Suraj
ID: 23692810
Its ok.. no problem.. you can do that.. make sure you have enough space in that drive...
0
 

Author Comment

by:Kingsteve
ID: 23693230
yeah i do. im just going to rename that folder in the drive its in.
0
 

Author Comment

by:Kingsteve
ID: 23693932
I renamed mailroot to mailrootOLD. it looks like exchange made a new Mailroot folder. i have to leave work in an hour due to restrictions with the time i can be here in a week. i will be checking back here every so often if you have anything else for me. otherwise, thank you very much for your help. ill be sure to award points when i get a second.
0
 

Author Comment

by:Kingsteve
ID: 23694248
i just requested a delisting from CBL. it now says im not listed, but im still waiting. i tried to send an email to my hotmail account and it still bouncing back. how long do you think itll take after a delisting requst for their servers to let me through?
0
 
LVL 17

Expert Comment

by:Suraj
ID: 23694677
it usually takes 24-48 hrs...
0
 

Author Comment

by:Kingsteve
ID: 23694778
alright. well heres an update real quick. im actually able to send an email to one of my hotmail accounts and it got through. however ive sent a few to my domain account here and nothing is getting through.
0
 

Author Comment

by:Kingsteve
ID: 23694805
no emails at all are getting through actually.
0
 
LVL 17

Expert Comment

by:Suraj
ID: 23698333
what is your connecting Ip address ?
go to command prompt...
telnet maila.microsoft.com 25
ehlo

NOW WHAT IP DO YOU GET NEXT TO EHLO...? its the connecting ip.. not it down
go to www.mxtoolbox.com
and click on black list... put in your connecting ip there... see if you are black listed.......

-x
0
 

Author Comment

by:Kingsteve
ID: 23700499
alright, well it looks like its working now. i must have had to wait for, like you said, the 24-48 hours for everything to work properly again. i ran another check on mxtoolbox, and i am currently not listed on any black list. i will confirm on monday, that nothing has changed and ill post back.

once again, thank you for all your help.
0
 
LVL 17

Expert Comment

by:Suraj
ID: 23700563
No problem Buddy.
0
 

Author Comment

by:Kingsteve
ID: 23713248
Well as of right now, everything is working great. Still off blacklists and im able to send and receive external emails again. yet again, thanks for the help.
0
 

Author Closing Comment

by:Kingsteve
ID: 31548408
EE rocks.
0
 
LVL 17

Expert Comment

by:Suraj
ID: 23718227
 Good ;-)

-=@X-SaM@=-
0
 

Author Comment

by:Kingsteve
ID: 23733634
Ive been blacklisted again. I just checked mxtoolbox and now im on CBL, spamhaus and spamcop. what can i possibly do now??
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses
Course of the Month15 days, 20 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question