Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1416
  • Last Modified:

Ubuntu missing icons and menus

I have Ubuntu 8.10 loaded on my laptop. I recently tried to uninstall evolution mail and a few other things I did not think I needed. When I rebboted, I am greeted with just the picture of my desktop and no icons or menus present. I have tried alt +f2 and ctrl +alt + t, to get to the terminal with no luck. I pretty much can not do anything at all. I would hate to reinstall because I have VMWare installed and spent alot of time configuring windows xp and vista. When I put a cd in, that appears on my desktop and I can navigate a little bit. Any help is appreciated.
0
GTPD22
Asked:
GTPD22
  • 7
  • 4
1 Solution
 
Morne LateganCommented:
Might be that you deleted your Documents folder. If so:

Press CTRL+ALT+F1 to get to your console (instead of ALT+F1). Log in with your user. At the prompt, do "ls" and check to see if you have a Documents folder. If not, mkdir Documents and reboot. Nautilus needs your Documents folder to exist in order to display the icons.
0
 
GTPD22Author Commented:
I did as you suggested and the Documents folder was already there. I have been playing around and managed to get to the help screen (F1). While inside there I was able to get Firefox opened. I can navigate from site to site with no issues, If I shrink Firefox, it takes me back to a blank screen and I have to go inside the help folder to bring it back up. The menu bar at the top is missing as well and I am absolutely stuck. I forgot to mention this is the first dealing I have had with linux so I am clueless.
0
 
Morne LateganCommented:
This is a wild guess, but maybe nautilus was uninstalled as well due to a dependency or something. Try from the F1 console:

dpkg -l \*nautilus\*

If its not listed as installed ("ii" at the beginning of the line), try apt-get install nautilus
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Morne LateganCommented:
Make that:

sudo apt-get install nautilus
0
 
GTPD22Author Commented:
I tried that and it said nautilus was already at the most current version. I recall messing with a screen resolution setting prior to this happening. Im wondering if I just have the screen resolution so out of whack that the items are stretched off the screen?
0
 
Morne LateganCommented:
Try, from the console:

pkg-reconfigure xserver-xorg
0
 
Morne LateganCommented:
typo:

sudo dpkg-reconfigure xserver-xorg
0
 
GTPD22Author Commented:
Once I got to that screen I realized I had done that step already. I did it again and still no change. Looks like a fresh install may be the only option at this point.
0
 
Morne LateganCommented:
You're just missing some package. You can try

sudo apt-get install ubuntu-desktop

or

sudo apt-get --reinstall install ubuntu desktop

If all else fails and you have to reinstall, simply copy the virtual machines accross to another system, or to a removable drive, reload and copy them back. They'll run no probs on the new system.
0
 
GTPD22Author Commented:
Thnaks a ton. Ultimately the line "sudo apt-get install ubuntu-desktop" is what fixed it. As soon as I ran that code I saw all of the things I deleted being reinstalled. Upon a reboot everything is back to normal. Thanks again
0
 
Morne LateganCommented:
You're welcome :
0
 
SanktwoCommented:
I had the same problem on Ubuntu netbook remix 9.04 on an eeepc 900. The solutions above did not work for me. Like the original poster said, plugging in a cd brought up an icon and it was possible to play the cd but NOT to move the window around the screen. For me right-clicking on the desktop opened up a menu and allowed me to create empty files and launchers on the desktop. These I COULD move around. I am 100% sure I caused this problem by copying the whole of my original /home/ray filesystem from Xandros on top of the one created by the installation of Ubuntu. The next time I rebooted I also got a brown screen with no menus. I believe that it is not Nautilus that has failed but the window manager whatever that is on Gnome.

I fixed it by using the console (since I could not figure out how to use any of the gnome gui applications except console) as follows:
First get to a console. Right click on the empty desktop and select "create launcher". In "name" put anything e.g. "terminal" and in "Command" put "gnome-terminal". Hit OK. An icon should appear. Click on it and a terminal window should appear. Type:
sudo useradd -m newuser
You will be asked for a password, -m creates a new home directory and newuser is the user name, substitute one of your own.
then:
sudo passwd newuser
and you will be asked for a password for your new user. The above two steps can be done as one, but keep it simple...
You are not finished yet since this user is not permitted to do much and you have to add it to some groups to permit you (for example) to try to delete the original user and (hopefully) recreate it if you wish.
I am unsure about to which groups it actually needs to belong in order to do useful things. I added it to the same groups as the original user. To find that out I typed:
less /etc/group
which gives you a line per group (name before the first colon) then other stuff, then the usernames.  I used an editor to add ",newuser" whereever I found the old user. I had nano installed so used that. First backup the file:
sudo cp /etc/group /etc/group.backup
in case you nuke the file.
then:
sudo nano /etc/group
and use the nano keyboard commands to add ,newuser whereever you find your old username. Do not add blank lines or fiddle around with anything else.

I think that you can also add users to a group using "sudo adduser newuser oldgroup" (where "oldgroup" is one of the group names you found in /etc/group) but I did not do that (if you don't like editing files).

Next, if you have set your computer to autologin to the original username (ie. you did not get the opportunity to say which username to use), you will have to fix that as well.
This time backup /etc/gdm/gdm.conf thus:
sudo cp /etc/gdm/gdm.conf /etc/gdm/gdm.conf.backup
Then change the line which says "AutomaticLoginEnable=true" to "AutomaticLoginEnable=false" and do nothing else using nano.
Now when you reboot your computer you should be given the option to login to your "newuser" and that user should have a normal (empty) desktop in gnome.

Then you have to fix your original login directory files (or delete it all) if you want the original user back. Note that I had significant problems because, although I used the gnome administration system to remove the original user, and sure enough it vanished, I could not then re-create it using the gui because the administrative window said "user already exists use another name" despite the fact that it was not being shown on the list of users. I suspect that is because it tries to create a group of the same name, but fails to remove it when the user is removed. Just another annoying bug...(or feature if Ubuntu were Windows)

I re-created the original user after having deleted it using the gui by using the command line as shown above but using the -g switch of useradd to put the re-created user in the original group.

I hope that this helps users facing a blank Ubuntu screen without spending a whole day trying to sort it out like I did.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now