We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Unable to open an ACT database on a 2008 server domain. New ACT installation, never used before

Medium Priority
740 Views
Last Modified: 2012-06-22
Hi

I'm setting up a 2008 SBS server and domain for a customer who today handed me a copy of ACT 2009 (v11) and asked me to install it for him and setup access from 5 other PCs.  The server operates fine, the clients access the domain, files and shared resources fine.

I have no knowledge of ACT, and have installed it on the server and created a database which I have shared to the appropriate users. I have designated to share the db on the server, and a .PAD file has been created which appears to contain valid information as per name of server etc.

It opens and works fine from the server.  But from the client PCs, it comes up with "The database xyz could not be accessed. In order to access this database, check your network connection and verify that your database server is available ..."

The database is in a shared folder \\server\ACT , and on each client pc I have mapped a drive (Y) to the ACT folder.  So when opening the database on the client PC, it is Y:\dbname.pad

I have no idea how to fix this and know nothing of ACT.  Some pointers would be useful please.

Thanks
eMicros

Comment
Watch Question

Mike LazarusAct! Evangelist - CRM Consultant
CERTIFIED EXPERT

Commented:
The instructions for setting up a shared ACT! database on a network can be found here: http://blog.glcomputing.com.au/2009/02/sharing-act-network-or-sync.html

That particular error is common when ACT! can't properly connect. It can be a number of things... the error should be listed at the bottom of that post

Author

Commented:
Thanks for your comments

I have worked through that list, but nothing works.

Sorry :(

eMicros
Mike LazarusAct! Evangelist - CRM Consultant
CERTIFIED EXPERT

Commented:
I can guarantee it will be one of them.

But also, DON'T map the drive on the server, just use \\Server\ACT or copy the PAD file locally. MAPs can create multiple shares as per one of the issues in that article.

Can you post the contents of the PAD file?

If it's a Domain, what sort of access have you give, and to what folders?

Author

Commented:
I have removed the drive mapping and tried to opne directly from \\server\database but I get same error.
The db folder is shared, it needs to be obviously.

I have tried sharing to user names specifically and to "everyone"

The pad file is :

<?xml version="1.0" standalone="no"?>
<!DOCTYPE ACTDatabasePADFile>
<!--This file represents a Pointer to an Act Database or [PAD]-->
<ACTDatabase name="XYZ" host="XYZSERVER" location="C:\Data\ACT\XYZ.ADF" type="Sql" />

I have tried substituting host with ip address.

I cannot get it working.  This clien is on xp pro sp2.

Thaks for continuing to help with this

Mike LazarusAct! Evangelist - CRM Consultant
CERTIFIED EXPERT

Commented:
What permissions have you given to "Everyone" in the Share?

Author

Commented:
co-owner & full control / change / read in the share tabs
all ticked in the allow column on security tab (except special perms) an none in the deny columnn

i dont think this ia a problem with the share on this folder, the users can open text documents from within the same folder.  Perhaps there are other folders which need sharing?  It doesn't make much sense.
Mike LazarusAct! Evangelist - CRM Consultant
CERTIFIED EXPERT

Commented:
The users need full control on the Database folder and sub-folders

Author

Commented:
The database folder has full control perms for everyone, and so do all child folders and files

Author

Commented:
i have been on the phone to sage support and been through a number of things with no joy. they state that it is not supported on 2008 sbs and that is why it doesnt work.  has anybody else got this working under 2008 sbs?
Mike LazarusAct! Evangelist - CRM Consultant
CERTIFIED EXPERT

Commented:
Interesting that 2008 SBS isn't supported - http://www.act.com/2009/system/

I wonder what's special about SBS? I though it might just be because Exchange takes all available RAM and causes performance issues for ACT!, but maybe there's something else.

Have you tried disabling any firewalls and UAC?
Let's make sure SQL can be seen - from one of the client PCs, can you try a Telnet to the SQL port (1433)
  • From CMD Prompt
  • telnet <Machine_Name> <Port_Number>
  • If it has an error, it's either a SQL or firewall issue. If there's a blank screen, then that part should be ok and you can quit
Maybe, if you like, I might look at a GoTo Meeting session and see if I can get it working for you? I like a challenge :-)
Act! Evangelist - CRM Consultant
CERTIFIED EXPERT
Commented:
As discussed off-line, the other option is to look at the DEP settings as per:
 
http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=20124   

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Hurrah! Thanks GL, it was the DEP setting causing me the problem.  Good spot and thanks for your help.
Mike LazarusAct! Evangelist - CRM Consultant
CERTIFIED EXPERT

Commented:
I've aslo put the suggestion to Sage that the DEP KB article be added as one of the fixes for the general error as per the first KB.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.