We help IT Professionals succeed at work.

Reading drives with false Invalid Node Structure error Mac

Medium Priority
1,133 Views
Last Modified: 2013-11-10
I have a raid system on my mac that is reporting a false error of Invalid Node Structure. Because of this error, my mac can not read the drives, though the data and everything is still in tact. I have tried DiskWarrior to fix the error but DiskWarrior can not fix it, but it can allow me to read the drives to get the data off. It works perfectly because it mounts the drives as read only and I can just drag the files off onto another drive.

The problem I have is, though DiskWarrior allows me to read the drives, DiskWarrior opens my .DMG on the disc and makes them look like actual folders. It also will not let me copy these .DMG files off the drive while it will let me copy everything else off.

I am looking for a program that will let me open the drive as read only to copy the stuff off of it onto another drive and does not break down any of the .DMG files.
Comment
Watch Question

There are a 1000 ways to skin the technology cat.
CERTIFIED EXPERT
Commented:
You can try ProSoft http://www.prosofteng.com/products/data_rescue.php?PHPSESSID=2ce12a1d2458d6e45ec07d8201e994dd

Have you tried repairing your volume in Singe User mode?

  1. Boot holding the CMD+S keys
  2. at the prompt type fsck -f  It should find errors on your volume and automatically repair them
  3. when complete type reboot and hold CMD+V to view the boot process

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I have tried ProSoft's Data Rescue 2... the problem with that is that it checks the drives Bit for Bit and my drives are actually 1TB of available space (700GB used) that thinks it has 2TB of available space for hot swopping and upgrading... this causes some problems with it... with that said, Data Rescue 2 also says it will talk about a week to finish scanning the drives and when it does finish I am left with a lot of files I dont need and a huge pile of ones I do need all un-organized.
Irwin W.There are a 1000 ways to skin the technology cat.
CERTIFIED EXPERT

Commented:
Please try the steps for the BSD command line to try and repair your volume errors that I have mentioned.  I use this all the timeand works better than most utilities.

Author

Commented:
I will try that in a bit but I am kind of hesitant to doing it just because I want to keep writhing to the drives to a minimum and just read the data off of them. If you strongly think it will fix the problem, I will try it.
Irwin W.There are a 1000 ways to skin the technology cat.
CERTIFIED EXPERT

Commented:
I used it today on one of my users whose office and laptop is in Montreal and me in Toronto. Worked like a charm.

When complete, boot to your OS check/repair disk and permissions.

Author

Commented:
This is an external drive so I think "fsck -f [drive location]" in the terminal will work....
You can use Disk Utility to run a verify which should be a read-only operation.

To use fsck on a non-boot drive requires working with its device ID,
from there you can run it.

Eg
 # fsck_hfs /dev/disk1s3

But there is something really, really *off* when you say "that thinks it has 2TB of available space for hot swopping and upgrading"

If a drive is capacity is reporting incorrectly, how on earth would the drive assign that extra space for "hot swapping and upgrading" ? I think there's alot more here than you're telling us.

Author

Commented:
Its not a single disc, its a Raid 5 backup drive system with currently 4 discs. It is reported to my computer as a single 2 TB disc through the controller. Though the current capacity for data storage is 1TB (with about 700GB being used) I have it reporting to the computer that it is actually just a single 2TB disc so I can do hot upgrading with high capacity discs if I need to. The health of the system and actual space available and being used is ran though another program and not what the computer reports.

For what ever reason after a backup of one of my computer the whole system reported the error. I just need to copy the data off the drives onto another one to do do a full format of the system.

I have tried DiskWarrior which said it could not fix it because it was a critical error and was unable to wright to the disks but could read them so I can get my data off. That worked the best because it mounted the drive but it broke down all the .DMG files and would not let me copy them off but it would let me copy everything else off.

I have also tried Disk Utility which is no help at all, and Data Rescue 2 which just takes for ever and is a big mess.

I am really looking for something like DiskWarrior that will let me just explore the discs to copy stuff off of it onto another drive.
Irwin W.There are a 1000 ways to skin the technology cat.
CERTIFIED EXPERT

Commented:
Who is the maker of the raid controller OS X does not support RAID5 natively only raid 0,1, 0+1
Further to nappy_d's comment, this is probably nothing to do with OS X at all.

Indeed, who makes the controller and what management software do they provide you ?

Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.