[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1634
  • Last Modified:

Data Protection Manager 2007 - Tape Library not seeing drive in ADIC FastStor 2 - Problems with Drive Mapping Tool and DPMLA.xml

Ok, so here goes:

Trying to move tape backups from Symantec to Microsoft DPM.  The setup is a HP LTO Ultrim 2 Drive, in an ADIC FastStor 2 Robotic Library.
Server 2008 Standard, DPM 2007, DPM SP1 installed, DPM Hotfix 949779 Installed.

Trying to follow the instructions available at: http://technet.microsoft.com/en-au/library/bb795782.aspx

I stop the DPMLA service, and run the DPMDriveMapping.exe, and get the following error:

C:\Program Files\Microsoft DPM\DPM\bin>DPMDriveMappingTool.exe
Drive Mapping Failed.
Error Code is: 0x80070424, Error Message is: The specified service does not exist as an installed service.

From there, unable to figure out what service it claims to be calling on, I've moved on to manually creating a DPMLA.xml in the Microsoft Data Protection Manager\DPM\Config folder.
I hit ReScan in the DPM Administrator Console.
The Library appeared, with 8 tape slots (correct!) but no DRIVE to actually write with!

Both the Drive, and the Autoloader are visible in Device Manager.  Both have working drivers that have been proven working by Symantec successful tape backups.

Next, I've tried creating and editing the DPMLA.xml file myself, as the instructions say.
I've saved it in unicode, and hit rescan, and the DPM Console says nothing new.  The console does not display the serial number of the autoloader, even though its in the .xml file, and still no luck.

Now, I know that DPM is actually reading this file, because when I purposely save it as non-unicode format, and press Rescan in DPM, it throws an error that the file is not of the format expected.

So, My question is:
1:  What service is the tool calling on, so that I can get this to work?
2:  What is wrong with my xml file, and why isnt DPM seeing it change?
Microsofts Example of DPMLA.xml:
<?xml version="1.0" encoding="utf-16"?>
<LAConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/2003/dls/LAConfig.xsd">
  <DriveReMapInfo IsMannuallyMapped="true"> 
    <DriveLibraryAssociation>
      <Drive SerialNumber="HUL4B06579" SCSIPort="10" SCSIBus="23" SCSITargetId="80" SCSILun="4" DriveBayIndex="0" />
      <Library SerialNumber="2B41146637" SCSIPort="6" SCSIBus="5" SCSITargetId="0" SCSILun="1" />
    </DriveLibraryAssociation>
  </DriveReMapInfo>
</LAConfig>
 
My version:
<?xml version="1.0" encoding="utf-16"?>
<LAConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/2003/dls/LAConfig.xsd">
 <DriveReMapInfo IsMannuallyMapped="true">
  <DriveLibraryAssociation>
   <Drive SerialNumber="HUL4C04414" SCSIPort="5" SCSIBus="0" SCSITargetId="5" SCSILun="0" DriveBayIndex="0" />
   <Library SerialNumber="9Z3374417" SCSIPort="5" SCSIBus="0" SCSITargetId="0" SCSILun="0" />
  </DriveLibraryAssociation>
 </DriveReMapInfo>
</LAConfig>

Open in new window

0
Nathan P
Asked:
Nathan P
1 Solution
 
Nathan PSystems ArchitectAuthor Commented:
The whole problem, ended up being that I was using drivers that reported to be HP Ultrium LTO 2, but setting the drive to use just generic LTO drivers, seems to have fixed it.

Also, I had to remove the DPMLA.xml file, as once the drivers were right, it wasnt needed.


Also, the service that the DPMDriveMappingTool.exe is trying to call on is the Removable Storage Service, in Windows 2003Server and below, which no longer exists in Server 2008!

So, thats all.. I'll close it, but I wanted to leave it here for others as a reference.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now