We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Exchange server and Windows Mobile

sachiek
sachiek asked
on
Medium Priority
319 Views
Last Modified: 2012-05-06
Hi,
  We had an exchange server which was working perfectly. It was configured in such a way to receive email in Mobile.
  But while installing CRM we had to reinstall this Exchange server.
  Now after reinstalling Exchange svr, we are not able to receive the emails in mobile.
 
  This is Exchange server 2003 and CRM 3.0.
  Anyone got a solution please reply me asap.

Thanks in advance,
Sachi
 
Comment
Watch Question

Commented:
What error message you get. Try https://FQDN name of your mail server/oma from internal network and check you get access to mobile access. you can use above link with out ssl if not configured on your server.
Check event log and find out errors related to outlook mobile access or OMA.

Author

Commented:
Sorry the exchange server version is 2007

Commented:
Still try above and let us know

Author

Commented:
Are you referring to OWA?Outlook web access?
I could'nt find any think like OMA!

Commented:
For 2007 it is Activesync. Do you get any errors in event log under application event. can you share that event error.

Author

Commented:
Activesync is running fine..
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
If you can't receive emails in Windows Mobile then ActiveSync isn't working fine. That is what provides the email communication to WM devices.

Use a test account on the Microsoft test site and see what that flags:
https://www.testexchangeconnectivity.com

-M

Author

Commented:
Hi Mestha,
  When tested with the link you given I got the error "Exchange activesync test failed"
  Any clue how to proceed now.

Commented:
If you expan the test results it will show you  cause of failuers.

Author

Commented:
Please check the attached screenshot..

Author

Commented:
Please see the attached screenshot.
error1.JPG

Commented:
Sachiek
Just expand Additional details to findout exact erros. Also check on Tell me more link

Author

Commented:
Expanded screenshot.
error1.JPG
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
The authentication settings aren't correct on the virtual directories.
Reset the virtual directories to start with:
http://support.microsoft.com/default.aspx?kbid=883380

-M

Author

Commented:
is this the same steps for Exchange 2007?
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
I was basing on the original question which said 2003.

For 2007 you need to remove the ActiveSync VD using Remove-ActiveSyncVirtualDirectory. If you only have one web site then you can use

Get-ActiveSyncVirtualDirectory | Remove-ActiveSyncVirtualDirectory

rather than typing the full command list in.

To add it back in again use this command (presuming the web site is called "Default Web Site")

New-ActiveSyncVirtualDirectory -WebSiteName "Default Web Site"

-M

Author

Commented:
Well, I am not able to remove the directory. Always end up in error.

But did tried to modify the settings little bit based on owa iis settings.

Currently I am getting error as per attached screenshot.
Hope to solve this error with your help.

Error-1.JPG
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
That is also an authentication error.
If the command that I have posted gave an error then you will need to it the long way:

Remove-ActiveSyncVirtualDirectory

When it prompts for the identity that will usually be servername\Microsoft-Server-ActiveSync

-M

Author

Commented:
I had used this command.
Even with your update domaincontroller it is not simply removing. Always getting the error Domaincontroller could find this object in the serve xxxx.

I tried all sort of name for this domaincontroller. It is not going through.


Author

Commented:
how to find the domain controller exactly? Any clue?

Author

Commented:
Remove-ActiveSyncVirtualDirectory -Identity "Microsoft-Server-ActiveSync
(Default Web Site)"

I had tried this command too. Same error still.
Expert of the Quarter 2009
Expert of the Year 2009
Commented:
Prompts about the domain controller not finding the object means that you haven't got the identity information correct.
It has nothing to do with the domain controller itself.

However I didn't give you a complete command. Sorry about that.

Remove-ActiveSyncDirectory -identity "server\Microsoft-Server-ActiveSync (Default Web Site)"

where server is the name of your Exchange server.

If you run

get-activesyncvirtualdirectory |fl

and then scroll up the list of results, you will see what the identity is.

-M

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.