apache2 Invalid directory indexing option

recently, i reinstalled apache and used the old config files. However when i restart apache, it gives the error

Syntax error on line 11 of /etc/apache2/mods-enabled/autoindex.conf:
Invalid directory indexing option

this is line 11
IndexOptions FancyIndexing VersionSort HTMLTable NameWidth=* DescriptionWidth=* Charset=UTF-8

any ideas how to fix this?
krisdigitxAsked:
Who is Participating?
 
krisdigitxConnect With a Mentor Author Commented:
i fixed this temporarily by using .htaccess on the documentroot

AddCharset UTF-8 .htm
<Files "file1.htm">
AddCharset gb2312 .htm
</Files>
<Files "file2.htm">
AddCharset Shift_JIS .htm
</Files>
<Files "file3.htm">
AddCharset windows-1251 .htm
</Files>
0
 
krisdigitxAuthor Commented:
the problem is with Charset=UTF-8, if i remove it works,
0
 
caterham_wwwCommented:
The logic in the code is

        else if (!strncasecmp(w, "Charset=", 8)) {
            d_cfg->charset = apr_pstrdup(cmd->pool, &w[8]);
        }
        else {
            return "Invalid directory indexing option";
        }

don't know, why the comparison doesn't work (since it works for me on apache 2.2.11) and you got the "else"
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.