We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Shared Network Drive showing up as "blank" from other computers - worked fine yesterday

Medium Priority
638 Views
Last Modified: 2012-06-21
Strangest thing is happening. I have an external USB drive connected to one of our servers for backups. I have the other servers map to it's shared USB drive and proceed to backup directly to the drive. This method worked fine...for two days.

Now when I try to view the drive from other computers using \\xxxsrv0\g$ (G being the drive letter) all that pops up is a window that is completely blank. Also the NT Backups are failing because of this, it says it cannot find the media. When I try to view the drive from the computer it's actually connected to - voila! I can see everything!

What would cause the drive to appear blank on all the computers that map to it?
Comment
Watch Question

Commented:
Try with a normal share instead of using administrative share (\$g).
On the server create a new share like \\xxxsrv0\backup that points to drive G.

Author

Commented:
How do I do that with a drive? It only lets me share it as an administrative drive.

Commented:
- Go to the server where the drive is connected
- Open explorer and right click on the drive G
- Go to the Sharing tab and select Add New Share
- Configure the share name and don't forget the permissions (by default, Windows makes the access type Read-Only).

For example if you add the new share with name "NEW_SHARE", then on another machine you can access it by \\SERVENAME\NEW_SHARE

Try it first with permissions FULL on Everyone to see if works, and then fine tune the permissions to your needs.

Author

Commented:
Ok I shared it as a new share \\xxxsrv0\BackupDrive
I can now access this from the other computers via a mapped drive and see the contents. Weird thing is my Scheduled NTBackup is still failing for the same reason - say's it cannot find the media.
If I double click the backup script directly it runs fine. When I right click the scheduled task that points to the script and click "Run", it fails saying it cannot find the media.
I definitely verified that the computer CAN see the drive. What is going on?

Commented:
Probably you problem is in the task permissions. Try to change the user that runs the task.
On Scheduled Tasks, right click on the task, properties and then confirm the "run as" field.
Try to run it as administrator.

If the drive it correctly mapped, the scripts runs OK directly and not on scheduled tasks - the problem must be here...

Author

Commented:
It's running as a domain admin...

Author

Commented:
Also I'd like to mention, the NTBackup reports the attempted Scheduled Task as a failure because it could not find the media. So it definitely is attempting.

Commented:
...  One ore try (I've found this solution to an identical problem):

"Delete the scheduled task that is giving out the error and redo the schedule.
You maybe change the account which the task scheduler uses to log on to run that particular task.
When you schedule a job, and when it asks you to type in the credentials for the useraccount, make sure the account exists in the security database (or active directory) and make sure you typed in the correct password."

So, in your situation, try to delete the taks and create a new pointing to the same batch.
Anyway, NTBackup is VERY buggy and maybe the problem it's not yours.
In Server 2008 this tool is not included (wonder why?) =)
This makes no sense. I manually logged off another administrator I had logged on from home and now it is working. So the backup won't run if multiple people are logged on...nice.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
Maybe if someone is with opened files in the share, the backup cant run because it can't copy the files in use. One thing I'm pretty sure, it got nothing to do with multiple concurrent logins...

I believe it was a problem due the changes in the system. Probably if you had done a reboot in the machines everything was alright....
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.