[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cannot ping between Vlan's ASA5505

Posted on 2009-02-19
29
Medium Priority
?
2,854 Views
Last Modified: 2012-06-27
Dear,

I am trying to configure a new asa5505, here what i would like to achieve :
1. I have a LAN with IP 192.168.20.x configure on VLAN 1(inside)  that i would like to give access to a server located on VLAN2 10.4.120.1 port 6339 (outside).
2. I want the VLAN 1 to be able also to ping VLAN 2 for testing connectivity.
3. Is it possible for VLAN 2 to ping also the network on VLAN 1?
Here my current configuration

Thanks for your help
AIME
: Saved
:
ASA Version 7.2(3) 
!
hostname RNP-ASA
domain-name rnp.bi
enable password sT72sqFRyMwhHlYp encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.20.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.4.120.1 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name rnp.bi
same-security-traffic permit intra-interface
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 10.4.120.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.20.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:3377ab9fcb0ff27f2dfcd7d6200dae20
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

0
Comment
Question by:aime14
  • 15
  • 13
28 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23682574
1. I have a LAN with IP 192.168.20.x configure on VLAN 1(inside)  that i would like to give access to a server located on VLAN2 10.4.120.1 port 6339 (outside).

This should be working now.

2. I want the VLAN 1 to be able also to ping VLAN 2 for testing connectivity.

You need to allow ICMP:

access-list outside_access_in extended permit icmp any any
access-group outside_access_in in interface outside

3. Is it possible for VLAN 2 to ping also the network on VLAN 1?

Only if you present the real IP addresses to the outside network:

static (inside,outside) 192.168.20.0 192.168.20.0 netmask 255.255.255.0

The 10.4.120.x hosts will need a default gateway of 10.4.120.1 (assuming there is no router on the outside) if you go this route.  The 10.4.120.x hosts will now communicate with the VLAN1 hosts using their real IP addresses (192.168.20.x).
0
 

Author Comment

by:aime14
ID: 23682801
Thanks for your reply,
I still cannot ping from LAN 192.168.20.x to 10.4.120.x and vice versa.

I can only ping from my laptop (192.168.20.2) to 192.168.20.254 (e0/01)
And
From 10.4.120.10 ping 10.4.120.1 (e0/0)

here my new configuration :
: Saved
:
ASA Version 7.2(3) 
!
hostname RNP-ASA
domain-name rnp.bi
enable password sT72sqFRyMwhHlYp encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.20.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.4.120.1 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name rnp.bi
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 192.168.20.0 192.168.20.0 netmask 255.255.255.0 
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.4.120.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.20.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:ff0bac356f3db7aa76123c4d2bb4d720
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23682821
Is 192.168.20.254 your default gateway?  Is 10.4.120.1 the default gateway for 10.4.120.10?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:aime14
ID: 23682868
I don't have any router, no internet will be connected on this private network.
The gateway for 10.4.120.x is the outside port : e0/0 IP 10.4.120.1
The gateway for 192.168.20.x is the inside port : e0/1 IP 192.168.20.254

Thx

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23682938
Remove this as it is not needed.

conf t
no route outside 0.0.0.0 0.0.0.0 10.4.120.1 1

Well, this should be working.  Do you have windows Firewall enabled on these hosts?
0
 

Author Comment

by:aime14
ID: 23683154
Still cannot ping from my two laptops, i've disable the firewall on both laptops.



Here my new configuration
: Saved
:
ASA Version 7.2(3) 
!
hostname RNP-ASA
domain-name rnp.bi
enable password sT72sqFRyMwhHlYp encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.20.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.4.120.1 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name rnp.bi
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 192.168.20.0 192.168.20.0 netmask 255.255.255.0 
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.20.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:7d1cbdde3fc327c8501d723fce7d642f
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23683230
The config is fine.  You are absolutely positive that the 192.168.20.2 host has a default gateway of 192.168.20.254 and the 10.4.120.10 host has a default gateway of 10.4.120.1?

Can you post an ipconfig and route print from both PC's?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23683242
Also, on the ASA, do a "wr mem" and then "reload" to reboot it.
0
 

Author Comment

by:aime14
ID: 23683359
Attached the ipconfig and route Print.

THX




Laptop 1
 
Carte Ethernet Connexion au réseau local:
 
        Suffixe DNS propre à la connexion :
        Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
        Adresse physique . . . . . . . . .: 00-16-D4-A7-54-93
        DHCP activé. . . . . . . . . . . : Non
        Adresse IP. . . . . . . . . . . . : 192.168.20.2
        Masque de sous-réseau . . . . . . : 255.255.255.0
        Passerelle par défaut . . . . . . : 192.168.20.254
 
C:\Documents and Settings\ultra>
C:\Documents and Settings\ultra>route print
===========================================================================
Liste d'Interfaces
0x1 ........................... MS TCP Loopback interface
0x2 ...00 1a 73 0b 90 87 ...... Broadcom 802.11a/b/g WLAN - Miniport d'ordonnan
ement de paquets
0x20003 ...00 16 d4 a7 54 93 ...... Broadcom NetXtreme Gigabit Ethernet - Minip
rt d'ordonnancement de paquets
===========================================================================
===========================================================================
Itinéraires actifs :
Destination réseau    Masque réseau  Adr. passerelle   Adr. interface Métrique
          0.0.0.0          0.0.0.0   192.168.20.254    192.168.20.2       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      169.254.0.0      255.255.0.0     192.168.20.2    192.168.20.2       20
     192.168.20.0    255.255.255.0     192.168.20.2    192.168.20.2       20
     192.168.20.2  255.255.255.255        127.0.0.1       127.0.0.1       20
   192.168.20.255  255.255.255.255     192.168.20.2    192.168.20.2       20
        224.0.0.0        240.0.0.0     192.168.20.2    192.168.20.2       20
  255.255.255.255  255.255.255.255     192.168.20.2               2       1
  255.255.255.255  255.255.255.255     192.168.20.2    192.168.20.2       1
Passerelle par défaut :    192.168.20.254
===========================================================================
Itinéraires persistants :
  Aucun
 
 
LapTop2
Windows IP Configuration
 
 
 
 
 
Ethernet adapter LAN:
 
 
 
        Connection-specific DNS Suffix  . : 
 
        IP Address. . . . . . . . . . . . : 10.4.120.10
 
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
 
        IP Address. . . . . . . . . . . . : fe80::217:a4ff:fed8:f81f%7
 
        Default Gateway . . . . . . . . . : 10.4.120.1
 
 
 
Tunnel adapter Teredo Tunneling Pseudo-Interface:
 
 
 
        Connection-specific DNS Suffix  . : 
 
        IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%5
 
        Default Gateway . . . . . . . . . : 
 
 
 
Tunnel adapter Automatic Tunneling Pseudo-Interface:
 
 
 
        Connection-specific DNS Suffix  . : 
 
        IP Address. . . . . . . . . . . . : fe80::5efe:10.4.120.10%2
 
        Default Gateway . . . . . . . . . : 
 
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x20004 ...00 17 a4 d8 f8 1f ...... Broadcom NetLink (TM) Gigabit Ethernet - Packet Scheduler Miniport
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       10.4.120.1     10.4.120.10	  20
       10.4.120.0    255.255.255.0      10.4.120.10     10.4.120.10	  20
      10.4.120.10  255.255.255.255        127.0.0.1       127.0.0.1	  20
   10.255.255.255  255.255.255.255      10.4.120.10     10.4.120.10	  20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1	  1
      169.254.0.0      255.255.0.0      10.4.120.10     10.4.120.10	  20
        224.0.0.0        240.0.0.0      10.4.120.10     10.4.120.10	  20
  255.255.255.255  255.255.255.255      10.4.120.10     10.4.120.10	  1
Default Gateway:        10.4.120.1
===========================================================================
Persistent Routes:
  None

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23683378
That all looks good.  Did you try the "wr mem" and "reload" on the ASA?
0
 

Author Comment

by:aime14
ID: 23683454
yes i did, still no chance to ping between the two LAN

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23683486
You are sure these laptops aren't running anything that would block ICMP?

Ping each laptop from the ASA and see if that works to start with.
0
 

Author Comment

by:aime14
ID: 23689783
From the router i can ping the two laptops, i checked and there is nothing blocking ICMP.
How can i perform another test?
what is the command line to allow all the LAN on VLAN1 to access a server on VLAN2 10.4.120.1 port 6339
Regards
AIME
0
 

Author Comment

by:aime14
ID: 23689805
Does my configuration will allow the security level 0 (valn 2) to ping vlan 1 with security level 100?
For now, even Vlan 1 cannot ping host or port e0/0 on Vlan 2

Please help
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23690766
This is very strange.  The ASA is configured to allow ICMP both ways.

Add this:

conf t
logging bufferred debugging

Try a ping again to 10.4.120.10 and on the ASA do a "show log | i 192.168.20.2"  assuming 192.168.20.2 is the laptop you are using to ping with.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23690773
Also, remove these and try again.

conf t
no global (outside) 1 interface
no nat (inside) 1 0.0.0.0 0.0.0.0
0
 

Author Comment

by:aime14
ID: 23691364
Please attached the logs
thx for your help, hope to find a solution today!!!!
Plase find here the logs : RNP-ASA# show logging | i 192.168.20.2
%ASA-6-110002: Failed to locate egress interface for TCP from inside:192.168.20.2/4026 to 64.233.183.18/80
%ASA-7-710005: TCP request discarded from 192.168.20.2/4027 to inside:192.168.20.254/23
%ASA-7-609001: Built local-host inside:192.168.20.2
%ASA-7-609001: Built local-host NP Identity Ifc:192.168.20.254
%ASA-6-302013: Built inbound TCP connection 2 for inside:192.168.20.2/4027 (192.168.20.2/4027) to NP Identity Ifc:192.168.20.254/23 (192.168.20.254/23)
%ASA-7-710002: TCP access permitted from 192.168.20.2/4027 to inside:192.168.20.254/telnet
%ASA-6-605005: Login permitted from 192.168.20.2/4027 to inside:192.168.20.254/telnet for user ""
%ASA-6-110002: Failed to locate egress interface for TCP from inside:192.168.20.2/4026 to 64.233.183.18/80
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-302021: Teardown ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
%ASA-6-110002: Failed to locate egress interface for TCP from inside:192.168.20.2/4026 to 64.233.183.18/80
%ASA-6-302020: Built inbound ICMP connection for faddr 192.168.20.2/768 gaddr 10.4.120.1/0 laddr 10.4.120.1/0
RNP-ASA#
 
 
 
Here my new configuration
: Saved
:
ASA Version 7.2(3) 
!
hostname RNP-ASA
domain-name rnp.bi
enable password sT72sqFRyMwhHlYp encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.20.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.4.120.1 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone CAT 2
dns server-group DefaultDNS
 domain-name rnp.bi
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any 
access-list inside_access_in remark ACL in to EFT server
access-list inside_access_in extended permit tcp any host 10.4.120.181 eq 6339 log 
pager lines 24
logging enable
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
static (inside,outside) 192.168.20.0 192.168.20.0 netmask 255.255.255.0 
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.20.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:b0388e1beb3825a7286a1531244f1f34
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23691380
Remove this until things are working and then you can restrict traffic from the inside to the outside if desired.

conf t
no access-group inside_access_in in interface inside

From the logs, you are pinging the 10.4.120.1.  You can't ping this from the inside (only the outside).  Once you remove the access-group, ping 10.4.120.10 (the laptop on the outside) and post the "show log".
0
 

Author Comment

by:aime14
ID: 23691464
laptop inside :192.168.20.2 ----e0/1 IP:192.168.20.254 ---e0/0 IP 10.4.120.1 ---10.4.120.10 laptop outside.

how do you want me to do the ping?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23691520
From a command prompt on 192.168.20.2.

ping 10.4.120.10
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23691524
Make sure you remove the access-list first:

conf t
no access-group inside_access_in in interface inside
0
 

Author Comment

by:aime14
ID: 23691580
Dear,
After removing :no access-group inside_access_in in interface inside
the laptop 192.168.20.2 was able to ping the laptop : 10.4.120.10 and vice versa!!!!
: Saved
:
ASA Version 7.2(3) 
!
hostname RNP-ASA
domain-name rnp.bi
enable password sT72sqFRyMwhHlYp encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.20.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.4.120.1 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone CAT 2
dns server-group DefaultDNS
 domain-name rnp.bi
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any 
access-list inside_access_in remark ACL in to EFT server
access-list inside_access_in extended permit tcp any host 10.4.120.181 eq 6339 log 
pager lines 24
logging enable
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
static (inside,outside) 192.168.20.0 192.168.20.0 netmask 255.255.255.0 
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.20.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:20f556009c15d2d04e5609fa9aa7ca33
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23691597
Good.  You should also be able to connect to 10.4.120.181via port 6339.
0
 

Author Comment

by:aime14
ID: 23691702
Yes,
I was able to connect from 192.168.20.2 to my server IP :10.4.120.181via port 6339.
But i have to put the gateway on both side!!!
192.168.20.254 and 10.4.120.1
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23691757
Yes, or if you have a router on the inside and outside, you can put routes on those boxes or put host routes on the PC's.

On 192.168.20.x:

route add -p 10.4.120.0 mask 255.255.255.0 192.168.20.254

On 10.4.120.x:

route add -p 192.168.20.0 mask 255.255.255.0 10.4.120.1
0
 

Author Comment

by:aime14
ID: 23691835
Thank you so much, you deserve all the POINTS.
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 23691976
Hi aime14,

Thanks and you are welcome.

Looks like you are closing out the question instead of accepting one of my comments as the answer.  Can you cancel the close request and accept one of my comments as the answer.  This make things easier for the moderators.  Thanks!
0
 

Author Comment

by:aime14
ID: 23692062
I would like to accept a solution instead of closing, sorry for the mistake
0

Featured Post

How to change the world, one degree at a time.

By embracing technology, we can solve even the biggest problems—including the gender gap.  By earning a degree from WGU, you have an opportunity to gain the knowledge, credentials, and experience it takes to thrive in today’s high-growth IT industry.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let’s face it: one of the reasons your organization chose a SaaS solution (whether Microsoft Dynamics 365, Netsuite or SAP) is that it is subscription-based. The upkeep is done. Or so you think.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses
Course of the Month18 days, 17 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question