[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1016
  • Last Modified:

Error creating Reports on CRM 4

I am trying to create some custom reports on CRM 4, however I keep getting the same message:

Error Uploading Report
An error occured while trying to add the report to Microsoft Dynamics CRM.

Try this action again.  If the problem continures, check the microsoft dynamics crm community for solutions or contact your organisations Microsoft CRM Administrator.  

In the event log I get error 19969:
Web service request CreateReport to Report Server http://myserver/ReportServer1/ReportService2005.asmx failed with SoapException. Error: The Hyperlink expression for the textbox Table0_Details1 contains an error: [BC30277] Type character '!' does not match declared data type 'Microsoft.ReportingServices.ReportProcessing.ReportObjectModel.Fields'.

I appreciate any advice on this, thanks.
0
roscoe2008
Asked:
roscoe2008
  • 7
  • 4
1 Solution
 
gregowensCommented:
Well the first question to ask is what value do you have in the Hyperlink expression for your textbox called Table0_Details1? :)
0
 
gregowensCommented:
Also - does your report preview ok from Visual Studio? Sounds like you may not have refreshed the Forms collection from the Data tab in your solution, perhaps?
0
 
roscoe2008Author Commented:
'Well the first question to ask is what value do you have in the Hyperlink expression for your textbox called Table0_Details1?'

Where do I check this?  

I've built the report within CRM using the wizard so how do I preview it in VS?
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
gregowensCommented:
Ahh - assumption on my part I assumed you had used VS.
OK, so are all of your customisations (esp. those you are trying to query) published?
Also, are you on the latest Rollup Update for CRM?
 
0
 
roscoe2008Author Commented:
All I did was start the report wizard to create a report for user activities within CRM.  So from that I wouldn't think I need to publish anything.

Currently on Rollup 1 haven't installed Rollup 2 yet.
0
 
gregowensCommented:
What I meant was, do you have any customisations to your CRM deployment which have not yet been published?
Does this only occur when you use activities in your report or is it for all reports? If it is the former, can you describe your report in more detail so I can try to replicate the problem?
g.
0
 
gregowensCommented:
Also, in a similar issue, Experts Exchange user "crm_info" made the following suggestion:
 * Do you have multiple fields with a display name of "Subject" on any of the Activity entities (i.e. Email, Phone Call, Task, Appointment, etc)?  I've seen that having multiple fields with the same name can throw an error in reporting at times.
0
 
roscoe2008Author Commented:
I've installed Rollup 2 and have just been able to create a custom report!  
0
 
gregowensCommented:
Thanks for the update. Seemingly this is an issue that is not acknowledged by the Rollup Update 2 KB article, so glad that it works.
0
 
roscoe2008Author Commented:
Thanks for the help Greg, you pointed me in the right direction.

Ross
0
 
gregowensCommented:
Not probs Roscoe - not sure I really earned all the points there though, so thanks to you too. ;)
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now