We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Background color not showing in Firefox or Safari

Medium Priority
1,543 Views
Last Modified: 2013-12-16
Hi,
I'm using NetObjects Fusion 8 to create a simple, 6-page web-site.
I can't get my overall background color to show in Firefox or Safari, even though I've added it to the CSS stylesheets -- and I can't find anywhere else in the Fusion HTML that's over-riding the CSS settings.
If someone is willing to take a look at my site's code, please tell me how best to "package" it for uploading here.
Thanks in advance.
Don
Comment
Watch Question

shonkSoftware Engineer

Commented:
Can you post a link please?

Commented:
Sure:  www.enhealing.com

Thanks!
Software Engineer
Commented:
Your body tag is showing STYLE="background-color: transparent; background-image: none;"

What happens if you change this to STYLE="background-color:#99ccff; background-image: none;"

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
The inline style overrides the body elements in the CSS.

Shonks is right.

How about taking out the background-color: transparent;

It seems to fix it.



MD

Author

Commented:
The transparent setting is done somewhere in Fusion (I can't find where), and it won't let me change that part of the auto-generated html directly.  I just tried inserting background-color: #99ccff; in the part of the Body tag where Fusion allows me to edit, but Fusion just RETAINS the "transparent" setting and ADDS my insertion -- with no change to the appearance of the site.
So I need to find out where Fusion gets the transparent setting (it's not in the css files) and/or how to change it in the "protected" area of the auto-generated html.
PS: Thanks, Shonk, for your help!
You will have to edit the pagee in NetObjects. There should be a place to select edit page .

Kindly try and let us know what happens eventually

MD

Author

Commented:
Hi Shonk & MyDerrick,
I had to edit the auto-generated html in FrontPage, then FTP the files to the site host -- without opening the site in Fusion again (because Fusion ignores my edits to its auto-generated html).
So it's an annoying but simple workaround that I'll have to do each time I change the site.
Lesson learned: check the auto-generated html, not only the css files (which is what I did originally).
Many thanks to you both!
shonkSoftware Engineer

Commented:
Glad you got it sorted.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.