[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 260
  • Last Modified:

How to change the time in a domain

How do I set the time on pcs in my domain. I tried changing the time on my domain controller, but it changes itself back.
0
kenfitzgerald
Asked:
kenfitzgerald
  • 17
  • 9
  • 5
  • +1
1 Solution
 
wantabe2Commented:
The command
net time /querysntp
will report the manually configured NTP server even if it is not being used
because the Domain Hierarchy is being used.

Also check the System Event Log; after each restart, there is normally a log
entry from W32Time with Event ID 35 that reports where the time service is
currently getting time.

By default all domain members get their time from the domain controller.
0
 
tigermattCommented:

You need to ensure that the DC is properly configured to sync up with an external time server, first. At the DC, issue the command:

w32tm /config /syncfromflags:MANUAL /manualpeerlist:pool.ntp.org,0x8

This will sync the DC on regular intervals with pool.ntp.org, a global network of NTP time servers.

Then, the workstations should automatically pick up the time from the DC, since the DC will announce itself as an authoritative time resource. If workstations don't pick the DC up, they're probably configured for some other NTP server, and you should reset the W32Time service on them by running the commands

net stop w32time
w32tm /unregister
w32tm /register
net start w32time

-Matt
0
 
kenfitzgeraldAuthor Commented:
yes they are getting the time from my domain controller, but I am unable to change the time on my dc. each time I change it there it changes back.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
tigermattCommented:

That is probably because the DC is syncing its time from an external source, to ensure it is always up-to-date and a reliable time source. Why do you want to change the time at the DC?
0
 
kenfitzgeraldAuthor Commented:
Because the time at the dc is wrong. it's about 8 minutes off
0
 
kenfitzgeraldAuthor Commented:
I ran the command w32tm /config /syncfromflags:MANUAL /manualpeerlist:pool.ntp.org,0x8
but the time didn't change
0
 
tigermattCommented:

That command just updates the configuration. After you run it, run the command

w32tm /resync /rediscover

to actually cause the time to resync. If there's not a configuration problem, the time should sync up with the external NTP server and update itself.

-Matt
0
 
kenfitzgeraldAuthor Commented:
it still did not change the time
0
 
tigermattCommented:

You must have an NTP configuration issue, then. Run the following commands

net stop w32time
w32tm /unregister
w32tm /register
w32tm /config /syncfromflags:MANUAL /manualpeerlist:time.nist.gov,0x8 /update
net stop w32time
net start w32time
w32tm /resync /rediscover

-Matt
0
 
kenfitzgeraldAuthor Commented:
the time changed, but then it changed back.
0
 
tigermattCommented:
Something is wrong somewhere. My next course of action would be to check all your Group Policies and verify you don't have any of the policies in Computer Config > Administrative Templates > System > Windows Time Service either Enabled or Disabled (the policy there and the set of policies in the 'Time Providers' folder should all be 'Not Configured').

-Matt
0
 
kenfitzgeraldAuthor Commented:
they are all set to not configured. I have 2 domain controllers, one is server 2003 and the other 2008. could that have anything to do with this? I tried to run the commands on my 08 machine and got an access denied error, but I was logged in as a domain admin
0
 
tigermattCommented:

Which server is holding the PDC Emulator FSMO role?
0
 
kenfitzgeraldAuthor Commented:
where do I find that?
0
 
tigermattCommented:

Download and extract the Server 2003 Support Tools onto your 2003 DC. Go to Start > Programs > Windows Support Tools > Command Prompt and then enter the command

netdom query fsmo

The PDC Emulator will be reported along with the 4 other FSMO roles.

-Matt
0
 
kenfitzgeraldAuthor Commented:
I found it in active directory users and computers. the dc that ran the commands successfully is the pdc emulator.
0
 
tigermattCommented:

That's strange. Anyhow, try the same commands on the 2008 DC. You'd need to do it from an elevated command prompt (Start, type cmd, press Ctrl + Shift + Enter then execute commands).

-Matt
0
 
wantabe2Commented:
Is this server in an OU? Check the OU the to make sure no time GPO's are being applied. Also, now since you have ran those commands, check the event log on the server to see if it shows where its getting its time from.
0
 
kenfitzgeraldAuthor Commented:
there's only one gpo applied to these, and they are in an ou. the domain controllers ou. the event logs on the server 08 dc say they're getting there time from
 Description:
The time service is now synchronizing the system time with the time source time.nist.gov,0x8 (ntp.m|0x8|0.0.0.0:123->192.43.244.18:123).
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="W32Time" />
    <EventID Qualifiers="16986">35</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-02-19T17:31:53.000Z" />
    <EventRecordID>23322</EventRecordID>
    <Channel>System</Channel>
    <Computer>PATTON.IndyOrch.org</Computer>
    <Security />
  </System>
  <EventData>
    <Data>time.nist.gov,0x8 (ntp.m|0x8|0.0.0.0:123->192.43.244.18:123)</Data>
  </EventData>
</Event>
0
 
kenfitzgeraldAuthor Commented:
is there a way to have them not sync and I can set the time myself manually?
0
 
wantabe2Commented:
Yes, you can hack the registry. I will try & find the location on Win 2008. Keep in mind this is not recomended. I will try to find another solution for you before I post the registry hack.
0
 
kenfitzgeraldAuthor Commented:
both dcs are global catalog servers. would that effect this?
0
 
wantabe2Commented:
No, having multiple DC's in a domain is fine. I have over 40 in mine. That shouldn't effect anything. WHile I was searching online for you, I rememebred something in the event log you posted. It says it is syncing with time.nist.gov Are you saying the time is wrong or the time zone? time.nist.gov should be the best time to use.
0
 
kenfitzgeraldAuthor Commented:
I know multiple dcs is normal, but is having multiple global catalogs normal? as for the time it is 8 minutes fast according to everyone's cell phone here.
0
 
wantabe2Commented:
Let me re-frase...in a large network multiple global catalog servers are normal & fine. You can have too many or too few, both can cause performance issues. With my experience a GC needs to be on each subnet within a LAN/WAN. If you have two, that is fine to but I would go with any more.

As far as the time, do you have a BES server managing your cell phones for your organization?
0
 
kenfitzgeraldAuthor Commented:
No, no bes. these are private cell phones managed by there providers.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Is the DC a Virtual Machine?  If so, I had a similar problem that was caused by the fact that the Virtual Machine was set to sync the time with the physical host.  The DC updated, but the host updated the DC before the DC could update the member server host.  If it is a VM, then you should look through your settings for an option to disable that hot/guest time sync.
0
 
kenfitzgeraldAuthor Commented:
yes I'm using the new microsoft Hyper-V virtualization. would the settings be on the virtual server or the host and where would that be?
0
 
tigermattCommented:
That's interesting and something I've never come across. Thanks Lee!
0
 
kenfitzgeraldAuthor Commented:
I ended up changing the time on my host and everything else worked.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
That's a good SHORT TERM fix, but you need to locate the setting in HyperV because if you don't change it, you'll have the same problem in a few months.
0
 
kenfitzgeraldAuthor Commented:
where would that setting be? I didn't find the setting I just saw a hyper v time synchronization service on the virtual server. should I disable that on all my virtual servers?
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
The setting is NOT in the Virtual Server - it's in the SETTINGS for the virtual server under Integration Services.
0
 
kenfitzgeraldAuthor Commented:
Found it, thank you
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 17
  • 9
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now