Networking between Win XP and Fedora Linux PC's.

Posted on 2009-02-19
Last Modified: 2013-12-16
I have a 8 port LAN switch to which I have connected Win XP (latest service pack) box and and Fedora Core 6 box.

There is router that connects the switch to the Internet. All is working except I do not know how to network Win XP and Linux boxes, I mean what setup I need to run on both so that I can easily see the hard disk content of one PC to from another PC as well easily copy files from one to another  mainly using GUI interface rather than command line.
Also Win Xp is fully protected with McAfee anti-virus software.

Please be specific when providing this solution like exactly what steps needs to be taken.
Question by:zenguru
    LVL 29

    Assisted Solution

    you will have to install Samba in each fedora pc to share file between them.

    have a look this one

    you need to install samba in fedroa

    yum install samba

    after installing
    follow that article from : We Need A New User

    LVL 32

    Accepted Solution


    Samba is a nice option. If you just want to move files, then it is better recommended to use the SFTP which is ftp over SSH. WinSCP is a nice SFTP client;

    Author Comment


    I tried to follow the instructions given at

    but unfortunatley I ran into  several problems.  For example  the command
    useradd -d /home/test5 -s /bin/false -r test5
     is not recognized in fedora linux.

    Also I do not want to create another samba user but I want to use existing user
    'speed'  which is me and I have all my files there that I want to be able to access
    from windows pc. It is not clear from the article do I must create a new samba user
    (test5 user in the article)?

    In the /etc/samba/smb.conf as referred to in the article there was no section created
    for 'fred' which is already existing user on my linux box. So I do not know where to set the path as there are several other sections  that also have commented out path line.

    So I am at total loss.  Please  clarify these issues.

    LVL 29

    Assisted Solution

    thats just the article .....
    you dont have to as it is..
    your commetns : useradd -d /home/test5 -s /bin/false -r test5

    you dont have to type like this

    just useradd test5

    it will create all necessary

    your commethns :
    It is not clear from the article do I must create a new samba use

    No you dont have to create samba user

    if you Write Security as Share

    so those share would be avialable to every one

    let me sent you an simple smb.conf wait...
    LVL 29

    Assisted Solution


    create a direcory : mkdir myshare
    in smb.conf

    change this options

    security = user

    security = Share    

    create a share like this

    comment = myshare
    path = /myshare
    guest ok = yes
    guest only = yes
    create mask = 0666
    directory mask = 0777
    browseable = no
    writable = yes

    now restart samba

    you will have to open port 137,138,139 to allow pc request samba share from your linux pc

    also : do you hae selinux ??

    Author Comment

    I do not know anything about selinux. How do I know if i have it?

    I followed your instructions. I am assuming you mean create myshare dir from the root and not from  /home/speed.

    whats next now?

    Also how do I open ports 137 etc?
    LVL 29

    Assisted Solution

    for simplicity create the directory at main directory where /root, /var , /etc/

    dont create under /home/speed, other wise user would not able to see those share in that case you need to implemetnation authentciation ..

    type :

    tel me does it show , enabled or diabled

    do you have iptables installed ?? if you dont have too much rules then just flush your iptables

    iptables --flush

    then from a windows pc

    do telnet

    telnet your-linux-pc-ip  139

    tel me if you can connect

    i will be off for couple of hours as my office is finshed, let me know the outcome


    Author Comment

    I typed sestatus in linux terminal window, I get the error:
    bash: sestatus: command not found

    both as root and as regular user.

    I did iptables --flush   in linux box.

    on windows  command line   doing telnet 139

    the window seems to kind of hang and everything is black and try to type anything it does not show but the cursor moves.


    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now