How do i keep a mailbox but stop incoming email in Exchange 2007

I have several employees that have left the company.  i'd like to keep their mailboxes online in a secondary mailbox store so that those left behind can access it quickly, I can control access, etc.  I've already moved them to the new store.  In 2003, I could disable the account in AD and the mailbox would not accept any more mail.  That doesn't work in 2007.  The only obvious option is to "Disable" the mailbox but that sets it up to be removed.  How do I disable the mailbox so that new email is bounced back, my mailboxes don't continue to grow, but they can stay online for access until I decide to archive them?  Thanks!
SKeezotAsked:
Who is Participating?
 
MesthaCommented:
Having played around with this, it would seem that Exchange has been designed on the "Everyone accept <list>" model - so it will accept email from everyone or or a list, or reject email from none or a list. What you would prefer is the opposite. Reject email from everyone but the list.

The only suggestion I can make is to apply a restriction using your equivalent of "All Staff" and also enable the option to require the senders to be authenticated.
Another option would be a group with no members as the "Accept email from" list.

-M
0
 
MesthaCommented:
Hide the mailbox from the GAL, then change the message delivery restrictions on the Mail Flow tab of the Properties of the user.

-M
0
 
SKeezotAuthor Commented:
I had them hiddens so that's done.  In the Mail Flow tab, is there a way to Restrict email from "all" or do I "only accept email from the list" and leave the list empty?  I tried the "only accept" approach and then sent an email.  I expected to get an undeliverable message but didn't.  Thanks
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
gupnitCommented:
Hi,
Choose restrict from all
Cheers
Nitin
0
 
MesthaCommented:
You want an empty list. However do note that it will not be effective immediately, as Exchange caches permissions. It can take two hours before a change is seen. I think restarting the transport service should make it refresh though.

-M
0
 
SKeezotAuthor Commented:
I've restricted incoming email to the list.  The list is empty.  I've waited anywhere from hours to days and it does not keep email from coming into this user's mailbox.  Any other ideas?
0
 
MesthaCommented:
Did you restart the transport service?

-M
0
 
SKeezotAuthor Commented:
This is so stupid.  I has to be easier than this.  I can check the box that says "Accept messages from...Only senders in the following list" under Delivery Restrictions.  i leave the list empty (there is no "restrict all") and hit OK.  The Apply button never becomes active.  It will not save the changes unless I put something in the list.  There has got to be some way to have a mailbox available for users to access it and not allow any new email to be received into it.  In 2003, you simply disabled the mailbox.  If I disable it in 2007 it says it's marked for deletion.  I don't want to delete it and frankly I don't trust 2007 that it won't deliete it. Please HELP
0
 
SKeezotAuthor Commented:
FINALLY, thank you so much.  I created an empty distribution list and added it to the "Only accept email from" list.  Sent the test and it came back undeliverable.  Thank you very much.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.