OleDbConnection just hangs..

Hi - I have an asp.net app that reads an Excel workbook using Jet.OLEDB. The live environment is a hosted server (W2003). This has all worked fine for 2 years+. Now when I run it, the system variously hangs or goes in a cpu-intensive loop - it never gets beyond "conn.Open()". I can't get any error message, and there's nothing in the event-log.

My code is exactly the same as before, and it runs fine in my dev environment and on another (totally different) hosted server. So obviously, I'm figuring that there's something wrong with the environment on the live server.
Does anyone have any ideas on how I might get more information on what's going on and/or how to check the install of Jet/OLEDB? (obviously, I've rebooted...)

Thanks,
Paul.
connstr = "Provider=Microsoft.Jet.OLEDB.4.0;" & _
               "Data Source=" & FullPath & ";" & _
               "Extended Properties=""Excel 8.0;HDR=NO;IMEX=1""" 
 Dim conn As New OleDb.OleDbConnection(connstr)
  WriteToMYLogFile("here22")
   Try
    conn.Open()
     WriteToMyLogFile(here23")
     ....
Catch ex As OleDb.OleDbException
   .......

Open in new window

pw911Asked:
Who is Participating?
 
grayeConnect With a Mentor Commented:
OK...it does look like IIS is running in the 32-bit compatibillity mode.   So, that's not the problem.
What's the value of FullPath in your example?
0
 
grayeCommented:
You don't suppose that they've upgrade to a 64-bit version of Windows 2003?
I think you'll have to ask the hosting company for more details....
0
 
pw911Author Commented:
It IS 64-bit W2003, but it always has been. Are you aware of any incompatibilities?

Paul.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
grayeCommented:
Yes... there is no 64-bit version of the OleDB driver, so your program can not run on any 64-bit version of windows.
This is a known issue, and Microsoft has publicly stated that they will NOT produce a 64-bit version of the OleDb driver
0
 
pw911Author Commented:
The hosting company has confirmed (as I pretty much knew) that the OS has always been W2003 64-bit. Also, of course, I KNOW that this used to work. Any thoughts on any simple 'test-bed', etc. I can create to get more information on what is going on? Thanks.
0
 
grayeCommented:
Ask them if they've recently changed the IIS operating mode to 64 bits...   I bet that's what has changed that has broken your code.
0
 
pw911Author Commented:
Thanks for your help. I ran Cscript c:\inetpub\adminscripts\adsutil.vbs GET W3SVC/Apppools/enable32bitapponwin64
This gives the result "TRUE".  Does this indicate 32 or 64-bit?

When asp.net throws an error, it indicates "Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210 "

In the metabase, the only reference is
<IISApplicationPools  Location="/LM/W3SVC/AppPools"
...
   Enable32BitAppOnWin64="TRUE"

In IIS Web Service Extensions, I see:
asp.net v1.1.4322               Allowed
asp.net v2.0.50727              Prohibited
asp.net v3.0.50727 (32-bit) Allowed
0
 
pw911Author Commented:
unresolved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.