• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3290
  • Last Modified:

WPA2 setup on Cisco 1130AG Access Point

I have a Cisco 1130AG access point that is currently running WEP security.  Our company wants to migrate to WPA2 and what I would like to do is run 2 seperate SSID's...  one with WEP and the other with WPA2.  Is this possible?  We have hundreds of wireless devices that we will need to switch over, and if we could run the two seperate SSID's that would allow us to migrate over to WPA2 gradually.  We plan to use a RADIUS server for authentication through WPA2 with PEAP.  Also, I'm wanting to run a seperate VLAN for voice and data traffic.  (We have some wireless IP phones)  I'm posting the config of one of my APs.  Any ideas on how I can configure WPA2 on this AP?
Current configuration : 2504 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname wpa2testap
!
enable secret 5 $1$WQ0l$S4B2wETC2iGJiTYdhR19f/
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip domain name mycompany.com
ip name-server x.x.x.x
ip name-server x.x.x.x
!
!
!
dot11 ssid 123WireLess
!
dot11 ssid 123Wireless
   vlan 1
   authentication open
!
dot11 ssid voicewireless
   vlan 5
   authentication open
!
dot11 arp-cache optional
power inline negotiation prestandard source
!
!
username Cisco password 7 00261B150674
username admin password 7 01425434570153
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 shutdown
 !
 encryption vlan 1 key 1 size 128bit 7 CABC2D68735F41E7224C742CBAFD transmit-key
 encryption vlan 1 mode wep mandatory
 !
 ssid 123Wireless
 !
 ssid voicewireless
 !
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 !
 encryption vlan 1 key 1 size 128bit 7 389AB109271D1DC78774864F4A95 transmit-key
 encryption vlan 1 mode wep mandatory
 !
 ssid 123WireLess
 !
 dfs band 3 block
 channel dfs
 station-role root
!
interface Dot11Radio1.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address x.x.x.x 255.255.255.0
 no ip route-cache
!
ip default-gateway x.x.x.x
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
snmp-server community serv1 RO
snmp-server community serv2 RW
snmp-server enable traps tty
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 password 7 01405354580153
 login
!
end

Open in new window

0
woodas26
Asked:
woodas26
  • 2
  • 2
1 Solution
 
ciscoguy69Commented:
The answer is Yes, you can run both. The configuration is more complex as you need to define the server for authentication and the trustpoint for certificates and the SSID. You will need a separate SSID for the phones as you will most likely want to set QOS values for them. If you want to post the cert server IP, the authentication server, and the SSID / VLAN mappings you want to use, I can give you the config.
0
 
woodas26Author Commented:
I'd rather not post server IPs on a public forum...  Can you just do 10.35.##.## where you need to enter the RADIUS server IP?  As far as the vlan to SSID mappings, I am planning on having SSID wpadata mapped to vlan 2 and wpavoice mapped to vlan 6.

Thanks,
Andrew
0
 
ciscoguy69Commented:
Since I didn't see the VLAN 5 stuff in the config, I added that too. You will also want to set up the trustpoint if you want to use a common cert server. I did not include the trustpoint config because there is alot of sensitive information that is exchanged in that process and it differs based on the type of server. If you use  a Microsoft server for certs, just remember you will need to install MSCEP to pull them and enroll from Cisco devices. The config below will work for most EAP models.
 
Current configuration : 2504 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname wpa2testap
!
enable secret 5 $1$WQ0l$S4B2wETC2iGJiTYdhR19f/
!
aaa new-model
!
!
aaa group server radius rad_eap
 server 10.35.0.1 auth-port 2012 acct-port 1646
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
 server 10.35.0.1 auth-port 2012 acct-port 1646
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authentication enable default enable
aaa authorization exec default local
aaa authorization commands 0 default if-authenticated
aaa authorization commands 15 default local
aaa accounting network acct_methods start-stop group rad_acct
!
aaa session-id common
!
resource policy
!
ip subnet-zero
ip domain name mycompany.com
ip name-server x.x.x.x
ip name-server x.x.x.x
!
!
!
dot11 ssid 123Wireless
   vlan 1
   authentication open
!
dot11 ssid voicewireless
   vlan 5
   authentication open
!
dot11 ssid wpadata
   vlan 2
   authentication open eap eap_methods
   authentication key-management wpa version 2
   accounting acct_methods
!
dot11 ssid wpavoice
   vlan 6
   authentication open eap eap_methods
   authentication key-management wpa version 2
   accounting acct_methods
!
dot11 arp-cache optional
power inline negotiation prestandard source
!
!
username Cisco password 7 00261B150674
username admin password 7 01425434570153
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 shutdown
 !
 encryption vlan 1 key 1 size 128bit 7 CABC2D68735F41E7224C742CBAFD transmit-key
 encryption vlan 1 mode wep mandatory
 !
 station-role root
!
encryption vlan 2 mode ciphers tkip
!
encryption vlan 6 mode ciphers tkip
!
 !
 ssid 123Wireless
 !
 ssid voicewireless
 !
 ssid wpadata
 !
 ssid wpavoice
 !
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.2
 encapsulation dot1Q 2
 no ip route-cache
 bridge-group 2
 bridge-group 2 subscriber-loop-control
 bridge-group 2 block-unknown-source
 no bridge-group 2 source-learning
 no bridge-group 2 unicast-flooding
 bridge-group 2 spanning-disabled
!
interface Dot11Radio0.5
 encapsulation dot1Q 5
 no ip route-cache
 bridge-group 5
 bridge-group 5 subscriber-loop-control
 bridge-group 5 block-unknown-source
 no bridge-group 5 source-learning
 no bridge-group 5 unicast-flooding
 bridge-group 5 spanning-disabled
!
interface Dot11Radio0.6
 encapsulation dot1Q 6
 no ip route-cache
 bridge-group 6
 bridge-group 6 subscriber-loop-control
 bridge-group 6 block-unknown-source
 no bridge-group 6 source-learning
 no bridge-group 6 unicast-flooding
 bridge-group 6 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 !
 encryption vlan 1 key 1 size 128bit 7 389AB109271D1DC78774864F4A95 transmit-key
 encryption vlan 1 mode wep mandatory
 !
 ssid 123WireLess
 !
 dfs band 3 block
 channel dfs
 station-role root
!
interface Dot11Radio1.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1.2
 encapsulation dot1Q 2
 no ip route-cache
 bridge-group 2
 bridge-group 2 subscriber-loop-control
 bridge-group 2 block-unknown-source
 no bridge-group 2 source-learning
 no bridge-group 2 unicast-flooding
 bridge-group 2 spanning-disabled
!
interface Dot11Radio1.5
 encapsulation dot1Q 5
 no ip route-cache
 bridge-group 5
 bridge-group 5 subscriber-loop-control
 bridge-group 5 block-unknown-source
 no bridge-group 5 source-learning
 no bridge-group 5 unicast-flooding
 bridge-group 5 spanning-disabled
!
interface Dot11Radio1.6
 encapsulation dot1Q 6
 no ip route-cache
 bridge-group 6
 bridge-group 6 subscriber-loop-control
 bridge-group 6 block-unknown-source
 no bridge-group 6 source-learning
 no bridge-group 6 unicast-flooding
 bridge-group 6 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.2
 encapsulation dot1Q 2
 no ip route-cache
 bridge-group 2
 no bridge-group 2 source-learning
 bridge-group 2 spanning-disabled
!
interface FastEthernet0.5
 encapsulation dot1Q 5
 no ip route-cache
 bridge-group 5
 no bridge-group 5 source-learning
 bridge-group 5 spanning-disabled
!
interface FastEthernet0.6
 encapsulation dot1Q 6
 no ip route-cache
 bridge-group 6
 no bridge-group 6 source-learning
 bridge-group 6 spanning-disabled
!
interface BVI1
 ip address x.x.x.x 255.255.255.0
 no ip route-cache
!
ip default-gateway x.x.x.x
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
radius-server attribute 32 include-in-access-req format %h
radius-server host 10.35.0.1 auth-port 2012 acct-port 1646 key 7 06150A225E4B1D
radius-server vsa send accounting
snmp-server community serv1 RO
snmp-server community serv2 RW
snmp-server enable traps tty
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 password 7 01405354580153
 login
!
end
0
 
woodas26Author Commented:
Thanks for your help!
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now