The snipping tool is not working on your computer

This is a real annoyance. I am running Windows Vista Pro SP1, with all the latest updates and patches. For some reason, when trying to use the Snipping tool, i get this message, "The snipping tool is not working on your computer. Restart your computer and try again..." After rebooting, it will work fine, but then, after awhile it will start doing the same thing again. I've tried disabling it in the control panel and re-enabling it, but it still does it. I've read on some forums that running the Office Diagnostics fixes the problem, but it doesn't fix mine. I also noticed that when I tried to do a normal print screen and paste in the Paint program it gives me this error, " The information on the Clipboard can't be inserted into Paint" I noticed that they both stop working at the same time. I've tried copying over clipbrd.exe from an XP machine, but that just tells me that the Clipbook service is unavailable, which I couldn't find in my services utility. So I am at a loss. I read on several forums with issues similar to mine, but no solutions that fix my particular problem. Any help would be appreciated.

Here are my specs:
HP Compaq dc7800
Intel Core 2 Quad CPU Q6600@2.40Ghz
3GB RAM
Nvidia GeForce 7600 GS 512MB
nmoreno9Asked:
Who is Participating?
 
nmoreno9Author Commented:
Alrighty, I figured out what the problem was. It was in fact a printer issue. I currently use Photoshop and I noticed that when I tried to open more than one file, it would crash. After doing some research as to why it was crashing, I come to find out, that if you have a network printer that is no longer connected or working properly, it could cause Photoshop to crash when trying to open multiple files. So I thought, maybe that was causing my Snipping Tool issue as well. And sure enough, after deleting all my network printers, I haven't had the Snipping Tool crash, it's been since Friday.

I appreciate everyone's help and input.
0
 
tl121000Commented:
increase your Virtual memory and see what happens
0
 
tl121000Commented:
check out number #2
 
I believe the snippit is  max your virtual memory...
 
this might help
 
http://www.vistax64.com/tutorials/141940-clear-clipboard-shortcut.html
 
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LeeTutorretiredCommented:
Go to Programs and Features in Control Panel, then click on the link for Turn Windows features on or off, then make sure that Tablet Pc Optional Components has a check mark next to it.  The Snipping Tool will not work unless that feature is turned on.
0
 
nmoreno9Author Commented:
tl121000:
I tried the number #2 option, but it didn't work. I also increased my virtual max from 3GB to 5GB, but I'm thinking 3GB should be enough. It used to work fine before, I'm just wondering if an update messed with something. BTW, I can still copy and paste images and text, I just can't take screenshots or use the Snipping tool.

LeeTutor:
The Tablet Pc Optional Components is checked. When I reboot the PC everything works fine, it just stops working after awhile.

Thanks for the input so far.
0
 
LeeTutorretiredCommented:
Does this happen in safe mode, too?  If not, it may be a startup program or driver used in normal mode but not in safe mode.  In Windows 98/ME/XP/Vista, you can choose which programs are run at startup by using the Microsoft Configuration utility:  click on the Start button, choose Run, type in MSCONFIG (doesn't need to be all capitals), click OK.  Choose the Startup tab, deselect programs to run at startup by removing the check mark.  In Windows 9x/ME, you may need to disable just about everything except Explorer, ScanRegistry and SysTray.  In Windows XP/Vista, just click on the button for Disable All. Reboot and see if the problem goes away.  If it does then re-enable the startup programs one (or a few) at a time, reboot, and when the problem occurs again, there is your culprit.  If you have a great number of apps to narrow down on in trying to track down the culprit, do it instead by dividing up the loading programs into successively smaller halves:  disable half of them; if the problem doesn't go away, then the offending app is within the other half, so divide that group into half; or if the problem does go away, then the disabled group contains the offender, so again narrow down by dividing in half.  

In Windows XP/Vista: If the problem continues to come up with all startup programs disabled, then it is probably a driver or service.  You can click on the Services tab in MSCONFIG, click on the button for Hide All Microsoft Services, leaving only third-party services displayed, then try turning them off in the same way you did for startup programs.  Finally, if third-party services are eliminated from being the cause of the problem, you could try narrowing down on Microsoft services in the same way.
0
 
Alan HendersonRetired marine engineerCommented:
Also try Vista System File Checker to restore/repair missing or corrupt Windows files:

Click Start » All Programs » Accessories.
Right click Command Prompt.
Select Run as Administrator.

At the command prompt type
sfc /scannow (dont miss the space before the /)
Click OK.

You may need your Vista DVD if prompted for SFC.
0
 
nmoreno9Author Commented:
vallis:

I will try the sfc /scannow . I will let you know if it works.
0
 
LeeTutorretiredCommented:
nmoreno9, any feedback?  Have you tried safe mode and/or MSCONFIG?
0
 
nmoreno9Author Commented:
Vallis:
I tried your solution, and it hasn't fixed the issue.

LeeTutor:
I will try your solution next.
0
 
LeeTutorretiredCommented:
nmoreno9, how is it going?
0
 
cking22001Commented:
Well, that sounds crazy. If you do some searching you WILL find that the snipping tool does stop working for some people. I deleted my network printers and it still happens.

Sometimes if I wait long enough, the snipping tool starts to work again. Sometimes the process shows up in task manager and killing it off  sometimes works.

I feel the snipping tool is Vista's killer app. It sucks to not be able to rely on this. I will award someone 1 million points if they can figure out what is going on.  :)
0
 
Alan HendersonRetired marine engineerCommented:
@ cking22001
If you need a real snipping tool try Snagit.
http://www.techsmith.com/screen-capture.asp
worth every penny of $49.95 and maybe even a million points.
:o)
0
 
The_Big_TunaCommented:
This solution worked!!!  Broken network printers caused the issue!  
0
 
nmoreno9Author Commented:
Well, much to my chagrine, the issue came back, no matter what I did to the printers. So I have been dealing with the Snipping Tool issue for months again. Until now. I finally found the solution. I tried this about three weeks ago, and I haven't had the problem since. Apparently you have to set or increase the IRPStackSize parameter in the registry. I guess the value of 15 is not enough, and only values in the range of 16 to 25 solved the problem. Try 16 first. The most successful values seem to be 16 and 18. And don't forget to reboot after each change, because only that makes the new value effective. This is what I did:

Here is the offending registry value:

HKEY_LOCAL_MACHINE
 \SYSTEM
  \CurrentControlSet
   \Services
    \LanmanServer
     \Parameters
IRPStackSize DWORD 0x0000000f (15)

Check for the presence of the value named IRPStackSize. If it doesn't exist, create it as type DWORD and make sure you have the capitalization absolutely correct (5 upper case, 7 lower case characters), because the system strangely seems to depend on that. Make sure also that you haven't by mistake added a leading or trailing space as described in this comment below.

With base set to decimal, enter the value 16 or higher. 15 is the default, so entering 15 should have the same effect as removing that value altogether.

Reboot the computer.
Here is the complete article, it wasn't exactly the problem I was having, but it fixed my particular issue. I went ahead and copied and pasted certain snippets of the article above to make a long story short. Here is the link:

http://winhlp.com/node/40
1
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.