PIX 515E - Route traffic to different interfaces

Posted on 2009-02-19
Last Modified: 2012-05-06
I've got a PIX 515E with 6 interfaces - we've got a device on eth2 that needs to have http and https forwarded to it.  I've set the ACLs and the static entries, and still can't pass any traffic.  I can ping the host behind eth2 as well as to the outside and to the internal LAN from the console.

PIX Version 7.2(2)
interface Ethernet0
 nameif outside
 security-level 0
 ip address <outside_ip>
interface Ethernet1
 nameif inside
 security-level 100
 ip address
interface Ethernet2
 nameif eth2
 security-level 0
 ip address
interface Ethernet3
 no nameif
 no security-level
 no ip address
interface Ethernet4
 no nameif
 no security-level
 no ip address
interface Ethernet5
 no nameif
 no security-level
 no ip address
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
access-list outside-coming-in extended permit tcp any host <outside_ip> eq www
access-list outside-coming-in extended permit tcp any host <outside_ip> eq https
access-list outside-coming-in extended permit tcp any host <outside_ip> eq 8200
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu eth2 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm-522.bin
no asdm history enable
arp timeout 14400
static (eth2,outside) tcp interface https https netmask
static (eth2,outside) tcp interface 8200 8200 netmask
static (eth2,outside) tcp interface www www netmask
access-group outside-coming-in in interface outside
route outside <gateway_ip> 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
console timeout 0
class-map inspection_default
 match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
service-policy global_policy global
prompt hostname context
Question by:brianunc
    LVL 43

    Accepted Solution

    Add this:

    conf t
    same-security-traffic permit inter-interface
    LVL 3

    Author Closing Comment

    You are a genius.  Thanks so much JFredrick.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
    There are many useful and sometimes not well documented or forgotten IOS or ASA/PIX commands. See IPE article here , there was also one on PacketU and on Cisco Tips & Tricks. Below are my favorites. I give also a few most often used for Cisco IPS an…
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now