[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

OpenPbs configure error

Posted on 2009-02-19
11
Medium Priority
?
1,022 Views
Last Modified: 2013-11-13
this is the error message i receive when i configure OpenPBS (OpenPBS_2_3_16) with the following parameters

./configure --set-default-server=localhost.localdomain --with-scp --set-server-home=/usr/local/spool/pbs --disable-gui
creating cache ./config.cache
checking host system type... Invalid configuration `x86_64-pc-linux-gnuoldld': machine `x86_64-pc' not recognized

Invalid configuration `x86_64-pc-linux': machine `x86_64-pc' not recognized
configure: error: config.sub failed on x86_64-pc-linux


this is the output of the uname -a command

Linux localhost.localdomain 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64 x86_64 x86_64 GNU/Linux

Please tell me how can i overcome this.
Thanks in advance
0
Comment
Question by:imagineer12
  • 3
  • 3
  • 2
8 Comments
 
LVL 29

Expert Comment

by:Michael Worsham
ID: 23696859
It sounds like something in the configuration script doesn't see your os type correctly or is misidentifing it.

Can you attach a copy of the configuration script here so we can take a closer look?
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 23699081
I fetched OpenPBS_2_3_16 and tried this myslef, with the same results as your good self.
The problem is the ./buildutils/config.sub has no knowledge of X86_64 architecture. In other words, the package does not build for x86_64.
The way around this is to build it as a 32-bit application. For that, you need two main features:
1. Your x86_64 system contains 32-bit runtime support (shared libraries in /lib rather than in /lib64 or /usr/lib64...). On my system, I have kept that moderately up to date, as required.
2. You have a 32-bit bootable Linux on another partition. In that system, your architecture would show up as i686-pc which would be recognised. Again I have one of these, updated from time to time as erquired.
From your question, I imagine you don't have these facilities right now. They are a bit of work to set up (but as a Slackware user, I'm used to that ;)
rpm will install "wrong architecture" packages if you override its ARCH check - that's how I got started (because Slackware doesn't actually do x86_64 yet).
Installing your 32-bit system should be straightforward, as long as you have or can make a spare partition (an extra HDD solves this really quickly).
THere may be a solution involving "CC='gcc -mi686'" and hacking config.sub, but I've never tried doing it that way.
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 23706569
I may have found a less painful workaround.
config.sub is just an OS verifier. The version in OpenPBS_2_3_16 is exceptionally old - 1996. I replaced this with a new version and configure ran to completion.

I located a build.sub with a timestamp in 2008 (iptables-1.4.1.1) but anuthing newer than say 2002 should do.
If you have a number of source packages, you could do what I did:

locate config.sub|xargs grep timestamp|grep 2008

If that turns up nothing, try 2007, and so on.

Unfortunately when I tried "make" it failed:

make[4]: Entering directory `/tmp/OpenPBS_2_3_16/src/lib/Libattr'
make[4]: *** No rule to make target `<built-in>', needed by `attr_atomic.o'.  Stop.

Possibly you won't encounter that - it may be related to gcc version. Or you may be able to hack that Makefile not to require built-in and find it still runs to completion.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:imagineer12
ID: 23708518
Firstly i thank u all for pouring in your answers..
I could install OpenPBS by adding my machine architecture in ../buildutils/config.sub @ line 615 (in my case)

pentiumpro-* | p6-* | x86_64-*)
            basic_machine=i686-`echo $basic_machine | sed 's/^[^-]*-//'`
            ;;
with this is could successfully configure it. But when i try to make it i received  an error about node attributes i solved it by

src/include/pbs_nodes.h:
-extern struct attribute_def  node_attr_def[]; /* node attributes defs */
+extern struct attribute_def  *node_attr_def[]; /* node attributes defs */
(http://www.unipg.it/carlo/OpenPBS_Debian.html)

after installing it successfully,  another error appears when i run it:
qsub:supporting protocol failure.

now this where i'm stuck..
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 23709652
You had better luck than I in building! Even if I could build it, I wouldn't want to install it because I have no use for it ATM.
The message "Supporting protocol failure" corresponds to the DIS_PROTO error that the package defines. This error is raised in a number of places. The error is converted to the text string by accessing the dis_emsg array.

I was thinking that since qsub is a command, you could run gdb on it (having made sure you have compiled for debugging; -g at a minimum and -g3 -ggdb for best results). But even if you did that, it's not really clear to me how you'd proceed. Is this message output to stderr (appears on console) or was it in the log file? Many instances of output seem to go to the log file (which I suppose might be stderr) but maybe there is a possibility to narrow down candidate instances of outputting the error.

It could well be that your problem is actually in your environment somewhere (not your environment as output by env, but more generally). Debugging will highlight what is the problem but could be tedious. Is there anything in the documentation? Can you find this error  on Google?
0
 
LVL 29

Expert Comment

by:Michael Worsham
ID: 23712362
I'm just curious, but what OS platform are you using? I found there are several RPM builds of the OpenPBS for x64 and wondered why just not use one of them?

Also, when I was reading on one of the RPM builds of the software, this caught my eye:

* Fri Jun 17 2005 - meissner@suse.de
  - fixed problem on 64bit platforms.

So if you are using the pre-2005 release, most likely you still have this problem.

Reference:
http://rpmfind.net/linux/RPM/suse/updates/10.0-OSS/i386/rpm/ppc/OpenPBS-2.3.16-611.2.ppc.html
0
 

Author Comment

by:imagineer12
ID: 23713415
@mwecomputers:
I use RHEL5
I tried installing those rpm's and the one you cited, but the problem is:
rpm's require tcl/tk 8.0 and i have 8.xx (8.04 if i'm not wrong)
0
 
LVL 29

Accepted Solution

by:
Michael Worsham earned 2000 total points
ID: 23713867
Did you try downloading the rpm file then running 'yum localinstall <rpmfile>'?

Yum will attempt to resolve the dependencies.

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Q&A with Course Creator, Mark Lassoff, on the importance of HTML5 in the career of a modern-day developer.
I have written articles previously comparing SARDU and YUMI.  I also included a couple of lines about Easy2boot (easy2boot.com).  I have now been using, and enjoying easy2boot as my sole multiboot utility for some years and realize that it deserves …
In this fifth video of the Xpdf series, we discuss and demonstrate the PDFdetach utility, which is able to list and, more importantly, extract attachments that are embedded in PDF files. It does this via a command line interface, making it suitable …
Introduction to Processes
Suggested Courses

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question