Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 469
  • Last Modified:

Dreamweaver CS4 Data Source will not refresh

I am having the strangest problem with Dreamweaver CS4 where all of sudden it will not refresh the tables of a Data Source on one of my sites. It still functions properly on other defined sites, but on the one in particular, it has stopped refreshing.

Basically, I found this problem when I added a couple of tables and then while using Adobe Dreamweaver Developer Toolbox, could get them to show up. Naturally, I deleted the database persistence caches first (which normally resolves such an issue) and that still didn't work.

So then I tried just refreshing from the datasource dialog area in dreamweaver and that didn't work.

Now, here's where it gets really strange - I decided (for kicks and giggles) to back up my data to a dump and completely delete the database off of my testing environment. After doing that, Dreamweaver still shows the exact same data it did before. Somehow, it is caching or reading that data from somewhere even when the database has been removed!

Any thoughts? (By the way, I am on a MacBook Pro with Leopard 10.5.6 - intel; my testing server environment is MAMP and I'm working on a PHP site)

Thanks,

Brian
0
anaheimDuck
Asked:
anaheimDuck
  • 2
1 Solution
 
Jason C. LevineNo oneCommented:
Hi anaheimDuck,

>> Basically, I found this problem when I added a couple of tables and then while using Adobe Dreamweaver
>> Developer Toolbox

The toolkit works with CS4 now?  I was under the impression they had not upgraded it.

Anyway, try doing Site | Advanced | Remove Connection Scripts and then Site | Advanced | Recreate Connection Scripts
0
 
anaheimDuckAuthor Commented:
Hi Jason,

Yeah Adobe released a beta cycle for Toolkit that was compatible for CS4 back in early January... with not really any bugs, I believe that after several of us tested, it has now become the official 1.01 version that is downloadable. So, it was great to have all my tools available to me again but now this problem.

I tried your suggestion but still no luck. I think maybe something else is going on because it didn't even remove the connection from the datasources. While I hate do an entire reinstall, I might be on to that soon.
0
 
Jason C. LevineNo oneCommented:
anaheimDuck,

Can you be more specific than "the issue was resolved another way"

I'm curious to know how you solved it.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now