[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 560
  • Last Modified:

Configuration of Badmail Folder on new SMTP servers not working - Exchange 2003

We recently replaced our Exchange 2003 SMTP server with 2 new ones that are also Front End servers.  I have configured the "badmail folder" with the 2 registry entries per the Microsoft Instructions as follows:
____________________
To configure the new MaxBadMailFolderSize and BadMailSyncPeriod registry entries, follow these steps.
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
Click Start, click Run, type regedit in the Open box, and then click OK.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSVC
On the Edit menu, point to New, click Key, type Queuing, and then press ENTER.
Double-click Queuing.
On the Edit menu, point to New, and then click DWORD Value.
Type MaxBadMailFolderSize, and then press ENTER.
Double-click MaxBadMailFolderSize, type the maximum size of the Badmail folder in KB, click Decimal, and then click OK.
On the Edit menu, point to New, and then click DWORD Value.
Type BadMailSyncPeriod, and then press ENTER.
Double-click BadMailSyncPeriod, type the time in minutes until the local cache of the Badmail folder is synchronized with the Badmail folder in Exchange, click Decimal, and then click OK.
Close Registry Editor.
Restart the SMTP service. To do this, follow these steps:
Click Start, point to Programs, point to Administrative Tools, and then click Services.
Right-click SMTP Service, and then click Restart.
________________
I have tried setting the registry entries to both:

BadMailSyncPeriod 0x0000000f (15)
MaxBadMailFolderSize 0x00002800 (10240)

and

(This is how they were set up on the original SMTP server)
BadMailSyncPeriod (0x00000030 (48)
MaxBadMailFolderSize 0xffffffff (4294967295)

I am not seeing any messages in the Badmail folder appear at all since the cut over to the new SMPT servers.  We normally have 10 messages or so per day.  I have restarted the SMTP server on both SMTP servers as well after each registry change.

Is there anything else I need to do to get our normal badmail messages to start appearing in the badmail folder besides the two registry entries and restarting the SMTP service?

Thank you very much for you help with this issue.

badmailregsetting.doc
0
bayvalleyfoods
Asked:
bayvalleyfoods
  • 2
  • 2
1 Solution
 
Syedm2Commented:
Restart IIS admin service.( we are looking for routing engine to restart)
0
 
bayvalleyfoodsAuthor Commented:
I will restart the IIS admin service on both new SMTP servers tonight and let you know if that worked.  Thank you SO much for the suggestion!
0
 
Syedm2Commented:
np.
0
 
bayvalleyfoodsAuthor Commented:
Thank you so much, Syedm2.  Badmail started coming in as soon as I restarted the IIS admin service.  Your very quick and accurate solution was very much appreciated!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now