yum httpd-devel installation problem

Hello,

 i need to install httpd-devel but when i run the yum install httpd-devel command i get that error msg:

Error: Missing Dependency: libpq.so.4 is needed by package psa
Error: Missing Dependency: libpq.so.4 is needed by package sw-engine


how can i fix tha issue? im a total newbie for linux so plz be clear. Centos 5.1

thanks
jolly_jokerAsked:
Who is Participating?
 
fosiul01Connect With a Mentor Commented:
hi try by addign this 2 extra repo

 wget -c  http://apt.sw.be/redhat/el5/en/i386/rpmforge/RPMS/rpmforge-release-0.3.6-1.el5.rf.i386.rpm

then rpm -Uvh rpm ....    [ install the repo]

wget -c http://download.fedora.redhat.com/pub/epel/4/i386/epel-release-4-9.noarch.rpm

same here install the repo

then try

it might work..

or you might have to isntall those dependency  by rpm
0
 
woolmilkporcCommented:
How about
yum install libpq ?
wmp
 
0
 
jolly_jokerAuthor Commented:
installed these repos but it didnt solve the problem.

and

yum install libpq

turns:  No package libpq available.


is there any othe way to install that dependency or just to skip it and go on installation?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
woolmilkporcConnect With a Mentor Commented:
Seems to be related to PostgreSQL
Look here (don't mind the title!) -
http://www.postgresonline.com/journal/index.php?/archives/45-An-Almost-Idiots-Guide-to-PostgreSQL-YUM.html
wmp
 
0
 
fosiul01Connect With a Mentor Commented:
i have installed in my mechien httpd-devl with those repo it didnto complain...

you can read the article woolmikporc said.

also
what the output of :

locate libpq.so.4



may be you can install the rpm for libpq.so.4  from bellow :

http://rpmfind.net/linux/rpm2html/search.php?query=libpq.so.4
0
 
jolly_jokerAuthor Commented:
needed to install yum protect plugin. it was a repo problem some repos were downloading wrong versions of rpms.. provided links and info guieded me to find solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.