Error opening public folders in exchange - because SSL certificates used external domain name

When I try to open public folders in Exchange System Manager I get the error:  token supplied to the functinon is invalid - ID no 80090308.  I know it is because the SSL certificate is using the external domain name and not the internal name.  I've seen solutions about turning off the SSL but that is out of the question. I need to keep our secure email access/folder access.  Can someone tell me how to correct this problem.  I need to delete some old spam folders that a previously used package had created.  
cindyfillerAsked:
Who is Participating?
 
MesthaCommented:
Port 443 is something to check on your firewall. You cannot stop Exchange using port 80 internally, it makes internal calls on http://server/ using port 80.

The KB article is exactly what you need to do. If you find it doesn't work afterwards despite that, restart the web services on the server. (IIS, Web Publishing, HTTPS etc).

-M
0
 
MesthaCommented:
You have made a common error.
You are confusing turning off require SSL with turning off SSL completely.
There is no way to turn off SSL. If you don't want SSL on a server then you have to remove the certificate.

What you need to do is remove the setting that requires SSL on the virtual directory. If you only have port 443 open to the internet then you can remove the require SSL option from the entire site. SSL will still work correctly.

-M
0
 
cindyfillerAuthor Commented:
I figured I was confused.  Two followup questions - how do I tell if I only have port 443 open?  And I assume the steps in the following article will fix the problem:  http://support.microsoft.com/kb/324345
0
 
cindyfillerAuthor Commented:
I'm in IIS and for default web site, I see port 80 and ssl port 443.  I see other ports for administration and sharepoint administration.  I assume you wanted to know of some other ssl port was open?  Was this the only place I need to check?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.