?
Solved

Openmotif binaries...

Posted on 2009-02-20
8
Medium Priority
?
1,361 Views
Last Modified: 2012-05-06
Experts,
I tried to install legato backup client, version 7.4.3.1_x86_64.rpm on my RHEL server 5.2, but got problems with some dependencies.
It needs openmotif.
I then downloaded openmotif22.2.2.2.3-18 from RH network as .rpm and installed the package with "rpm -ivh packagename".
After this I tried to install lgtoclnt again, but the same dependencies still exists.

The "rpm -qa | grep motif" command reports that it's installed.
Also "locate motif" reports that some release notes are installed under /usr/share/doc/openmotif22.2.2.3-18, but I can't find any libs or binaries.

What is wrong? Have I installed the wrong package?
0
Comment
Question by:tietohacker
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 23

Expert Comment

by:Maciej S
ID: 23693933
Can you provide full output of your rpm -i legato_file.rpm command?
From where did you download this legato rpm? The same question for openmotif rpm. Write here full filenames of these rpms.
Also, paste here output of "uname -a" command.
0
 
LVL 27

Expert Comment

by:Nopius
ID: 23699012
> The "rpm -qa | grep motif" command reports that it's installed.

It may be different (than required) version or not x64.

> I tried to install legato backup client, version 7.4.3.1_x86_64.rpm on my RHEL server 5.2, but got problems with some dependencies.

Please copy-paste here the exact output from the 'rpm' command while installing.
0
 
LVL 27

Expert Comment

by:Nopius
ID: 23699017
oklit, sorry, this post was opened in my browser for several hours and I missed your response.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:tietohacker
ID: 23710303
[root@guru ~]# uname -a
Linux guru 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:15 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@guru tmp]# rpm -ivh lgtoclnt-7.4.3-1.x86_64.rpm
error: Failed dependencies:
        openmotif is needed by lgtoclnt-7.4.3-1.x86_64
[root@guru tmp]#


The packages I have installd is:

openmotif22-2.2.3-18.x86_64.rpm
(Don't remember where I found this one)

xorg-x11-deprecated-libs-6.8.2-1.EL.52.x86_64.rpm
(Downloaded from RHN, xorg-x11-deprecated-libs-6.8.2-1.EL.52.x86_64  Red Hat Enterprise Linux ES (v. 4 for AMD64/Intel EM64T)  )

How can I check what .rpm that is the correct one for my system? Any good rule that I can follow?

/Mega newbie
0
 
LVL 23

Accepted Solution

by:
Maciej S earned 750 total points
ID: 23710624
Go to RHN and download openmotif from there. You may also need openmotif-devel (I'm not completely sure).
I can't give you direct links, because I don't have access to RHN.
0
 
LVL 16

Expert Comment

by:ai_ja_nai
ID: 23711094
>xorg-x11-deprecated-libs-6.8.2-1.EL.52.x86_64.rpm
if it's deprecated, why did you installed?

>lgtoclnt-7.4.3-1.x86_64
I'd have a look at this, either. Is it installed?
0
 

Author Comment

by:tietohacker
ID: 23719142
I will try to install the openmotif package (from RHN) instead.

ai_ja_nai: I installed deprecated version of xorg-X11 because the legato-clnt package also ased for libXp.so.6 and as I understod it is included in the deprecated version of xorg-X11.

I will try your suggested solutions and come back...

/T
0
 

Author Comment

by:tietohacker
ID: 23721364
Hi again,

I installed openmotif from RHN instead but that one needed xorg-X11-lib, so I had to install that one to.
After this I was able to install lgtoclnt... YES, Case closed!

/T
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Often times it's very very easy to extend a volume on a Linux instance in AWS, but impossible to shrink it. I wanted to contribute to the experts-exchange community a way of providing a procedure that works on an AWS instance. It can also be used on…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month16 days, 3 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question