• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 578
  • Last Modified:

RPC Server Error

I am having an issue using Windows Remote Desktop feature that has stumped both Dell technicians and my partners here.  We have spent numerous hours making registry changes, applying updates and reconfiguring our NIC's (as well as uninstalling completely and then reinstalling) to no avail.  This is on  Windows Server 2003 SP2 servers.  
Here is our issue:

We have a Dell MD3000i storage server that we want to connect 8 server hosts to so that we can utilize the 3000i remote virtual storage feature.  Dell states that we can connect up to 16 hosts virtually to this server and we have successfully connected two with no issues.  When I attempted to map two more virtual drives on two different servers, I was successfull BUT now I am unable to use Remote Desktop to log in and manage these two newly configured servers.
I have attempted to log on to these servers using different client computers but I get the same message over and over again:  Log on Message:  The system cannot log youon due to the following error:  The RPC server is unavailable.  

I have checked all the services that Remote Desktop depends on to run and I have checked posts on this website that suggests that maybe permissions were set correctly on C: drive and I have also looked at posts that suggested maybe the registry settings for terminal server were not correct.  All appears okay.  We have also compared the iSCSI settings from the servers that work and they are identical.  

I have attached a word doc that shows the errors that are received on the host server whenever we attempt to log on.

One other thing that I forgot to mention was that when I disable the iSCSI connection on the server that I am trying to remote into, it will allow the client to log on with no errors.  

Any help that you can provide would be awesome and much appreciated!

Thanks!
Errors.doc
0
jcconetwork
Asked:
jcconetwork
  • 2
1 Solution
 
jcconetworkAuthor Commented:
One other thing that I forgot to mention was that when I disable the iSCSI connection on the server that I am trying to remote into, it will allow the client to log on with no errors.  
0
 
jcconetworkAuthor Commented:
I just want to say that I appreciate all of the responses to my question.  Anyway, I found the solution on Microsoft's website via a post that I found on this site after a lot of searching:
http://support.microsoft.com/default.aspx/kb/902336 
I ended up using the workaround:

1.       Click Start, click Run, type regedit, and then click OK.
2.       Locate the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
3.       Click Edit, point to New, and then click DWORD Value.
4.       In the New Value #1 box, type IgnoreRegUserConfigErrors, and then press ENTER.
5.       Right-click IgnoreRegUserConfigErrors, and then click Modify.
6.       In the Value data box, type 1, click Decimal, and then click OK.
7.       Quit Registry Editor.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now