• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 961
  • Last Modified:

Slow access to a network drive

We recently got a new model laptop here and our base image is the same as the rest of our computers.  However the issue we are having is when we log into the Novell client and try to access a network drive, it takes about 5-10 seconds before the list of files and folders is finally displayed.

We are using a DELL Latitude E6500
Windows XP SP3
Novell Client 4.91 SP5
Novell ZenWorks 7 SP1

I have already tried re-imaging the computer, I have updated the NIC driver to it's latest version.

I am looking for any assistance anyone may be able to provide.
0
jfountaine
Asked:
jfountaine
  • 8
  • 7
  • 7
  • +4
1 Solution
 
ShineOnCommented:
That sounds a lot like the typical slowdown due to Windows Explorer searching the whole network for shared folders and printers.

I'll bet the second time you open Windows Explorer it's right there, but if you wait 15 min to 1/2 hour it will be slow again.  That's because of the UNC path filter feature of the Novell client - after the first go-around, the Novell client knows what Windows is looking for and automatically redirects requests to the Windows requester anything that is truly on Windows, and any NetWare resources never get to the Windows requester.  That cache does clear itself after a while, which is why it can be slow again on a subsequent attempt.

I don't know why it's only happening on this one computer, but one thing you can do that's likely to have an immediate impact would be (and this is a per-user-profile thing) - go into Windows Explorer, Tools, Folder Options, View tab and un-check "Automatically search for network folders and printers."  Apply, then click "apply to all folders."

While you're in there, turn off the "hide known extensions" so people know when they're opening "mynewtrojan.txt.exe" ;)
0
 
rionrocCommented:
Hello

Try to uninstall and delete the updated NIC driver files.  Restart and Reinstall the Old driver for the NIC.



Great is our GOD.
:)
rionroc
0
 
wantabe2Commented:
Since it is a new computer, is it trying to download install updates...maybe even service pack 3 while your trying to use it... That will slow it down & if its a wireless connection, it will be even slower.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
jfountaineAuthor Commented:
Tried first two response and still no dice.
Wantabe2:  All updates are installed on this computer already.  Nothing left to update.  This is why this is so puzzling.
0
 
wantabe2Commented:
Is it wired or wireless? If wired into a managed switch, check the switch ports to make sure its not half duplex at 10mb. The ports should be either AUTO or 100 Full duplex. Also, makes sure you don't have Windows firewall on if your behind an additional firewall. ANd make sure only one anti-virus is installed. New computers usually have a 30 -60 day evaluation copy installed.
0
 
jfountaineAuthor Commented:
Wired computer, and switch is set to auto and the computer is connected at 1gbps.  The Windows Firewall is off and there is only one antivirus installed because it is a corporate image, not just a tweaked basic factory windows install with all of their junk loaded.
0
 
wantabe2Commented:
Is there any program doing file indexing?
0
 
ShineOnCommented:
Try uninstalling the Novell client and reinstalling it.  I wonder if the provider order got screwed up.

Barring that, there are tweaks for adding your Windows servers to the "bad server name" cache so the Novell client never intercepts those requests and passes them directly to the Windows redirector.  If you want to try that, there are instructions and discussion about that here on E-E.  A quick search should turn it up for you.  Look for "bad server name cache"
0
 
rionrocCommented:
OK,

Try this:
Go to your device properties, select the (Network Adapters)Ethernet Device properties, go to advance tab menu, adjust received and transmit buffer size to 128 only.   Configure it also in the remote computer(for testing).

test it.

Great is our GOD.
:)
rionroc
0
 
ShineOnCommented:
?

Why mess around with the communications buffers?  Especially on any of the servers this computer is connecting to?

Anyway, jfountaine,  you mention it's a new model laptop and you laid your base image on it.

1)  What is the image?  ZEN, Ghost, G4U, Partimage, something else?  Since you have Zen 7.1 I'll assume ZEN.

2)  What is the model of the new laptop (E6500?) and what is the model of the base image?

3)  Are you installing ZEN to the clean laptop to get an image-safe area before loading the base image?

Just for kicks, you may want to run the resource CD you got with the new laptop anyway, to make sure you have all of your drivers in sync with what Dell expects you to have for that model.  Be sure to run them in the proper order.  Dell laptops can be flaky if you update certain drivers before others.
0
 
rionrocCommented:
Hello

Some Network Buffers delays network connections, if is not the solution, then lets wait and see authors comment.

[And Also], check shared folders to the remote machine, it maybe left or deleted when the sharing is still on.
You can check-in using regedit: type at run window: regedit
Go to:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Lanmanserver\Shares

Check it, if shared folder is shared truly.  If is not existing, delete the value name.


Great is our GOD.
:)
rionroc
0
 
rionrocCommented:
And to see if there are still existing shared name, press Control-F, then type the shared name not existing.
or
You can also continue checking at:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanserver\Shares

Ops!
                                                          V
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Lanmanserver\Shares
                                                          V
                                                  Change to: CurrentControlSet001


Great is our GOD.
:)
rionroc
0
 
ShineOnCommented:
That last might make sense - at least as far as deleted shares is concerned.

If this is a mixed network, and the image hasn't been refreshed lately, it could have a "stale" share (or more,) and this new laptop is lagging on Windows Exploder to timeout while it is looking for it/them and can't find it/them.

The same could be said for network printers, or any other resource the computer is expecting to find when Explorer is launched.
0
 
jfountaineAuthor Commented:
Alright, Sorry for the delayed response. I don't have a spot in the Ethernet Driver to adjust the trasmit buffers.  Also I am using a Zen image, and the base was created by installing a fresh copy of Windows XP on the exact model laptop, so there would be no issues with drivers from other computers, printers installed, etc.  I also checked those registry keys and they all come up clean.  There are no entries in there.  What makes this really puzzling is that we have about 6 of these in the building and only 2 are having this issue.
0
 
rionrocCommented:
Hello

Try to rename all workgroups to other name. eq.  groupworks, all of them rename it.

Restart them twice.

:)
rionroc
0
 
jfountaineAuthor Commented:
We are not on a workgroup.  The computer is joined to our domain.
0
 
alextoftCommented:
Have you considered sniffing the LAN connection with WireShark in order to see what's going on? It sounds like a name resolution timeout of some description.

PS. I'm not being funny, but why is rionroc raving on about his god all the time? This is a technical forum.
0
 
rionrocCommented:
Hey Guru alextoft, don't mind.  Its only my signature.
0
 
ShineOnCommented:
I see his point though.  This is a technical forum.  E-E has zones specifically for non-technical topics including religion and politics.

It's not proper to inject religion into the technical topic zones, even as a "signature" line.
0
 
rionrocCommented:
Vee-Mode say's:
I will not respond to any future posts you make with your religious statement imbedded.

And either you may not respond.
So leaved it.  Never mind my signature.  Its not to you, its between me and GOD.
And lets stop arguing, this is a technical forum.

OK? Peace!
0
 
rionrocCommented:
To jfountaine,

O, I remember its a Novell client.

Ops! have you check the cables?  Try to switch cables from good computer to bad computer.  Or you can make one for new cable connection.  And try also to switch port.

If cables don't solve, try to check Novel client configurations on bad computer, maybe there are some entries are invalid.

I have no dough in your Laptop [if] some computers you've tried too the same things happen.  And [if] only the Laptop connects and delays, meaning, the connection from your Laptop has the problem.

Don't get confuse, this is troubleshooting.  And were just trying to help.


Great is our GOD  (Without Him we can't ..., to GOD be the Glory).
:)
rionroc
0
 
jfountaineAuthor Commented:
I actually tried taking the laptop to the switch directly and tried 2 different cables, 3 different switches and still the lag.  I did also verify the Novell Client settings to a T with a working computer and they all match.  That is why I am out here trying to grasp at any lingering straws because this is so odd.
0
 
ShineOnCommented:
You did do the "image safe" thing before laying down the image, right?

I kinda think it might be a registry thing - damifino where though...

Have you tried pre-populating the bad name cache with your Windows server names?  If the lag is at the initial launch of Windows Explorer but isn't there on the next launch of Windows Explorer, then prepopulating the bad name cache might do the trick.
0
 
jfountaineAuthor Commented:
I did clear image safe data before uploading the image to the server therefore your answer is yes.

The lag is not actually when opening Windows explorer.  I can open explorer, open the C drive, CD drive, Jump drive (if inserted).  It is when I try to open a network drive that the short lag occurs.
0
 
Ghost96Commented:
This will likely sound stupid, but if you use a different file manager (like A43 or Total Commander) do you experience the same lag when opening the networked drives?

In most environments I find that it'll open instantly using a different manager.  That's not a solution, but I am curious if it displays a major improvement or not.
0
 
jfountaineAuthor Commented:
Just to update everyone..We think we found a solution to this problem:

Go into Network Connections and click Advanced --> Advanced Settings
Click the Tab: Provider Order
In the Network Providers section, make sure NetWare Services is at the top of the list.  Reboot
Issue should be resolved.
0
 
deroodeCommented:
I had monitored this question, because of the same problem, and also found the same solution.. Albeit that now sometimes access to Netware volumes is slow, but not as bad as the other way around...

Cheers with your self-found solution!
0
 
ShineOnCommented:
I mentioned provider order back in my post # ID:23698168.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 8
  • 7
  • 7
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now