replication server not hibernating !

Dear Replication Experts,
Am trying to purge inbound quaue, but am not able to put repserver in hibernate mode,
when i do, am getting below error.  I know I can start in single user mode, but why
this error.

Also I see some missing subscriptions in my SQM, though
I dont see any in my rs_subscriptions,  How do i clear it..   I tried purgin  115,1 & 115,0
in single user mode, but it didnt help.

Appreciate your inputs..

1> sysadmin hibernate_on
2> go
Msg 14102, Level 12, State 0:
Server 'REPTEST':
Cannot start hibernation mode because configuration activity is currently running in background threads.
1>

2. 1> admin who, sqm
2> go
 Spid State                Info                                     Duplicates  Writes      Reads       Bytes       B Writes    B Filled    B Reads     B Cache     Save_Int:Seg                    First Seg.Block                 Last Seg.Block                  Next Read                       Readers     Truncs
 ---- -------------------- ---------------------------------------- ----------- ----------- ----------- ----------- ----------- ----------- ----------- ----------- ------------------------------- ------------------------------- ------------------------------- ------------------------------- ----------- -----------
    28 Awaiting Message     115:-2147483538 <MISSING SUBSCRIPTION>             0           0           0           0           0           0           0           0 strict:0                        0.1                             0.1                             0.1.0                                     0           1
     30 Awaiting Message     136:-2147483521 <MISSING SUBSCRIPTION>             0           0           0           0           0           0           0           0 strict:0                        0.1                             0.1                             0.1.0                                     0           1



Bola20705Asked:
Who is Participating?
 
alpmoonConnect With a Mentor Commented:
Sybase documents say:
"You cannot start hibernation mode while a route is being created or dropped, a subscription is being materialized or de-materialized, or a stand-by connection is being created or switched."

Have you checked rs_subscriptions in both RSSD databases?

select * from rs_subscriptions where materializing > 0 or dematerializing > 0

If you find anything you should drop that subscription.

Also you can execute below command  to drop the materialization queue if any exists:
sysadmin drop_queue, q_number, q_type
0
All Courses

From novice to tech pro — start learning today.