• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 781
  • Last Modified:

Error connecting to an instance of SQL Server

I have a WSS database on SQL Server 2005. Instanace is MICROSOFT#SSEE. When trying to connect to the instance with Management Studio, I get the follow error.

A network-related or instance-specific error occurred while establishing a connection to sql server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (Provider: SQL Network Interfaces, error 26 - Error locating server/instance specified)

The instance is there. The instance is configured for remote connections from looking at the Surface Area Configuration. SQL Server 2000 is also installed on the server.

Do you have any suggestions onwhy I can not connect to this instance?

Thank you.
0
gtrapp
Asked:
gtrapp
  • 4
  • 3
2 Solutions
 
ralmadaCommented:
Hello gtrapp,

Make sure SQL Browser on the remote server is be enabled and UDP port 1434 should be put into exception if firewall presents.

Regards,

ralmada
0
 
ralmadaCommented:
Also, If you install SQL Server on a computer that is also running SQL Server 2000 or MSDE, they must be upgraded to SP3 or later. Versions earlier than SP3 do not properly share port 1434 and might not make your SQL Server instances available to requesting client applications. Although you can change the startup order so that the SQL Server Browser service starts before SQL Server 2000 or MSDE, the recommended resolution is to update all older versions of SQL Server to the latest service pack.
0
 
gtrappAuthor Commented:
How do I tell if I have SP3? How do I change the startup order for the instances?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
gtrappAuthor Commented:
I have versions 8.0.2050, 8.0.760, and 9.0.4035 installed.
0
 
gtrappAuthor Commented:
MSDE and Express Editions are installed. SP2 is installed.
0
 
ralmadaCommented:
Actually I was thinking, before doing that. Can you verify if you have a firewall. If so create an exception on port TCP 1433. If that doesn't work then start SQL Browser and add port UDP 1434 as an exception in your firewall.


So you have two instances of SQL 2000?
8.0.2050 is very old.
8.0.760 is SQL 2000 SP3

0
 
aibusinesssolutionsCommented:
Look in the SQL Server Configuration Manager, under Network Configuration.  Make sure "Hide Instance" is set to No.
0
 
gtrappAuthor Commented:
I checked the Hide Instance flag and it was set to Yes to hide. Changed it to no and the instanance showed up.

I will also look into upgrading.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now