• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4731
  • Last Modified:

How I Can check or increase the UDP or TCP buffer size, and what size is recommended ?


    I have many DOS console executable programs running sumultaneously in a PC with Windows XP Proffesionnal, in a automatized process, scheduled every 10 minutes. In the process I use the ftp service, to transfer data.
For months (almost a year) all the things works OK., but suddenly I have intermittent ftp service, but almost
all the time the programs try to use the ftp returns with the message: ftp bind: no  buffer space supported.

  I read the related article in this forum, where they related to winsock allocated memory, and one possible solution
is to increase the buffer size for UDP or TCP. My question is how I can increase this buffer size ?
0
ensmex
Asked:
ensmex
  • 4
  • 4
  • 2
  • +1
2 Solutions
 
paullamhkgCommented:
Try the following regkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Afd\Parameters \DefaultReceiveWindow (REG_DWORD) = 16384 (decimal)

0
 
paullamhkgCommented:
Microsoft Windows supports a fast I/O path which is utilized when sending "small" datagrams. The default setting for what is considered a small datagram is 1024 bytes; increasing this value to match your network MTU (normally 1500) can significantly improve network performance.

To adjust this parameter:

Run Registry Editor (regedit)
Locate the following registry key
HKLM\System\CurrentControlSet\Services\AFD\Parameters
Add the following new DWORD value
Name: FastSendDatagramThreshold
Value: 1500 (decimal)
Reboot

The above from http://wiki.tangosol.com/display/COH33UG/Performance+Tuning
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
giltjrCommented:
If you are using the MS supplied ftp command line client it has a default buffer size of 4K.  You need to specify -w ##### to specify a different buffer size:

   ftp -w 32120

is an example of setting the buffer size to 32120.
0
 
ensmexAuthor Commented:

   I increase the buffer size in a variety of ways (as was said by the experts comments), but I have
the same result:   ftp: bind: no buffer space supported.

 One clue more is that when I re-start the system, the first time I can use the FTP, for a while,
and sudddenly freeze. If I kill this window and open another new command window, and I enter
ftp with some address, the result is the above message.

  After a reboot process,  (some 10-20 minutes), the FTP fails almost all the times, whenever I used or not before the ftp command once the reboot process is completed.
0
 
giltjrCommented:
Wow, searching on EE is amazing.  I found this problem from a couple of years ago.  It eems that this problem has nothing to do with the ftp data buffer size, but with the amount of memo available on the system.

     http://www.experts-exchange.com/Operating_Systems/Q_20561572.html

0
 
ensmexAuthor Commented:

  The memory in the system is 1 Gb, and the OS is Windows XP Professional SPK 2. I can use all the
programs in a normal way in  the PC, and I can get a fast answer, and 'normal' behaviour in almost all of them. In reality there are three windows programs running all the time......and a variety of small DOS-console programs builded with Visual C. This small programs together with Windows XP Task Scheduller, makes possible send out, via ftp ,the captured to my office in an automatically way.
 
  The system is designed to  monitor weather and oceanographic sensors coupled in a sea structure. I can reach the system via remote using VPN. The system is collecting data evey 10 minutes,
and send out, via ftp, the last group of data captured, to a server in my office. Every time Ithe system sends out the volume of data , is less than 100 Kb.

  For almost a year, the system works O.K., and all the things in the PC are O.K., ..... but one day i get
the FTP BIND BUFFER message. Intermmitent with  a god behaviour of FTP, in average once a day and for a few minutes. So 95% percent the programs use the FTP, returns with FTP: BIND message,
and 5% of the times works O.K.

    It is possible that some external connection is failing, and there is the cause of the problem ???,
or definitivly is related to a system problem ????
0
 
giltjrCommented:
In this sense memory does not mean RAM, it referring to specify "type" of memory used for specify types of buffers.

Based on the other post it could be due to too many programs running at the same time that attempt to use this same memory/buffer pool.

Are you getting entries in your event log?
0
 
crokeefe28Commented:
Pretty dumb question, but have you rebooted yet to clear the memory?
0
 
ensmexAuthor Commented:

      I tried all the sugerences, with a lot of reboots, but the results all the time were the same.
So, my last chance was to recover the system to the last backup I made with Acronis.
This was October 2007.

      After the recovering the ftp script programs are working well.
   
0
 
giltjrCommented:
Well, now all you need to do is figure out what changes you made over the 16 months and you will find what caused the problem.  :)

Well I guess you now know why you should back up often.

But seriously, I would focus on any software updates/changes you made just prior to the failures.  This includes any patches (Windows automated updates) that you may have put on to anything you have as well as any new software you may have installed.  This includes upgrades to non-IE browsers (like firefox).
0
 
ensmexAuthor Commented:
No solution.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now