• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1133
  • Last Modified:

How do I publish web pages to IIS V5.1 on Windows XP Pro using FrontPage Server Extension?

I have tried many possible ways for FrontPage Server Extension configuration to enable me to publish my web pages to my localhost server running IIS version 5.1 on Windows XP.

Is there any procedure that can guide to succeed in publishing my web pages to IIS 5.1? I want to publish using FrontPage or SharePoint Services for Remote Server Type under Remote Web Site Properties Window of MS FrontPage 2003
0
tballah
Asked:
tballah
  • 13
  • 11
  • 4
1 Solution
 
James MurrellProduct SpecialistCommented:
0
 
James MurrellProduct SpecialistCommented:
Can you open the web via Frontpage (Page open - http://www.example.com)

0
 
tballahAuthor Commented:
I'm sorry for being late to respond to you as I'm checking this thread today and let me follow the instruction and I will  let you know the result.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
cj_1969Commented:
If you have IIS installed and the server extensions installed then the next question is:
Have you enabled the Front Page Server Extensions on the site?
You have to explicitly enable the extenstions for each site that you want to update this way.

From the first lnkt that cs97jjm3 provided, read the section "To verify that the FrontPage snap-in is installed"
0
 
tballahAuthor Commented:
Yes FrontPage snap-in is installed was already installed.

I use it on Windows XP, the guide from the link is for Windows 2000 and until now I could not succeed in doing so. These are my steps I use on Windows XP

1. From Internet Information Services snap-in I created virtual directory linking to C:\VAS in local hard disk, then I created Server Extensions Web
2. I created one user called webadmin and I added this to "vas Admins" which created when I created "vas" folder in Server Extensions Web step

From FrontPage 2003 I try to publish my web pages to this local server I select:
1. FrontPage for Remote Web server type
2. type http://mycomputer/vas for Remote Web site location
3. After I click OK it prompts me the username and password so I type webadmin as username and webadmin as password but I still cannot log in

However I already added user webadmin from local security settings in "Log on locally" policy

Is there any simple steps to set it up and it will work properly?

My local web server is http://localhost/

I want to set up a virtual server looks like http://localhost/vas

where vas is linked to C:\VAS

From FrontPage I need to publish web pages to this folder C:\VAS using FrontPage Server Extension and the users can normally access to this server from other computers without prompting password.
0
 
cj_1969Commented:
I don't hear mention of the granting of permissions to the new directory on the C drive ...
0
 
tballahAuthor Commented:
What permission should I set to C:\VAS? Was it controlled and set by IIS or FrontPage Server Extension? Kindly advise
0
 
cj_1969Commented:
If you are browsing and running executables then I would grant the following:
system - full control
IUSR_<> - read
IWAM_<> - read/write/exec
vas Admins - full control

See if this gets it working
0
 
tballahAuthor Commented:
I right-click VAS folder under drive C but I could not find any option to set the permission. When I try to publish to local server it always prompts me again and again for the username and password
VAS-Permission.png
Remote-Web-Site-Properties.png
username-passwd-prompt.png
0
 
cj_1969Commented:
Since you do not have a Security permissions tab this tells me your are running FAT32 for your disk formatting so NTFS permissions is not an issue.

based on the configurations that you have posted this leads to me think there is something in the web site configuration that is causing the problem.

Check the properties for your site and see if anonymous access is enabled and using the default account.
Disable Windows Integrated Authentication if this is selected.

Is your code accessing anything on a network server or share?  If it is then this could be what is causing the prompt to appear also.
0
 
tballahAuthor Commented:
My web pages are under "C:\Documents and Settings\Tith Ballah\My Documents\My Web Sites" and I want to use FrontPage Server Extension to transfer these pages to my local web server whose URL is http://localhost/vas which links to C:\VAS. I tried to deselect integrated Windows authentication but the prompt still appears.
C-drive-properties.png
Authentication-Methods.png
0
 
cj_1969Commented:
Are you logged into the workstation with local admin rights?
If you are on an NTFS file system then there should be a security tab to set the access permissions.
The Integrated Windows authentication could be enabled for the FP publishing capabilities.
0
 
James MurrellProduct SpecialistCommented:
untick  Integrated Windows authentication
0
 
James MurrellProduct SpecialistCommented:
guess that worked then
0
 
tballahAuthor Commented:
Now I'm reading Help Topics for Server Extensions Administrator and also follow all your suggestions and I will get back to you the result and I would need some time to do it. I would also have some questions during configuration and revert back to you.
0
 
cj_1969Commented:
cs97jjm3,
They tried that and they still got prompted for credentials, its the last line of the tballah's last (before your comments) post.
0
 
tballahAuthor Commented:
I have repeated all the steps again and again according to Help and your advises but I still cannot succeed. Under my local web server I want to set up a virtual server that will be http://localhost/vas and I did the configurations for FrontPage Server Extension, Local Policy and permission for a user called vasadmin as an admin of the web server http://localhost/vas, belonging to group "VAS Admins" and I still cannot log in when publishing from FrontPage Editor. I also observe that when I click Browse button from Remote Web Site Properties Window then I double-click "localhost" I find nothing and I could not find virtual server i.e. what I expect after double-clicking "localhost" the folder vas which could be http://localhost/vas

Are there other workarounds?
C-drive-VAS-Folder.png
Virtual-Server-FPSE.png
User-Group.png
Users.png
vasadmin-in-group-VAS-Admins.png
Remote-Web-Site-Properties.png
New-Publish-Location.png
New-Publish-Location-Localhost.png
0
 
cj_1969Commented:
I was just looking at all of the images that you posted again ...
Can you double check the c:\vas directory properties ... in the screen shot that you posted it shows the directory as read-only
0
 
tballahAuthor Commented:
Yes it is read-only as shown in pic. above with title "VAS Folder Permission". I try to deselect this read-only option and I apply this permission to this folder and its sub folder after that I check the property of the folder VAS again under drive C it is still read-only.
0
 
cj_1969Commented:
Try creating a new directory, not off the root of C ... i.e. c:\NewInet\VAS
See if you can control the directory permissions here.
Copy the contents of the existing directory and then point the IIS configuration to the new directory and see if thing work.
0
 
tballahAuthor Commented:
I'm following your instruction now and I'd revert back to you tomorrow at most
0
 
tballahAuthor Commented:
With no luck, the folder is still read-only.
0
 
cj_1969Commented:
And you cannot change it?
This does not make sense.  Do you have admin rights on the machine?  Can you go into the properties and take ownership of it.  
If it is not allowing you to change the permissions, this indicates to me that you do not have admin rights on the machine.  If you did, you should be able to over ride and change those permissions.  

Try adding the VAS Admin ID to the local administrator group.
I was taking a closer look at your screen shots and might have come up with the reason this is not working.

The server extensions within your directory are not in the VAS directory that youcreated, they are under the Program Files directory (look at your screen shots).  In order for this to work then ID you are using to publish is going to have to have access to those folders also.

By adding the publishing ID to local admin group this will bypass all other security restrictions ... if this works then you have a permissions issue with the account you created and it cannot access the resources that it needs to access the server extensions.

I still question if you are logged into the machine with an ID with local admin rights.  You are on an NTFS volume and you should be able to see the security permissions of the folder and over ride that read-only attribute.
0
 
tballahAuthor Commented:
I'm logged in as user "Tith Ballah" with local admin rights. This user belongs to Administrators group. Actually this user is automatically logged in when booting to Windows. DefaultPassword value under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon is blank.
User-Admin.png
0
 
tballahAuthor Commented:
The reason why Security tab cannot be found when viewing property of VAS folder because "Use simple file sharing (Recommended)" option under Folder Options was selected. By deselecting this option I can see the Security Tab and now I succeed to log in to http://localhost/vas and I can publish my page to the server. However I have noted that when I publish my page lonely FrontPage does not check dependencies such as images and other objects so when I view, for example, http://localhost/vas/mypage.html the images in the page are missing and cannot be displayed. The case of publishing using FrontPage Server Extention on Windows XP with MS FrontPage 2003 is solved.
Folder-Opt-Sharing.png
0
 
cj_1969Commented:
Do you see the security tab on other directories?
This is just not making sense to me.
The only other thing I can think of is that the FP extensions are over riding the default direectory permissions, locking it down and hence not making the security tab available.  IF this is the case then I would expect that you could over ride the permissions through the IIS Management tool.  See if you can access the directory and permissions through there.  
0
 
cj_1969Commented:
Yeah!
I'm glad you found the problem.
Did you just have to change that option or did you modify permissions after making that change?
0
 
tballahAuthor Commented:
Yes I give full permission to "VAS Admins" web admin group in which a user called vas is. Thank you very much for valuable time to support me to fix this problem. Have a nice weekend
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

  • 13
  • 11
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now