• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 446
  • Last Modified:

Take owenership of hard drive in Linux (Ubuntu) Automount

Hi, I have machine with a solid state drive which is too small to hold my media library.  I added a spinning drive where I'm planning to put my music and other files.  However when I try to access the drive, I get the following error:

You are not privileged to mount the volume 'Data'.

I followed this guide to mount the drive and it worked.  The problem is that I have to do it every time I start the computer.  

http://www.linuxconfig.org/Howto_mount_USB_drive_in_Linux

How do I mount the drive automatically every time at start up?
0
ubuntuguy
Asked:
ubuntuguy
5 Solutions
 
SteveNetwork ManagerCommented:
you need to modify your 'fstab' file to use get it to mount automatically.. (just make sure its always there otherwise you'll get boot errors)..

for ubuntu see something like :
http://ubuntuforums.org/showthread.php?t=283131

or simple google 'ubutnu fstab' for more details..

i dont want to give the exact fstab entry because i dont know what sort of drive / mount type or options you require and any wrong information could make your machine unusable..

0
 
Morne LateganCommented:
If you have the drive in /etc/fstab as described in that howto, you don't have to do the whole howto every time. It should mount automatically if plugged into the machine while booting. If not plugged in at boot time, simply run the mount -a statement to mount. The rest is a once off configuration.

0
 
omarfaridCommented:
have you added it to /etc/fstab file so that it is mounted every time you boot your system? Is the drive always connected to the system or it is connected later after the boot?
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
ubuntuguyAuthor Commented:
The drive is always connected.  No I have not added it to /etc/fstab


0
 
omarfaridCommented:
please add an entry to /etc/fstab as the link suggested
0
 
Maciej SsysadminCommented:
This howto didn't mention one thing.
If your additional disk was formated in windows, you may need to add to /etc/fstab "uid=XXX" option instead of "defaults" option. XXX is your user's id (you can check it issuing "id" command as this user.
If your additional disk was formated in linux it has probably ext2/3 filesystem, and if you want to be able to mount it as user (root can always do this), add "user" option instead of "defaults" option (in /etc/fstab of course). In this case (ext2/3 filesystem) change "vfat" in given  howto to "ext2" or "ext3".
0
 
ubuntuguyAuthor Commented:
I edited the fstab file as the link suggested.  I had no luck.  I don't know if I was doing it wrong, but I followed the directions and it would not automount at start up.  However I was able to automount the file using disk-manager.  It was pretty easy.  Thanks to all for the help.
0
 
ubuntuguyAuthor Commented:
I meant to automount the disk not the file in my comment above.  Also disk-manager is in the repos for anybody having the same problem.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now